View a markdown version of this page

Unterstützte Protokolle und Chiffren zwischen Viewern und CloudFront - Amazon CloudFront

Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.

Unterstützte Protokolle und Chiffren zwischen Viewern und CloudFront

Wenn du HTTPS zwischen Zuschauern und deiner CloudFront Distribution benötigst, musst du eine Sicherheitsrichtlinie wählen, die die folgenden Einstellungen festlegt:

  • Das SSL/TLS Mindestprotokoll, das für die Kommunikation mit Zuschauern CloudFront verwendet wird.

  • Die Chiffren, die zur Verschlüsselung der Kommunikation mit Zuschauern verwendet werden CloudFront können.

Um eine Sicherheitsrichtlinie auszuwählen, geben Sie den anwendbaren Wert für Sicherheitsrichtlinie ( SSL/TLS Mindestversion) an. In der folgenden Tabelle sind die Protokolle und Chiffren aufgeführt, die für jede Sicherheitsrichtlinie verwendet CloudFront werden können.

Ein Viewer muss mindestens eine der unterstützten Chiffren unterstützen, mit denen eine HTTPS-Verbindung hergestellt werden kann. CloudFront CloudFront wählt aus den vom Viewer unterstützten Chiffren eine Chiffre in der aufgeführten Reihenfolge aus. Siehe auch OpenSSL-, s2n- und RFC-Verschlüsselungsnamen.

Sicherheitsrichtlinie
SSLv3 TLSv1 TLSv1_2016 TLSv1.1_2016 TLSv1.2_2018 TLSv1.2_2019 TLSv1.2_2021 TLSv1.2_2025 TLSv1.3_2025
Unterstützte Protokolle SSL/TLS
TLSv1.3 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLSv1.2 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLSv1.1 ♦ ♦ ♦ ♦
TLSv1 ♦ ♦ ♦
SSLv3 ♦
Unterstützte TLSv1.3 Chiffren
TLS_AES_128_GCM_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_AES_256_GCM_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_CHACHA20_POLY1305_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
Unterstützte ECDSA-Verschlüsselungen
ECDHE-ECDSA-AES128-GCM-SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES128-SHA256 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES128-SHA ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES256-GCM-SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-CHACHA20-POLY1305 ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES256-SHA384 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES256-SHA ♦ ♦ ♦ ♦
Unterstützte RSA-Verschlüsselungen
ECDHE-RSA-AES128-GCM-SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES128-SHA256 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES128-SHA ♦ ♦ ♦ ♦
ECDHE-RSA-AES256-GCM-SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-CHACHA20-POLY1305 ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES256-SHA384 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES256-SHA ♦ ♦ ♦ ♦
AES128-GCM-SHA256 ♦ ♦ ♦ ♦ ♦
AES256-GCM-SHA384 ♦ ♦ ♦ ♦ ♦
AES128-SHA256 ♦ ♦ ♦ ♦ ♦
AES256-SHA ♦ ♦ ♦ ♦
AES128-SHA ♦ ♦ ♦ ♦
DES-CBC3-SHA ♦ ♦
RC4-MD5 ♦

OpenSSL-, s2n- und RFC-Verschlüsselungsnamen

OpenSSL und s2n verwenden für Chiffren andere Namen als die TLS-Standards verwenden (RFC 2246, RFC 4346, RFC 5246, und RFC 8446). Die folgende Tabelle ordnet den OpenSSL-Namen und s2n Namen den RFC-Namen für jedes Verschlüsselungsverfahren zu.

CloudFront unterstützt sowohl den klassischen als auch den quantensicheren Schlüsselaustausch. Unterstützt für den klassischen Schlüsselaustausch, der elliptische Kurven verwendet, Folgendes: CloudFront

  • prime256v1

  • X25519

  • secp384r1

Unterstützt für den quantensicheren Schlüsselaustausch Folgendes: CloudFront

Weitere Informationen zu den Zertifikatsanforderungen für finden Sie CloudFront unterAnforderungen für die Verwendung von SSL/TLS Zertifikaten mit CloudFront.

OpenSSL- und s2n-Chiffrenname RFC-Verschlüsselungsname
Unterstützte TLSv1.3 Chiffren
TLS_AES_128_GCM_SHA256 TLS_AES_128_GCM_SHA256
TLS_AES_256_GCM_SHA384 TLS_AES_256_GCM_SHA384
TLS_CHACHA20_POLY1305_SHA256 TLS_CHACHA20_POLY1305_SHA256
Unterstützte ECDSA-Verschlüsselungen
ECDHE-ECDSA-AES128-GCM-SHA256 TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256
ECDHE-ECDSA-AES128-SHA256 TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256
ECDHE-ECDSA-AES128-SHA TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA
ECDHE-ECDSA-AES256-GCM-SHA384 TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384
ECDHE-ECDSA-CHACHA20-POLY1305 TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256
ECDHE-ECDSA-AES256-SHA384 TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384
ECDHE-ECDSA-AES256-SHA TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA
Unterstützte RSA-Verschlüsselungen
ECDHE-RSA-AES128-GCM-SHA256 TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
ECDHE-RSA-AES128-SHA256 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
ECDHE-RSA-AES128-SHA TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA
ECDHE-RSA-AES256-GCM-SHA384 TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
ECDHE-RSA-CHACHA20-POLY1305 TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256
ECDHE-RSA-AES256-SHA384 TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
ECDHE-RSA-AES256-SHA TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
AES128-GCM-SHA256 TLS_RSA_WITH_AES_128_GCM_SHA256
AES256-GCM-SHA384 TLS_RSA_WITH_AES_256_GCM_SHA384
AES128-SHA256 TLS_RSA_WITH_AES_128_CBC_SHA256
AES256-SHA TLS_RSA_WITH_AES_256_CBC_SHA
AES128-SHA TLS_RSA_WITH_AES_128_CBC_SHA
DES-CBC3-SHA TLS_RSA_WITH_3DES_EDE_CBC_SHA
RC4-MD5 TLS_RSA_WITH_RC4_128_MD5

Unterstützte Signaturschemata zwischen Zuschauern und CloudFront

CloudFront unterstützt die folgenden Signaturschemata für Verbindungen zwischen Zuschauern undCloudFront.

Sicherheitsrichtlinie
Signaturschemata SSLv3 TLSv1 TLSv1_2016 TLSv1.1_2016 TLSv1.2_2018 TLSv1.2_2019 TLSv1.2_2021 TLSv1.2_2025 TLSv1.3_2025
TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA224 ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA224 ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SECP256R1_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SECP384R1_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA1 ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA1 ♦ ♦ ♦ ♦