View a markdown version of this page

Überwachen Sie Amazon Data Firehose mithilfe von Protokollen CloudWatch - Amazon Data Firehose

Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.

Überwachen Sie Amazon Data Firehose mithilfe von Protokollen CloudWatch

Amazon Data Firehose ist in Amazon CloudWatch Logs integriert, sodass Sie die spezifischen Fehlerprotokolle einsehen können, wenn der Lambda-Aufruf zur Datentransformation oder Datenübermittlung fehlschlägt. Sie können die Amazon Data Firehose-Fehlerprotokollierung aktivieren, wenn Sie Ihren Firehose-Stream erstellen.

Wenn Sie die Amazon Data Firehose-Fehlerprotokollierung in der Amazon Data Firehose-Konsole aktivieren, werden in Ihrem Namen eine Protokollgruppe und entsprechende Log-Streams für den Firehose-Stream erstellt. Das Format des Loggruppennamens ist/aws/kinesisfirehose/delivery-stream-name, wobei der Name des entsprechenden Firehose-Streams delivery-stream-name ist. DestinationDeliveryist der Log-Stream, der erstellt und verwendet wird, um alle Fehler im Zusammenhang mit der Übermittlung an das primäre Ziel zu protokollieren. Ein weiterer Protokollstream namens BackupDelivery, wird nur erstellt, wenn das S3-Backup für das Ziel aktiviert ist. Welcher Log-Stream S3-Backup-Übermittlungsfehler empfängt, hängt jedoch von der S3BackupMode Einstellung des Firehose-Streams ab. Wenn die S3BackupMode Einstellung lautet AllData (oder Enabled für Amazon Redshift), werden S3-Backup-Lieferfehler im BackupDelivery Log-Stream protokolliert. Wenn die S3BackupMode Einstellung aktiviert istFailedDataOnly, werden S3-Backup-Übermittlungsfehler (z. B.S3.AccessDenied) zusammen mit den Fehlern am primären Ziel im DestinationDelivery Log-Stream protokolliert. Sie werden nicht im BackupDelivery Log-Stream protokolliert. Die FailedDataOnly Einstellung ist für den HTTP-Endpunkt sowie die Splunk- OpenSearch, Snowflake- und Iceberg-Ziele verfügbar.

Wenn Sie beispielsweise einen Firehose-Stream "MyStream" mit Amazon Redshift als Ziel erstellen und die Amazon Data Firehose-Fehlerprotokollierung aktivieren, wird Folgendes in Ihrem Namen erstellt: eine Log-Gruppe mit dem Namen und zwei Log-Streams mit dem Namen und. aws/kinesisfirehose/MyStream DestinationDelivery BackupDelivery In diesem Beispiel wird DestinationDelivery verwendet, um alle Fehler im Zusammenhang mit der Übermittlung an das Amazon-Redshift-Ziel und auch an das S3-Zwischenziel zu protokollieren. BackupDelivery, falls das S3-Backup aktiviert ist, wird verwendet, um alle Fehler im Zusammenhang mit der Lieferung an den S3-Backup-Bucket zu protokollieren.

Nehmen wir als weiteres Beispiel an, Sie erstellen einen Firehose-Stream mit einem HTTP-Endpunkt als Ziel und setzen ihn auf. S3BackupMode FailedDataOnly Fehler für die Datensätze, die nicht zugestellt werden konnten und die auf S3 gesichert wurden (z. B.S3.AccessDenied), werden im DestinationDelivery Log-Stream protokolliert. Sie werden nicht im BackupDelivery Log-Stream protokolliert.

Sie können die Amazon Data Firehose-Fehlerprotokollierung über die AWS CLI, die API oder CloudFormation mithilfe der CloudWatchLoggingOptions Konfiguration aktivieren. Erstellen Sie dazu im Voraus eine Protokollgruppe und einen Protokollstream. Wir empfehlen, diese Protokollgruppe und diesen Protokollstream ausschließlich für die Amazon Data Firehose-Fehlerprotokollierung zu reservieren. Achten Sie außerdem darauf, dass die zugehörige IAM-Richtlinie über die Berechtigung "logs:putLogEvents" verfügt. Weitere Informationen finden Sie unter Steuerung des Zugriffs mit Amazon Data Firehose.

Beachten Sie, dass Amazon Data Firehose nicht garantiert, dass alle Versandfehlerprotokolle an Logs gesendet werden. CloudWatch Unter Umständen, in denen die Rate der Versandfehler hoch ist, erstellt Amazon Data Firehose Stichproben von Versandfehlerprotokollen, bevor sie an CloudWatch Logs gesendet werden.

Für Fehlerprotokolle, die an Logs gesendet werden, wird eine geringe Gebühr erhoben. CloudWatch Weitere Informationen finden Sie unter CloudWatch Amazon-Preise.

Fehler bei der Datenübermittlung

Im Folgenden finden Sie eine Liste mit Fehlercodes und Meldungen bei der Datenübermittlung für jedes Amazon Data Firehose-Ziel. Jede Fehlermeldung beschreibt auch die korrekte Maßnahme zur Behebung des Problems.

Amazon S3-Fehler bei der Datenübermittlung

Amazon Data Firehose kann die folgenden S3-related Amazon-Fehler an CloudWatch Logs senden.

Fehlercode Fehlermeldungen und Informationen
S3.KMS.NotFoundException

„Der angegebene AWS KMS Schlüssel wurde nicht gefunden. Wenn Sie einen Ihrer Meinung nach gültigen AWS KMS Schlüssel mit der richtigen Rolle verwenden, überprüfen Sie, ob ein Problem mit dem Konto vorliegt, an das der AWS KMS Schlüssel angehängt ist.“

S3.KMS.RequestLimitExceeded

„Der Grenzwert für KMS-Anfragen pro Sekunde wurde beim Versuch der Verschlüsselung von S3-Objekten überschritten. Erhöhen Sie den Grenzwert für Anforderungen pro Sekunde.“

Weitere Informationen finden Sie unter Limits im AWS Key Management Service Entwicklerhandbuch.

S3.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die Vertrauensrichtlinie für die angegebene IAM-Rolle Amazon Data Firehose die Übernahme der Rolle ermöglicht und dass die Zugriffsrichtlinie den Zugriff auf den S3-Bucket ermöglicht.“
S3.AccountProblem „Es liegt ein Problem mit Ihrem AWS Konto vor, das den erfolgreichen Abschluss des Vorgangs verhindert. Kontaktieren Sie den AWS -Support.“
S3.AllAccessDisabled „Der Zugriff auf das bereitgestellte Konto wurde deaktiviert. Wenden Sie sich an den AWS Support.“
S3.InvalidPayer „Der Zugriff auf das bereitgestellte Konto wurde deaktiviert. Wenden Sie sich an den AWS Support.“
S3.NotSignedUp „Das Konto ist nicht für Amazon S3 registriert. Registrieren Sie das Konto, oder verwenden Sie ein anderes Konto.“
S3.NoSuchBucket "Der angegebene Bucket ist nicht vorhanden. Erstellen Sie den Bucket, oder verwenden Sie einen anderen Bucket, der existiert.“
S3.MethodNotAllowed „Die angegebene Methode ist für diese Ressource nicht zulässig. Ändern Sie die Bucket-Richtlinie, um die korrekten Amazon-S3-Operationsberechtigungen zuzulassen.“
InternalError „Interner Fehler beim Versuch des Übermittelns von Daten. Die Zustellung wird erneut versucht. Wenn der Fehler weiterhin besteht, wird er AWS zur Behebung an das Unternehmen gemeldet.“
S3.KMS.KeyDisabled „Der bereitgestellte KMS-Schlüssel wurde deaktiviert. Aktivieren Sie den Schlüssel oder verwenden Sie einen anderen Schlüssel.“
S3.KMS.InvalidStateException „Der angegebene KMS-Schlüssel hat den Status Ungültig. Bitte verwenden Sie einen anderen Schlüssel.“
KMS.InvalidStateException „Der angegebene KMS-Schlüssel hat den Status Ungültig. Bitte verwenden Sie einen anderen Schlüssel.“
KMS.DisabledException „Der bereitgestellte KMS-Schlüssel wurde deaktiviert. Bitte stellen Sie den Schlüssel ein oder verwenden Sie einen anderen Schlüssel.“
S3.SlowDown „Die Rate der Put-Anfragen an den angegebenen Bucket war zu hoch. Erhöhen Sie die Größe des Firehose-Stream-Puffers oder reduzieren Sie Put-Anfragen von anderen Anwendungen.“
S3.SubscriptionRequired „Beim Aufrufen von S3 wurde der Zugriff verweigert. Stellen Sie sicher, dass die IAM-Rolle und der übergebene KMS-Schlüssel (falls angegeben) über ein Amazon-S3-Abonnement verfügen.“
S3.InvalidToken „Das bereitgestellte Token ist falsch formatiert oder anderweitig ungültig. Bitte überprüfen Sie die angegebenen Anmeldeinformationen.“
S3.KMS.KeyNotConfigured „Der KMS-Schlüssel ist nicht konfiguriert. Konfigurieren Sie Ihre KMSMasterKeyID oder deaktivieren Sie die Verschlüsselung für Ihren S3-Bucket.“
S3.KMS.AsymmetricCMKNotSupported „Amazon S3 unterstützt nur symmetrische CMKs. Sie können keinen asymmetrischen CMK verwenden, um Daten in Amazon S3 zu verschlüsseln. Verwenden Sie die DescribeKey KMS-Operation, um den Typ Ihres CMK abzurufen.“
S3.IllegalLocationConstraintException „Firehose verwendet derzeit den globalen S3-Endpunkt für die Datenlieferung an den konfigurierten S3-Bucket. Die Region des konfigurierten S3-Buckets unterstützt den globalen S3-Endpunkt nicht. Bitte erstellen Sie einen Firehose-Stream in derselben Region wie der S3-Bucket oder verwenden Sie den S3-Bucket in der Region, die den globalen Endpunkt unterstützt.“
S3.InvalidPrefixConfigurationException „Das für die Zeitstempelauswertung verwendete benutzerdefinierte s3-Präfix ist ungültig. Prüfen Sie, ob Ihr s3-Präfix gültige Ausdrücke für das aktuelle Datum und die aktuelle Uhrzeit des Jahres enthält.“
DataFormatConversion.MalformedData „Ungültiges Zeichen zwischen Token gefunden.“

Fehler bei der Datenübermittlung in Apache Iceberg Tables

Informationen zu Fehlern bei der Datenübermittlung in Apache Iceberg Tables finden Sie unter. Liefern Sie Daten mit Amazon Data Firehose an Apache Iceberg Tables

Fehler bei der Datenübermittlung bei Amazon Redshift

Amazon Data Firehose kann die folgenden Redshift-related Amazon-Fehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
Redshift.TableNotFound

„Die Tabelle für das Laden von Daten wurde nicht gefunden. Stellen Sie sicher, dass die angegebene Tabelle vorhanden ist.“

Die Zieltabelle in Amazon Redshift, an die Daten von S3 kopiert werden sollten, wurde nicht gefunden. Beachten Sie, dass Amazon Data Firehose die Amazon Redshift-Tabelle nicht erstellt, wenn sie nicht existiert.

Redshift.SyntaxError „Der COPY-Befehl enthält einen Syntaxfehler. Wiederholen Sie den Befehl.“
Redshift.AuthenticationFailed „Der bereitgestellten Benutzernamen und das Passwort konnten nicht authentifiziert werden. Geben Sie einen gültigen Benutzernamen und ein gültiges Passwort ein.“
Redshift.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die Vertrauensrichtlinie für die angegebene IAM-Rolle Amazon Data Firehose die Übernahme der Rolle ermöglicht.“
Redshift.S3BucketAccessDenied „Der COPY-Befehl konnte nicht auf den S3-Bucket zugreifen. Stellen Sie sicher, dass die Zugriffsrichtlinie für die angegebene IAM-Rolle den Zugriff auf den S3-Bucket ermöglicht.“
Redshift.DataLoadFailed „Das Laden von Daten in die Tabelle ist fehlgeschlagen. Prüfen Sie die STL_LOAD_ERRORS-Systemtabelle für Details.“
Redshift.ColumnNotFound „Eine Spalte in dem COPY-Befehl ist in der Tabelle nicht vorhanden. Geben Sie einen gültigen Spaltennamen an.“
Redshift.DatabaseNotFound „Die in der Amazon-Redshift-Zielkonfiguration oder der JDBC-URL angegebene Datenbank wurde nicht gefunden. Geben Sie einen gültigen Datenbanknamen an.“
Redshift.IncorrectCopyOptions

„Es wurden widersprüchliche oder redundante COPY-Optionen angegeben. Einige Optionen sind in bestimmten Kombinationen nicht kompatibel. Überprüfen Sie die COPY-Befehlsreferenz", um weitere Informationen zu erhalten.“

Weitere Informationen finden Sie unter Amazon Redshift COPY-Befehl im Datenbankentwicklerhandbuch zu Amazon Redshift.

Redshift.MissingColumn „Eine Spalte im Tabellenschema ist als NOT NULL ohne DEFAULT-Wert spezifiziert und nicht in der Spaltenliste enthalten. Schließen Sie diese Spalte aus, stellen Sie sicher, dass die geladenen Daten immer einen Wert für diese Spalte angeben, oder fügen Sie dem Amazon-Redshift-Schema für diese Tabelle einen Standardwert hinzu.“
Redshift.ConnectionFailed „Die Verbindung zum angegebenen Amazon-Redshift-Cluster ist fehlgeschlagen. Stellen Sie sicher, dass die Sicherheitseinstellungen Amazon Data Firehose-Verbindungen zulassen, dass der in der Amazon Redshift-Zielkonfiguration oder in der JDBC-URL angegebene Cluster oder die Datenbank korrekt ist und dass der Cluster verfügbar ist.“
Redshift.ColumnMismatch „Die Anzahl der jsonpaths in dem COPY-Befehl und die Anzahl der Spalten in der Zieltabelle sollten miteinander übereinstimmen. Wiederholen Sie den Befehl.“
Redshift.IncorrectOrMissingRegion „Amazon Redshift hat versucht, den falschen Regionenendpunkt für den Zugriff auf den S3-Bucket zu verwenden. Geben Sie entweder einen korrekten Regionenwert in den Optionen für den COPY-Befehl an oder stellen Sie sicher, dass sich der S3-Bucket in derselben Region wie die Amazon-Redshift-Datenbank befindet.“
Redshift.IncorrectJsonPathsFile „Die bereitgestellte jsonpaths-Datei hat kein unterstütztes JSON-Format. Wiederholen Sie den Befehl.“
Redshift.MissingS3File „Eine oder mehrere für Amazon Redshift erforderliche S3-Dateien wurden aus dem S3-Bucket entfernt. Überprüfen Sie die S3-Bucket-Richtlinien, und entfernen Sie das automatische Löschen von S3-Dateien.“
Redshift.InsufficientPrivilege „Der Benutzer hat keine Berechtigung zum Laden von Daten in die Tabelle. Überprüfen Sie die Amazon-Redshift-Benutzerberechtigungen auf die INSERT-Berechtigung.“
Redshift.ReadOnlyCluster „Die Abfrage kann nicht ausgeführt werden, da sich das System im Resize-Modus befindet. Versuchen Sie die Abfrage später erneut.“
Redshift.DiskFull „Die Daten konnten nicht geladen werden, da der Datenträger voll ist. Erhöhen Sie die Kapazität des Amazon-Redshift-Clusters oder löschen Sie nicht benötigte Daten, um Speicherplatz freizugeben.“
InternalError „Interner Fehler beim Versuch des Übermittelns von Daten. Die Zustellung wird erneut versucht. Wenn der Fehler weiterhin besteht, wird er zur Behebung gemeldet.“ AWS
Redshift.ArgumentNotSupported „Der Befehl COPY enthält Optionen, die nicht unterstützt werden.“
Redshift.AnalyzeTableAccessDenied Zugriff verweigert. Das Kopieren von S3 nach Redshift schlägt fehl, weil die Analyse der Tabelle nur vom Tabellen- oder Datenbankbesitzer durchgeführt werden kann.“
Redshift.SchemaNotFound „Das in der DataTableName Amazon Redshift-Zielkonfiguration angegebene Schema wurde nicht gefunden. Geben Sie einen gültigen Schemanamen an.“
Redshift.ColumnSpecifiedMoreThanOnce „In der Spaltenliste ist eine Spalte mehrfach angegeben. Stellen Sie sicher, dass doppelte Spalten entfernt werden.“
Redshift.ColumnNotNullWithoutDefault „Es gibt eine Spalte ohne DEFAULT, die ungleich Null ist und die nicht in der Spaltenliste enthalten ist. Stellen Sie sicher, dass solche Spalten in der Spaltenliste enthalten sind.“
Redshift.IncorrectBucketRegion „Redshift hat versucht, einen Bucket in einer anderen Region als der Cluster zu verwenden. Bitte geben Sie einen Bucket an, der sich in derselben Region wie der Cluster befindet.“
Redshift.S3SlowDown „Hohe Anforderungsrate an S3. Reduzieren Sie die Rate, um eine Drosselung zu vermeiden.“
Redshift.InvalidCopyOptionForJson „Bitte verwenden Sie entweder Auto oder einen gültigen S3-Pfad für json copyOption.“
Redshift.InvalidCopyOptionJSONPathFormat „COPY ist mit dem Fehler \"Ungültiges JSONPath-Format fehlgeschlagen. Der Array-Index liegt außerhalb des zulässigen Bereichs\“. Bitte korrigieren Sie den JSONPath-Ausdruck.“
Redshift.InvalidCopyOptionRBACAclNotAllowed „COPY ist mit dem Fehler \"Das RBAC-ACL-Framework kann nicht verwendet werden, solange die Rechteweitergabe nicht aktiviert ist.\“ fehlgeschlagen
Redshift.DiskSpaceQuotaExceeded „Die Transaktion wurde wegen Überschreitung des Speicherkontingents abgebrochen. Geben Sie Speicherplatz frei oder fordern Sie ein erhöhtes Kontingent für das/die Schema(s) an.“
Redshift.ConnectionsLimitExceeded „Das Verbindungslimit für den Benutzer wurde überschritten.“
Redshift.SslNotSupported „Die Verbindung zum angegebenen Amazon-Redshift-Cluster ist fehlgeschlagen, weil der Server SSL nicht unterstützt. Bitte überprüfen Sie Ihre Cluster-Einstellungen.“
Redshift.HoseNotFound „Der Schlauch wurde gelöscht. Bitte überprüfen Sie den Status des Schlauchs.“
Redshift.Delimiter „Das copyOptions-Trennzeichen im copyCommand-Trennzeichen ist ungültig. Stellen Sie sicher, dass es sich um ein einzelnes Zeichen handelt.“
Redshift.QueryCancelled „Der Benutzer hat den COPY-Vorgang abgebrochen.“
Redshift.CompressionMismatch „Hose ist mit UNCOMPRESSED konfiguriert, aber copyOption enthält ein Komprimierungsformat.“
Redshift.EncryptionCredentials „Für die Option ENCRYPTED sind Anmeldeinformationen im folgenden Format erforderlich: 'aws_iam_role=...;master_symmetric_key=...' oder 'aws_access_key_id=...;aws_secret_access_key=...[;token=...];master_symmetric_key=...'“
Redshift.InvalidCopyOptions „Ungültige COPY-Konfigurationsoptionen.“
Redshift.InvalidMessageFormat „Der Befehl Copy enthält ein ungültiges Zeichen.“
Redshift.TransactionIdLimitReached „Das Transaktions-ID-Limit wurde erreicht.“
Redshift.DestinationRemoved „Bitte stellen Sie sicher, dass das Redshift-Ziel existiert und in der Firehose-Konfiguration korrekt konfiguriert ist.“
Redshift.OutOfMemory „Der Redshift-Cluster verfügt nicht mehr über genügend Arbeitsspeicher. Bitte stellen Sie sicher, dass der Cluster über ausreichende Kapazität verfügt.“
Redshift.CannotForkProcess „Der Redshift-Cluster verfügt nicht mehr über genügend Arbeitsspeicher. Bitte stellen Sie sicher, dass der Cluster über ausreichende Kapazität verfügt.“
Redshift.SslFailure „Die SSL-Verbindung wurde während des Handshakes geschlossen.“
Redshift.Resize „Der Redshift-Cluster gibt eine neue Größe an. Firehose wird keine Daten liefern können, während die Größe des Clusters geändert wird.“
Redshift.ImproperQualifiedName „Der qualifizierte Name ist falsch (zu viele Namen mit Punkten).“
Redshift.InvalidJsonPathFormat „Ungültiges JSONPath-Format.“
Redshift.TooManyConnectionsException „Zu viele Verbindungen zu Redshift.“
Redshift.PSQLException "von Redshift aus PSQlException beobachtet.“
Redshift.DuplicateSecondsSpecification „Doppelte Sekundenangabe im date/time Format.“
Redshift.RelationCouldNotBeOpened „Redshift-Fehler aufgetreten, Beziehung konnte nicht geöffnet werden. Überprüfen Sie die Redshift-Protokolle für die angegebene Datenbank.“
Redshift.TooManyClients „Ich bin auf zu viele Kunden gestoßen, mit Ausnahme von Redshift. Überprüfen Sie die maximale Anzahl der Verbindungen zur Datenbank erneut, wenn mehrere Produzenten gleichzeitig in die Datenbank schreiben.“

Fehler bei der Bereitstellung von Snowflake-Daten

Firehose kann die folgenden Snowflake-related Fehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
Snowflake.InvalidUrl

„Firehose kann keine Verbindung zu Snowflake herstellen. Bitte stellen Sie sicher, dass die Konto-URL in der Snowflake-Zielkonfiguration korrekt angegeben ist.“

Snowflake.InvalidUser

„Firehose kann keine Verbindung zu Snowflake herstellen. Bitte stellen Sie sicher, dass der Benutzer in der Snowflake-Zielkonfiguration korrekt angegeben ist.“

Snowflake.InvalidRole

„Die angegebene Snowflake-Rolle existiert nicht oder ist nicht autorisiert. Bitte stellen Sie sicher, dass die Rolle dem angegebenen Benutzer gewährt wird.“

Snowflake.InvalidTable

„Die angegebene Tabelle existiert nicht oder ist nicht autorisiert“

Snowflake.InvalidSchema

„Das angegebene Schema existiert nicht oder ist nicht autorisiert“

Snowflake.InvalidDatabase

„Die angegebene Datenbank existiert nicht oder ist nicht autorisiert“

Snowflake.InvalidPrivateKeyOrPassphrase

„Der angegebene private Schlüssel oder die angegebene Passphrase ist nicht gültig. Beachten Sie, dass der angegebene private Schlüssel ein gültiger privater PEM-RSA-Schlüssel sein sollte.“

Snowflake.MissingColumns

„Die Einfügeanforderung wird aufgrund fehlender Spalten in der Eingabe-Nutzlast abgelehnt. Stellen Sie sicher, dass Werte für alle Spalten angegeben sind, für die keine Nullwerte zulässig sind.“

Snowflake.ExtraColumns

„Die Einfügeanforderung wurde aufgrund zusätzlicher Spalten abgelehnt. Spalten, die in der Tabelle nicht vorhanden sind, sollten nicht angegeben werden.“

Snowflake.InvalidInput

„Die Lieferung ist aufgrund eines ungültigen Eingabeformats fehlgeschlagen. Stellen Sie sicher, dass die angegebene Eingabe-Nutzlast im akzeptablen JSON-Format vorliegt.“

Snowflake.IncorrectValue

„Die Lieferung ist aufgrund eines falschen Datentyps in der Eingabe-Nutzlast fehlgeschlagen. Stellen Sie sicher, dass die in der Eingabe-Nutzlast angegebenen JSON-Werte dem in der Snowflake-Tabellendefinition deklarierten Datentyp entsprechen.“

Fehler bei der Bereitstellung von Splunk-Daten

Amazon Data Firehose kann die folgenden Splunk-related Fehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
Splunk.ProxyWithoutStickySessions

„Wenn Sie einen Proxy (ELB oder ein anderer) zwischen Amazon Data Firehose und dem HEC-Knoten haben, müssen Sie Sticky Sessions aktivieren, um HEC-ACKs zu unterstützen.“

Splunk.DisabledToken "Das angegebene HEC-Token ist nicht aktiviert. Aktivieren Sie das Token, um zu ermöglichen, dass Daten an Splunk geliefert werden."
Splunk.InvalidToken "Das angegebene HEC-Token ist ungültig. Aktualisieren Sie Amazon Data Firehose mit einem gültigen HEC-Token.“
Splunk.InvalidDataFormat "Die Daten sind nicht ordnungsgemäß formatiert. Informationen, wie Daten ordnungsgemäß für Raw-Format oder Ereignis-HEC-Endpunkte formatiert werden, finden Sie unter Splunk-Ereignisdaten."
Splunk.InvalidIndex "Die HEC-Token oder Eingabe ist mit einem ungültigen Index konfiguriert worden. Überprüfen Sie Ihre Indexkonfiguration und versuchen Sie es erneut."
Splunk.ServerError „Datenbereitstellung an Splunk ist aufgrund eines Server-Fehlers aus dem HEC-Knoten fehlgeschlagen. Amazon Data Firehose versucht erneut, die Daten zu senden, wenn die Wiederholungsdauer in Ihrem Amazon Data Firehose größer als 0 ist. Wenn alle Wiederholungsversuche fehlschlagen, sichert Amazon Data Firehose die Daten auf Amazon S3.“
Splunk.DisabledAck "Indexbestätigung für den HEC-Token ist nicht aktiviert. Aktivieren Sie die Indexbestätigung und versuchen Sie es erneut. Weitere Informationen finden Sie unter Aktivieren der Indexbestätigung.
Splunk.AckTimeout "Habe keine Bestätigung von HEC vor Zeitablauf des HEC-Bestätigungs-Timeout erhalten. Trotz der Anerkennung des Timeouts ist es möglich, dass die Daten erfolgreich in Splunk indiziert wurden. Amazon Data Firehose sichert Daten in Amazon S3, für die das Bestätigungs-Timeout abgelaufen ist.“
Splunk.MaxRetriesFailed

"Fehler beim Senden von Daten an Splunk oder beim Erhalt einer Bestätigung. Überprüfen Sie Ihre HEC-Gesundheit und versuchen Sie es erneut."

Splunk.ConnectionTimeout "Zeitlimit bei der Verbindung zu Splunk ist überschritten. Dies kann ein vorübergehender Fehler sein, die Anforderung wird wiederholt. Amazon Data Firehose sichert die Daten auf Amazon S3, wenn alle Wiederholungsversuche fehlschlagen.“
Splunk.InvalidEndpoint "Es konnte keine Verbindung mit dem HEC-Endpunkt hergestellt werden. Stellen Sie sicher, dass die URL des HEC-Endpunkts gültig und von Amazon Data Firehose aus erreichbar ist.“
Splunk.ConnectionClosed "Fehler beim Senden der Daten an Splunk aufgrund eines Verbindungsfehlers. Dies kann ein vorübergehender Fehler sein. Eine Erhöhung der Wiederholungsdauer in Ihrer Amazon Data Firehose-Konfiguration schützt möglicherweise vor solchen vorübergehenden Ausfällen.“
Splunk.SSLUnverified "Es konnte keine Verbindung mit dem HEC-Endpunkt hergestellt werden. Der Host stimmt nicht mit dem vom Peer bereitgestellten Zertifikat überein. Stellen Sie sicher, dass das Zertifikat und der Host gültig sind."
Splunk.SSLHandshake "Es konnte keine Verbindung mit dem HEC-Endpunkt hergestellt werden. Stellen Sie sicher, dass das Zertifikat und der Host gültig sind."
Splunk.URLNotFound „Die angeforderte URL wurde auf dem Splunk-Server nicht gefunden. Bitte überprüfen Sie den Splunk-Cluster und stellen Sie sicher, dass er korrekt konfiguriert ist.“
Splunk.ServerError.ContentTooLarge „Die Datenzustellung an Splunk ist aufgrund eines Serverfehlers mit dem statusCode: 413, Nachricht: Die Anfrage, die Ihr Kunde gesendet hat, war zu groß, fehlgeschlagen. Informationen zur Konfiguration von max_content_length finden Sie in der Splunk-Dokumentation.“
Splunk.IndexerBusy „Datenbereitstellung an Splunk ist aufgrund eines Server-Fehlers aus dem HEC-Knoten fehlgeschlagen. Stellen Sie sicher, dass der HEC-Endpunkt oder der Elastic Load Balancer erreichbar und fehlerfrei sind.“
Splunk.ConnectionRecycled „Die Verbindung von Firehose zu Splunk wurde recycelt. Die Lieferung wird erneut versucht.“
Splunk.AcknowledgementsDisabled „Bei POST konnten keine Bestätigungen abgerufen werden. Stellen Sie sicher, dass Bestätigungen auf dem HEC-Endpunkt aktiviert sind.“
Splunk.InvalidHecResponseCharacter „In der HEC-Antwort wurden ungültige Zeichen gefunden. Achten Sie darauf, den Dienst und die HEC-Konfiguration zu überprüfen.“

ElasticSearch Fehler bei der Datenübermittlung

Amazon Data Firehose kann die folgenden ElasticSearch Fehler an CloudWatch Logs senden.

Fehlercode Fehlermeldungen und Informationen
ES.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die bereitgestellte IAM-Rolle, die Firehose zugeordnet ist, nicht gelöscht wird.“
ES.ResourceNotFound „Die angegebene AWS Elasticsearch-Domain existiert nicht.“

Fehler bei der Datenübermittlung am HTTPS-Endpunkt

Amazon Data Firehose kann die folgenden Endpoint-related HTTP-Fehler an CloudWatch Logs senden. Wenn keiner dieser Fehler mit dem aufgetretenen Problem übereinstimmt, lautet der Standardfehler wie folgt: „Beim Versuch, Daten zu liefern, ist ein interner Fehler aufgetreten. Die Zustellung wird erneut versucht. Wenn der Fehler weiterhin besteht, wird er AWS zur Behebung gemeldet.“

Fehlercode Fehlermeldungen und Informationen
HttpEndpoint.RequestTimeout

Bei der Zustellung wurde das Zeitlimit überschritten, bevor eine Antwort eingegangen ist, und es wird erneut versucht. Wenn dieser Fehler weiterhin besteht, wenden Sie sich an das AWS -Firehose-Serviceteam.

HttpEndpoint.ResponseTooLarge „Die vom Endpunkt empfangene Antwort ist zu umfangreich. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.InvalidResponseFromDestination „Die vom angegebenen Endpunkt empfangene Antwort ist ungültig. Wenden Sie sich an den Besitzer des Endpunkts, um das Problem zu lösen.“
HttpEndpoint.DestinationException „Die folgende Antwort wurde vom Endpunktziel empfangen.“
HttpEndpoint.ConnectionFailed „Es konnte keine Verbindung zum Zielendpunkt hergestellt werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.ConnectionReset „Die Verbindung mit dem Endpunkt konnte nicht aufrechterhalten werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.ConnectionReset „Die Verbindung mit dem Endpunkt konnte nicht aufrechterhalten werden. Bitte wenden Sie sich an den Besitzer des Endpunkts.“
HttpEndpoint.ResponseReasonPhraseExceededLimit „Der vom Endpunkt empfangene Satz zur Begründung der Antwort überschreitet den konfigurierten Grenzwert von 64 Zeichen.“
HttpEndpoint.InvalidResponseFromDestination „Die vom Endpunkt empfangene Antwort ist ungültig. Weitere Informationen finden Sie unter Problembehandlung bei HTTP-Endpunkten in der Firehose-Dokumentation. Grund "
HttpEndpoint.DestinationException „Die Lieferung an den Endpunkt war nicht erfolgreich. Weitere Informationen finden Sie unter Problembehandlung bei HTTP-Endpunkten in der Firehose-Dokumentation. Die Antwort wurde mit dem Statuscode“ empfangen
HttpEndpoint.InvalidStatusCode „Ich habe einen ungültigen Antwortstatuscode erhalten.“
HttpEndpoint.SSLHandshakeFailure „Ein SSL-Handshake mit dem Endpunkt konnte nicht abgeschlossen werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.SSLHandshakeFailure „Ein SSL-Handshake mit dem Endpunkt konnte nicht abgeschlossen werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.SSLFailure „Ein TLS-Handshake mit dem Endpunkt konnte nicht abgeschlossen werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.SSLHandshakeCertificatePathFailure „Ein SSL-Handshake mit dem Endpunkt konnte aufgrund eines ungültigen Zertifizierungspfads nicht abgeschlossen werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.SSLHandshakeCertificatePathValidationFailure „Ein SSL-Handshake mit dem Endpunkt konnte aufgrund eines Fehlers bei der Validierung des Zertifizierungspfads nicht abgeschlossen werden. Wenden Sie sich an den Besitzer des Endpunkts, um dieses Problem zu lösen.“
HttpEndpoint.MakeRequestFailure.IllegalUriException „Die HttpEndpoint Anfrage ist aufgrund einer ungültigen Eingabe in der URI fehlgeschlagen. Bitte stellen Sie sicher, dass alle Zeichen in der Eingabe-URI gültig sind.“
HttpEndpoint.MakeRequestFailure.IllegalCharacterInHeaderValue „Die HttpEndpoint Anfrage ist aufgrund eines ungültigen Antwortfehlers fehlgeschlagen. Ungültiges Zeichen '\n' im Header-Wert.“
HttpEndpoint.IllegalResponseFailure "Die HttpEndpoint Anfrage ist aufgrund eines ungültigen Antwortfehlers fehlgeschlagen. Die HTTP-Nachricht darf nicht mehr als einen Content-Type Header enthalten.“
HttpEndpoint.IllegalMessageStart „Die HttpEndpoint Anfrage ist aufgrund eines ungültigen Antwortfehlers fehlgeschlagen. Ungültiger Start der HTTP-Nachricht. Weitere Informationen finden Sie unter Problembehandlung bei HTTP-Endpunkten in der Firehose-Dokumentation.“

Fehler bei der Übermittlung von Amazon OpenSearch Service Data

Für das OpenSearch Serviceziel sendet Amazon Data Firehose Fehler an CloudWatch Logs, sobald sie vom OpenSearch Service zurückgegeben werden.

Zusätzlich zu den Fehlern, die möglicherweise von OpenSearch Clustern zurückgegeben werden, treten möglicherweise die folgenden beiden Fehler auf:

  • Authentication/authorization Beim Versuch, Daten an den OpenSearch Ziel-Servicecluster zu übermitteln, tritt ein Fehler auf. Dies kann aufgrund von and/or zeitweiligen Berechtigungsproblemen auftreten, wenn die Konfiguration Ihrer Amazon Data OpenSearch Firehose-Ziel-Service-Domain geändert wird. Bitte überprüfen Sie die Clusterrichtlinie und die Rollenberechtigungen.

  • Daten konnten aufgrund von Fehlern nicht an den OpenSearch Ziel-Service-Cluster übermittelt werden. authentication/authorization Dies kann aufgrund von and/or zeitweiligen Berechtigungsproblemen passieren, wenn die Konfiguration Ihrer Amazon Data OpenSearch Firehose-Ziel-Service-Domain geändert wird. Bitte überprüfen Sie die Clusterrichtlinie und die Rollenberechtigungen.

Fehlercode Fehlermeldungen und Informationen
OS.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass Firehose aufgrund der Vertrauensrichtlinie für die angegebene IAM-Rolle die Rolle übernehmen kann und dass die Zugriffsrichtlinie den Zugriff auf die Amazon Service API ermöglicht.“ OpenSearch
OS.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass Firehose aufgrund der Vertrauensrichtlinie für die bereitgestellte IAM-Rolle die Rolle übernehmen kann und dass die Zugriffsrichtlinie den Zugriff auf die Amazon OpenSearch Service API ermöglicht.“
OS.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die bereitgestellte IAM-Rolle, die Firehose zugeordnet ist, nicht gelöscht wird.“
OS.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die bereitgestellte IAM-Rolle, die Firehose zugeordnet ist, nicht gelöscht wird.“
OS.ResourceNotFound „Die angegebene Amazon OpenSearch Service-Domain existiert nicht.“
OS.ResourceNotFound „Die angegebene Amazon OpenSearch Service-Domain existiert nicht.“
OS.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die Vertrauensrichtlinie für die angegebene IAM-Rolle Firehose die Übernahme der Rolle ermöglicht und dass die Zugriffsrichtlinie den Zugriff auf die Amazon OpenSearch Service API ermöglicht.“
OS.RequestTimeout „Bei der Anfrage an den Amazon OpenSearch Service-Cluster oder bei der OpenSearch serverlosen Erfassung ist ein Timeout aufgetreten. Stellen Sie sicher, dass der Cluster oder die Sammlung über ausreichend Kapazität für den aktuellen Workload verfügt.“
OS.ClusterError „Der Amazon OpenSearch Service-Cluster hat einen nicht näher bezeichneten Fehler zurückgegeben.“
OS.RequestTimeout „Bei der Anfrage an den Amazon OpenSearch Service-Cluster ist ein Timeout aufgetreten. Stellen Sie sicher, dass der Cluster über ausreichend Kapazität für den aktuellen Workload verfügt.“
OS.ConnectionFailed „Probleme beim Herstellen einer Verbindung zum Amazon OpenSearch Service-Cluster oder zur OpenSearch serverlosen Sammlung. Stellen Sie sicher, dass der Cluster oder die Sammlung fehlerfrei und erreichbar ist.“
OS.ConnectionReset „Die Verbindung mit dem Amazon OpenSearch Service-Cluster oder der OpenSearch Serverless Collection konnte nicht aufrechterhalten werden. Wenden Sie sich an den Besitzer des Clusters oder der Sammlung, um dieses Problem zu lösen.“
OS.ConnectionReset „Probleme bei der Aufrechterhaltung der Verbindung mit dem Amazon OpenSearch Service-Cluster oder der OpenSearch serverlosen Sammlung. Stellen Sie sicher, dass der Cluster oder die Sammlung intakt ist und über ausreichend Kapazität für den aktuellen Workload verfügt.“
OS.ConnectionReset „Probleme bei der Aufrechterhaltung der Verbindung mit dem Amazon OpenSearch Service-Cluster oder der OpenSearch Serverless Collection. Stellen Sie sicher, dass der Cluster oder die Sammlung intakt ist und über ausreichend Kapazität für den aktuellen Workload verfügt.“
OS.AccessDenied „Zugriff verweigert. Stellen Sie sicher, dass die Zugriffsrichtlinie auf dem Amazon OpenSearch Service-Cluster Zugriff auf die konfigurierte IAM-Rolle gewährt.“
OS.ValidationException „Der OpenSearch Cluster hat eine ESServiceException zurückgegeben. Einer der Gründe ist, dass der Cluster auf OS 2.x oder höher aktualisiert wurde, der TypeName Parameter für den Schlauch jedoch immer noch konfiguriert ist. Aktualisieren Sie die Schlauchkonfiguration, indem Sie den TypeName auf eine leere Zeichenfolge setzen, oder ändern Sie den Endpunkt auf den Cluster, der den Type-Parameter unterstützt.“
OS.ValidationException „Das Mitglied muss dem Muster für reguläre Ausdrücke entsprechen: [a-z] [a-z0-9\\-]+
OS.JsonParseException „Der Amazon OpenSearch Service-Cluster hat eine zurückgegeben JsonParseException. Stellen Sie sicher, dass die eingegebenen Daten gültig sind.“
OS.AmazonOpenSearchServiceParseException „Der Amazon OpenSearch Service-Cluster gab eine zurück AmazonOpenSearchServiceParseException. Stellen Sie sicher, dass die eingegebenen Daten gültig sind.“
OS.ExplicitIndexInBulkNotAllowed „Stellen Sie sicher, dass rest.action.multi.allow_explicit_index auf dem Amazon Service-Cluster auf true gesetzt ist.“ OpenSearch
OS.ClusterError „Der Amazon OpenSearch Service-Cluster oder die serverlose Sammlung haben einen unbekannten Fehler zurückgegeben.“ OpenSearch
OS.ClusterBlockException „Der Cluster hat eine zurückgegeben. ClusterBlockException Es ist möglicherweise überlastet.“
OS.InvalidARN „Der angegebene Amazon OpenSearch Service-ARN ist ungültig. Bitte überprüfen Sie Ihre DeliveryStream Konfiguration.“
OS.MalformedData „Ein oder mehrere Datensätze sind fehlerhaft formatiert. Bitte stellen Sie sicher, dass es sich bei jedem Datensatz um ein einzelnes gültiges JSON-Objekt handelt und dass er keine Zeilenumbrüche enthält.“
OS.InternalError „Interner Fehler beim Versuch des Übermittelns von Daten. Der Versand wird erneut versucht. Wenn der Fehler weiterhin besteht, wird er AWS zur Behebung gemeldet.“
OS.AliasWithMultipleIndicesNotAllowed „Alias ist mit mehr als einem Index verknüpft. Stellen Sie sicher, dass dem Alias nur ein Index zugeordnet ist.“
OS.UnsupportedVersion „Amazon OpenSearch Service 6.0 wird derzeit nicht von Amazon Data Firehose unterstützt. Kontaktieren Sie den AWS Support für weitere Informationen.“
OS.CharConversionException „Ein oder mehrere Datensätze enthielten ein ungültiges Zeichen.“
OS.InvalidDomainNameLength „Die Länge des Domainnamens liegt nicht innerhalb der gültigen Betriebssystemgrenzen.“
OS.VPCDomainNotSupported „Amazon OpenSearch Service-Domains innerhalb von VPCs werden derzeit nicht unterstützt.“
OS.ConnectionError „Der HTTP-Server hat die Verbindung unerwartet geschlossen. Bitte überprüfen Sie den Zustand des Amazon OpenSearch Service-Clusters oder der OpenSearch serverlosen Sammlung.“
OS.LargeFieldData „Der Amazon OpenSearch Service-Cluster hat die Anfrage abgebrochen, da sie Felddaten enthielt, die größer als zulässig waren.“
OS.BadGateway „Der Amazon OpenSearch Service-Cluster oder die OpenSearch serverlose Erfassung hat die Anfrage mit einer Antwort abgebrochen: 502 Bad Gateway.“
OS.ServiceException „Vom Amazon OpenSearch Service-Cluster oder der OpenSearch Serverless-Sammlung wurde ein Fehler gemeldet. Wenn sich der Cluster oder die Sammlung hinter einer VPC befindet, stellen Sie sicher, dass die Netzwerkkonfiguration Konnektivität zulässt.“
OS.GatewayTimeout „Firehose hat beim Herstellen einer Verbindung zum Amazon OpenSearch Service-Cluster oder zur OpenSearch Serverless Collection Timeout-Fehler festgestellt.“
OS.MalformedData „Amazon Data Firehose unterstützt keine Amazon OpenSearch Service Bulk API-Befehle innerhalb des Firehose-Datensatzes.“
OS.ResponseEntryCountMismatch „Die Antwort der Bulk-API enthielt mehr Einträge als die Anzahl der gesendeten Datensätze. Stellen Sie sicher, dass jeder Datensatz nur ein JSON-Objekt enthält und dass es keine Zeilenumbrüche gibt.“

Fehler beim Lambda-Aufruf

Amazon Data Firehose kann die folgenden Lambda-Aufruffehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
Lambda.AssumeRoleAccessDenied

„Zugriff verweigert. Stellen Sie sicher, dass die Vertrauensrichtlinie für die angegebene IAM-Rolle Amazon Data Firehose die Übernahme der Rolle ermöglicht.“

Lambda.InvokeAccessDenied

„Zugriff verweigert. Stellen Sie sicher, dass die Zugriffsrichtlinie den Zugriff auf die Lambda-Funktion zulässt.“

Lambda.JsonProcessingException

„Bei der Analyse der zurückgegebenen Datensätze von der Lambda-Funktion ist ein Fehler aufgetreten. Stellen Sie sicher, dass die zurückgegebenen Datensätze dem von Amazon Data Firehose geforderten Statusmodell entsprechen.“

Weitere Informationen finden Sie unter Erforderliche Parameter für die Datentransformation.

Lambda.InvokeLimitExceeded

„Das Limit für die gleichzeitige Lambda-Ausführung wurde überschritten. Erhöhen Sie das Limit für die gleichzeitige Ausführung.“

Weitere Informationen finden Sie unter AWS Lambda Limits im AWS Lambda -Entwicklerhandbuch.

Lambda.DuplicatedRecordId

„Es wurden mehrere Datensätze mit der selben Datensatz-ID zurückgegeben. Stellen Sie sicher, dass die Lambda-Funktion für jeden Datensatz eindeutige Datensatz-IDs zurückgibt.“

Weitere Informationen finden Sie unter Erforderliche Parameter für die Datentransformation.

Lambda.MissingRecordId

„Eine oder mehrere Datensatz-IDs wurden nicht zurückgegeben. Stellen Sie sicher, dass die Lambda-Funktion alle empfangenen Datensatz-IDs zurückgibt.“

Weitere Informationen finden Sie unter Erforderliche Parameter für die Datentransformation.

Lambda.ResourceNotFound

„Die angegebene Lambda-Funktion ist nicht vorhanden. Verwenden Sie eine andere Funktion, die vorhanden ist.“

Lambda.InvalidSubnetIDException

„Die angegebenen Subnetz-ID in der Lambda-Funktions-VPC-Konfiguration ist ungültig. Stellen Sie sicher, dass die Subnetz-ID gültig ist.“

Lambda.InvalidSecurityGroupIDException

„Die angegebene Sicherheitsgruppen-ID in der Lambda-Funktions-VPC-Konfiguration ist ungültig. Stellen Sie sicher, dass die Sicherheitsgruppen-ID gültig ist.“

Lambda.SubnetIPAddressLimitReachedException

"AWS Lambda konnte den VPC-Zugriff für die Lambda-Funktion nicht einrichten, da ein oder mehrere konfigurierte Subnetze keine verfügbaren IP-Adressen haben. Erhöhen Sie das Limit für IP-Adressen.“

Weitere Informationen zu diesen Limits finden Sie unter Amazon VPC-Limits – VPC und Subnetze im Amazon-VPC-Benutzerhandbuch.

Lambda.ENILimitReachedException

"AWS Lambda konnte in der VPC kein Elastic Network Interface (ENI) erstellen, das als Teil der Lambda-Funktionskonfiguration angegeben wurde, da das Limit für Netzwerkschnittstellen erreicht wurde. Erhöhen Sie das Limit für Netzwerkschnittstellen.“

Weitere Informationen zu diesen Limits finden Sie unter Amazon VPC-Limits – Netzwerkschnittstellen im Amazon-VPC-Benutzerhandbuch.

Lambda.FunctionTimedOut

Der Lambda-Funktions-Aufruf hat das Zeitlimit überschritten. Erhöhen Sie die Timeout-Einstellung in der Lambda-Funktion. Weitere Informationen erhalten Sie unter Zeitüberschreitung der Funktion konfigurieren.

Lambda.FunctionError

Dies kann an einen der folgenden zurückzuführen sein:

  • Ungültige Ausgabestruktur. Überprüfen Sie Ihre Funktion und stellen Sie sicher, dass die Ausgabe das erforderliche Format hat. Stellen Sie außerdem sicher, dass die verarbeiteten Datensätze den gültigen Ergebnisstatus von Dropped, Ok oder ProcessingFailed enthalten.

  • Die Lambda-Funktion wurde erfolgreich aufgerufen, hat aber ein Fehlerergebnis zurückgegeben.

  • Lambda konnte die Umgebungsvariablen nicht entschlüsseln, da der KMS-Zugriff verweigert wurde. Überprüfen Sie die KMS-Schlüsseleinstellungen der Funktion sowie die Schlüsselrichtlinie. Weitere Informationen finden Sie unter Fehlerbehebung beim Schlüsselzugriff.

Lambda.FunctionRequestTimedOut

Amazon Data Firehose hat festgestellt, dass die Anfrage nicht abgeschlossen wurde, bevor beim Aufrufen von Lambda ein Konfigurationsfehler für das Anforderungs-Timeout aufgetreten ist. Überprüfen Sie den Lambda-Code erneut, um zu überprüfen, ob der Lambda-Code über den konfigurierten Timeout hinaus ausgeführt werden soll. Wenn ja, sollten Sie die Lambda-Konfigurationseinstellungen, einschließlich Speicher und Timeout, optimieren. Weitere Informationen erhalten Sie unter Konfigurieren von Lambda-Funktionsoptionen.

Lambda.TargetServerFailedToRespond

Bei Amazon Data Firehose ist ein Fehler aufgetreten. Der Zielserver hat beim Aufrufen des AWS Lambda-Service nicht reagiert.

Lambda.InvalidZipFileException

Amazon Data Firehose ist InvalidZipFileException beim Aufrufen der Lambda-Funktion aufgetreten. Überprüfen Sie Ihre Lambda-Funktionskonfigurationseinstellungen und die Lambda-Code-ZIP-Datei.

Lambda.InternalServerError

„Amazon Data Firehose ist InternalServerError beim Aufrufen des Lambda-Service aufgetreten. AWS Amazon Data Firehose versucht erneut, Daten mit einer festen Anzahl von Malen zu senden. Sie können die Optionen für die erneuten Versuche mit den CreateDeliveryStream- oder UpdateDestination-APIs angeben oder überschreiben. Wenn der Fehler weiterhin besteht, wenden Sie sich an das AWS Lambda-Supportteam.

Lambda.ServiceUnavailable

ServiceUnavailableException Beim Aufrufen des Lambda-Service ist Amazon Data Firehose aufgetreten. AWS Amazon Data Firehose versucht erneut, Daten mit einer festen Anzahl von Malen zu senden. Sie können die Optionen für die erneuten Versuche mit den CreateDeliveryStream- oder UpdateDestination-APIs angeben oder überschreiben. Wenn der Fehler weiterhin besteht, wenden Sie AWS sich an den Lambda-Support.

Lambda.InvalidSecurityToken

Die Lambda-Funktion kann aufgrund eines ungültigen Sicherheitstokens nicht aufgerufen werden. Partitionsübergreifender Lambda-Aufruf wird nicht unterstützt.

Lambda.InvocationFailure

Dies kann an einen der folgenden zurückzuführen sein:

  • Amazon Data Firehose ist beim Aufrufen von Lambda auf Fehler gestoßen. AWS Der Vorgang wird erneut versucht; wenn der Fehler bestehen bleibt, wird er zur Lösung an AWS gemeldet.“

  • Amazon Data Firehose ist auf einen KMSInvalidStateException von Lambda gestoßen. Lambda konnte die Umgebungsvariablen nicht entschlüsseln, da der verwendete KMS-Schlüssel einen ungültigen Status für Entschlüsseln hat. Überprüfen Sie die Einstellungen des KMS-Schlüssels der Lambda-Funktion.

  • Amazon Data Firehose ist auf einen AWS LambdaException Mann von Lambda gestoßen. Lambda konnte das bereitgestellte Container-Image nicht initialisieren. Überprüfen Sie das Bild.

  • Amazon Data Firehose ist beim Aufrufen von Lambda auf Timeout-Fehler gestoßen. AWS Das maximal unterstützte Funktions-Timeout beträgt 5 Minuten. Weitere Informationen finden Sie unter Data Transformation Execution Duration.

Lambda.JsonMappingException

Bei der Analyse der zurückgegebenen Datensätze von der Lambda-Funktion ist ein Fehler aufgetreten. Stellen Sie sicher, dass das Datenfeld base-64-codiert ist.

Fehler beim Aufrufen von Kinesis

Amazon Data Firehose kann die folgenden Kinesis-Aufruffehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
Kinesis.AccessDenied „Beim Aufrufen von Kinesis wurde der Zugriff verweigert. Stellen Sie sicher, dass die Zugriffsrichtlinie für die verwendete IAM-Rolle den Zugriff auf die entsprechenden Kinesis-APIs ermöglicht.“
Kinesis.ResourceNotFound „Firehose konnte nicht aus dem Stream lesen. Wenn der Firehose mit Kinesis Stream verbunden ist, ist der Stream möglicherweise nicht vorhanden, oder der Shard wurde möglicherweise zusammengeführt oder aufgeteilt. Wenn der Firehose DirectPut vom Typ Firehose ist, existiert der Firehose möglicherweise nicht mehr.“
Kinesis.SubscriptionRequired „Beim Aufrufen von Kinesis wurde der Zugriff verweigert. Stellen Sie sicher, dass die IAM-Rolle, die für den Kinesis-Stream-Zugriff übergeben wurde, über ein Kinesis-Abonnement verfügt AWS .“
Kinesis.Throttling „Beim Aufrufen von Kinesis ist ein Drosselungsfehler aufgetreten. Das kann daran liegen, dass andere Anwendungen dieselben APIs wie der Firehose-Stream aufrufen, oder daran, dass Sie zu viele Firehose-Streams mit demselben Kinesis-Stream wie die Quelle erstellt haben.“
Kinesis.Throttling „Beim Aufrufen von Kinesis ist ein Drosselungsfehler aufgetreten. Dies kann daran liegen, dass andere Anwendungen dieselben APIs wie den Firehose-Stream aufrufen, oder daran, dass Sie zu viele Firehose-Streams mit demselben Kinesis-Stream wie die Quelle erstellt haben.“
Kinesis.AccessDenied „Beim Aufrufen von Kinesis wurde der Zugriff verweigert. Stellen Sie sicher, dass die Zugriffsrichtlinie für die verwendete IAM-Rolle den Zugriff auf die entsprechenden Kinesis-APIs ermöglicht.“
Kinesis.AccessDenied „Beim Versuch, API-Operationen auf dem zugrunde liegenden Kinesis-Stream aufzurufen, wurde der Zugriff verweigert. Stellen Sie sicher, dass die IAM-Rolle weitergegeben wird und gültig ist.“
Kinesis.KMS.AccessDeniedException „Firehose hat keinen Zugriff auf den KMS-Schlüssel, der für den Kinesis Stream verwendet wird. encrypt/decrypt Bitte gewähren Sie der Firehose-Lieferrolle Zugriff auf den Schlüssel.“
Kinesis.KMS.KeyDisabled „Firehose kann nicht aus dem Kinesis-Quellstream lesen, da der dafür verwendete KMS-Schlüssel deaktiviert ist. encrypt/decrypt Aktivieren Sie den Schlüssel, damit der Lesevorgang fortgesetzt werden kann.“
Kinesis.KMS.InvalidStateException „Firehose kann nicht aus dem Quell-Kinesis-Stream lesen, da der KMS-Schlüssel, der zum Verschlüsseln verwendet wurde, in einem ungültigen Zustand ist.“
Kinesis.KMS.NotFoundException „Firehose kann nicht aus dem Quell-Kinesis Stream lesen, da der KMS-Schlüssel, der zum Verschlüsseln verwendet wurde, nicht gefunden wurde.

Fehler beim Aufrufen von Kinesis DirectPut

Amazon Data Firehose kann die folgenden DirectPut Kinesis-Aufruffehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
Firehose.KMS.AccessDeniedException „Firehose hat keinen Zugriff auf den KMS-Schlüssel. Bitte überprüfen Sie die Schlüsselrichtlinie.“
Firehose.KMS.InvalidStateException „Firehose kann die Daten nicht entschlüsseln, weil der zur Verschlüsselung verwendete KMS-Schlüssel ungültig ist.“
Firehose.KMS.NotFoundException „Firehose ist nicht in der Lage, die Daten zu entschlüsseln, da der zur Verschlüsselung verwendete KMS-Schlüssel nicht gefunden wurde.“
Firehose.KMS.KeyDisabled „Firehose ist nicht in der Lage, die Daten zu entschlüsseln, da der zur Verschlüsselung der Daten verwendete KMS-Schlüssel deaktiviert ist. Aktivieren Sie den Schlüssel, damit die Datenübermittlung fortgesetzt werden kann.“

AWS Glue Fehler beim Aufrufen

Amazon Data Firehose kann die folgenden AWS Glue Aufruffehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
DataFormatConversion.InvalidSchema „Das Schema ist ungültig.“
DataFormatConversion.EntityNotFound „Die angegebene Datei table/database konnte nicht gefunden werden. Bitte stellen Sie sicher, dass das table/database existiert und dass die in der Schemakonfiguration angegebenen Werte korrekt sind, insbesondere in Bezug auf die Groß- und Kleinschreibung.“
DataFormatConversion.InvalidInput „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die angegebene Datenbank mit der angegebenen Katalog-ID existiert.“
DataFormatConversion.InvalidInput „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass der übergebene ARN das richtige Format hat.“
DataFormatConversion.InvalidInput „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die angegebene catalogId gültig ist.“
DataFormatConversion.InvalidVersionId „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die angegebene Version der Tabelle existiert.“
DataFormatConversion.NonExistentColumns „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die Tabelle mit einem Speicherdeskriptor konfiguriert ist, der nicht Null ist und die Zielspalten enthält.“
DataFormatConversion.AccessDenied Zugriff beim Übernehmen der Rolle verweigert Bitte vergewissern Sie sich, dass die in der Konfiguration der Datenformatkonvertierung angegebene Rolle dem Firehose-Dienst die Berechtigung erteilt hat, diese zu übernehmen.“
DataFormatConversion.ThrottledByGlue „Beim Aufrufen von Glue ist ein Drosselungsfehler aufgetreten. Erhöhen Sie entweder das Limit für die Anforderungsrate oder verringern Sie die aktuelle Rate, mit der Glue über andere Anwendungen aufgerufen wird.“
DataFormatConversion.AccessDenied „Beim Aufrufen von Glue wurde der Zugriff verweigert. Bitte stellen Sie sicher, dass die in der Konfiguration zur Datenformatkonvertierung angegebene Rolle dem Firehose-Dienst die Erlaubnis erteilt hat, diese Rolle zu übernehmen.“
DataFormatConversion.InvalidGlueRole „Ungültige Rolle. Bitte stellen Sie sicher, dass die in der Konfiguration zur Datenformatkonvertierung angegebene Rolle existiert.“
DataFormatConversion.InvalidGlueRole Das Sicherheits-Token der Anfrage ist ungültig. Stellen Sie sicher, dass die bereitgestellte IAM-Rolle, die Firehose zugeordnet ist, nicht gelöscht wird.“
DataFormatConversion.GlueNotAvailableInRegion „AWS Glue ist in der von Ihnen angegebenen Region noch nicht verfügbar. Bitte geben Sie eine andere Region an.“
DataFormatConversion.GlueEncryptionException „Beim Abrufen des Hauptschlüssels ist ein Fehler aufgetreten. Stellen Sie sicher, dass der Schlüssel vorhanden ist und über die richtigen Zugriffsberechtigungen verfügt.“
DataFormatConversion.SchemaValidationTimeout „Beim Abrufen der Tabelle von Glue ist eine Zeitüberschreitung aufgetreten. Wenn Sie über eine große Anzahl von Glue-Tabellen-Versionen verfügen, fügen Sie bitte die Berechtigung „Glue:GetTableVersion“ hinzu (empfohlen) oder löschen Sie nicht verwendete Tabellen-Versionen. Wenn Sie nicht über eine große Anzahl von Tabellen in Glue verfügen, wenden Sie sich bitte an den AWS Support.“
DataFirehose.InternalError „Beim Abrufen der Tabelle von Glue ist eine Zeitüberschreitung aufgetreten. Wenn Sie eine große Anzahl von Glue-Tabellen-Versionen haben, fügen Sie bitte die 'Glue: GetTableVersion '-Berechtigung hinzu (empfohlen) oder löschen Sie ungenutzte Tabellenversionen. Wenn Sie nicht über eine große Anzahl von Tabellen in Glue verfügen, wenden Sie sich bitte an den AWS Support.“
DataFormatConversion.GlueEncryptionException „Beim Abrufen des Hauptschlüssels ist ein Fehler aufgetreten. Stellen Sie sicher, dass der Schlüssel existiert und der Status korrekt ist.“

DataFormatConversion Fehler beim Aufrufen

Amazon Data Firehose kann die folgenden DataFormatConversion Aufruffehler an Logs senden. CloudWatch

Fehlercode Fehlermeldungen und Informationen
DataFormatConversion.InvalidSchema „Das Schema ist ungültig.“
DataFormatConversion.ValidationException „Spaltennamen und -typen dürfen keine leeren Zeichenfolgen sein.“
DataFormatConversion.ParseError „Auf falsch formatiertes JSON gestoßen.“
DataFormatConversion.MalformedData „Die Daten stimmen nicht mit dem Schema überein.“
DataFormatConversion.MalformedData „Die Länge des JSON-Schlüssels darf nicht größer als 262 144 sein“
DataFormatConversion.MalformedData „Die Daten können nicht dekodiert werden als.“ UTF-8
DataFormatConversion.MalformedData „Ungültiges Zeichen zwischen Token gefunden.“
DataFormatConversion.InvalidTypeFormat „Das Typformat ist ungültig. Überprüfen Sie die Typsyntax.“
DataFormatConversion.InvalidSchema „Ungültiges Schema. Bitte stellen Sie sicher, dass die Spaltennamen keine Sonderzeichen oder Leerzeichen enthalten.“
DataFormatConversion.InvalidRecord „Der Datensatz entspricht nicht dem Schema. Ein oder mehrere Map-Schlüssel waren für map<string,string> ungültig.“
DataFormatConversion.MalformedData „Die Eingabe-JSON enthielt ein Primitiv auf der obersten Ebene. Die oberste Ebene muss ein Objekt oder Array sein.“
DataFormatConversion.MalformedData „Die Eingabe-JSON enthielt ein Primitiv auf der obersten Ebene. Die oberste Ebene muss ein Objekt oder Array sein.“
DataFormatConversion.MalformedData „Der Datensatz war leer oder enthielt nur Leerzeichen.“
DataFormatConversion.MalformedData „Auf ungültige Zeichen gestoßen.“
DataFormatConversion.MalformedData „Es wurde ein ungültiges oder nicht unterstütztes Zeitstempelformat festgestellt. Informationen zu den unterstützten Zeitstempelformaten finden Sie im Firehose-Entwicklerhandbuch.“
DataFormatConversion.MalformedData „In den Daten wurde ein skalarer Typ gefunden, aber im Schema wurde ein komplexer Typ angegeben.“
DataFormatConversion.MalformedData „Die Daten stimmen nicht mit dem Schema überein.“
DataFormatConversion.MalformedData „In den Daten wurde ein skalarer Typ gefunden, aber im Schema wurde ein komplexer Typ angegeben.“
DataFormatConversion.ConversionFailureException "ConversionFailureException"
DataFormatConversion.DataFormatConversionCustomerErrorException "DataFormatConversionCustomerErrorException"
DataFormatConversion.DataFormatConversionCustomerErrorException "DataFormatConversionCustomerErrorException"
DataFormatConversion.MalformedData „Die Daten stimmen nicht mit dem Schema überein.“
DataFormatConversion.InvalidSchema „Das Schema ist ungültig.“
DataFormatConversion.MalformedData „Die Daten stimmen nicht mit dem Schema überein. Ungültiges Format für ein oder mehrere Daten.“
DataFormatConversion.MalformedData „Daten enthalten eine stark verschachtelte JSON-Struktur, die nicht unterstützt wird.“
DataFormatConversion.EntityNotFound „Die angegebene table/database Datei konnte nicht gefunden werden. Bitte stellen Sie sicher, dass das table/database existiert und dass die in der Schemakonfiguration angegebenen Werte korrekt sind, insbesondere in Bezug auf die Groß- und Kleinschreibung.“
DataFormatConversion.InvalidInput „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die angegebene Datenbank mit der angegebenen Katalog-ID existiert.“
DataFormatConversion.InvalidInput „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass der übergebene ARN das richtige Format hat.“
DataFormatConversion.InvalidInput „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die angegebene catalogId gültig ist.“
DataFormatConversion.InvalidVersionId „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die angegebene Version der Tabelle existiert.“
DataFormatConversion.NonExistentColumns „Es konnte kein passendes Schema von Glue gefunden werden. Bitte stellen Sie sicher, dass die Tabelle mit einem Speicherdeskriptor konfiguriert ist, der nicht Null ist und die Zielspalten enthält.“
DataFormatConversion.AccessDenied Zugriff beim Übernehmen der Rolle verweigert Bitte vergewissern Sie sich, dass die in der Konfiguration der Datenformatkonvertierung angegebene Rolle dem Firehose-Dienst die Berechtigung erteilt hat, diese zu übernehmen.“
DataFormatConversion.ThrottledByGlue „Beim Aufrufen von Glue ist ein Drosselungsfehler aufgetreten. Erhöhen Sie entweder das Limit für die Anforderungsrate oder verringern Sie die aktuelle Rate, mit der Glue über andere Anwendungen aufgerufen wird.“
DataFormatConversion.AccessDenied „Beim Aufrufen von Glue wurde der Zugriff verweigert. Bitte stellen Sie sicher, dass die in der Konfiguration zur Datenformatkonvertierung angegebene Rolle dem Firehose-Dienst die Erlaubnis erteilt hat, diese Rolle zu übernehmen.“
DataFormatConversion.InvalidGlueRole „Ungültige Rolle. Bitte stellen Sie sicher, dass die in der Konfiguration zur Datenformatkonvertierung angegebene Rolle existiert.“
DataFormatConversion.GlueNotAvailableInRegion „AWS Glue ist in der von Ihnen angegebenen Region noch nicht verfügbar. Bitte geben Sie eine andere Region an.“
DataFormatConversion.GlueEncryptionException „Beim Abrufen des Hauptschlüssels ist ein Fehler aufgetreten. Stellen Sie sicher, dass der Schlüssel vorhanden ist und über die richtigen Zugriffsberechtigungen verfügt.“
DataFormatConversion.SchemaValidationTimeout „Beim Abrufen der Tabelle von Glue ist eine Zeitüberschreitung aufgetreten. Wenn Sie über eine große Anzahl von Glue-Tabellen-Versionen verfügen, fügen Sie bitte die Berechtigung „Glue:GetTableVersion“ hinzu (empfohlen) oder löschen Sie nicht verwendete Tabellen-Versionen. Wenn Sie nicht über eine große Anzahl von Tabellen in Glue verfügen, wenden Sie sich bitte an den AWS Support.“
DataFirehose.InternalError „Beim Abrufen der Tabelle von Glue ist eine Zeitüberschreitung aufgetreten. Wenn Sie eine große Anzahl von Glue-Tabellen-Versionen haben, fügen Sie bitte die 'Glue: GetTableVersion '-Berechtigung hinzu (empfohlen) oder löschen Sie ungenutzte Tabellenversionen. Wenn Sie nicht über eine große Anzahl von Tabellen in Glue verfügen, wenden Sie sich bitte an den AWS Support.“
DataFormatConversion.MalformedData „Ein oder mehrere Felder haben ein falsches Format.“