View a markdown version of this page

AWS IoT Fehlerbehebung im Softwarepaketkatalog für die Geräteverwaltung - AWS IoT Core

Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.

AWS IoT Fehlerbehebung im Softwarepaketkatalog für die Geräteverwaltung

Dies ist der Abschnitt zur Problembehandlung für den AWS IoT Geräteverwaltungs-Softwarepaketkatalog.

Allgemeine Fehlermeldungen zur Fehlerbehebung

In diesem Abschnitt werden häufige Fehler aufgeführt, die während des gesamten Lebenszyklus der Softwarepaketversion auftreten.

HeadBucket-Fehler

Die folgenden Fehlermeldungen werden angezeigt, wenn der HeadBucket API-Vorgang oder der head-bucket CLI-Befehl aufgerufen wird, um den Amazon S3-Bucket zu überprüfen, der für den Dateiupload während einer Auftragsbereitstellung verwendet wird.

Weitere Informationen zur Verwendung eines Amazon S3-Buckets zum Hochladen von Dateien während einer Auftragsbereitstellung finden Sie unterVorsignierte URL für den Datei-Upload.

InvalidRoleException "Permission denied when attempting to use role %s to access bucket %s."
InvalidRequestException "Cross region S3 bucket is not supported for presigned url upload placeholder"
InvalidRequestException "S3 bucket in job document presigned url upload placeholder not found"
InvalidRequestException "Given S3 bucket name is invalid."
InvalidRequestException "Provided S3 bucket is not valid: %s. Error: %s"

Amazon S3 GetObject

Die folgende Fehlermeldung tritt auf, wenn ein ungültiges Argument angegeben wird, wodurch der Amazon GetObject S3-API-Vorgang fehlschlägt.

InvalidRequestException "Provided argument for presigned url is invalid"

Unterstützung der Amazon S3-Versions-ID

Wenn Sie mithilfe der Versionskontrolle den Zugriff auf einen Amazon S3-Bucket anfordern, stellen Sie sicher, dass Sie Ihren versionId oder die folgende Fehlermeldung angeben.

Weitere Informationen zu Amazon S3-Buckets, die die Versionskontrolle verwenden, finden Sie unter Verwenden der Versionierung in Amazon S3-Buckets

InvalidRequestException "VersionId not found when attempting to access s3 url"

Platzhalter innerhalb einer vorsignierten URL für den Datei-Upload

Die folgenden Fehlermeldungen werden angezeigt, wenn Probleme mit einem Platzhalter in einer vorsignierten URL auftreten, die während einer Auftragsbereitstellung zum Hochladen von Dateien in einen Amazon S3-Ziel-Bucket verwendet wird. Weitere Informationen zur Verwendung eines Amazon S3-Buckets zum Hochladen von Dateien während einer Auftragsbereitstellung und zur Definition eines lokalen Platzhalters finden Sie unter. Vorsignierte URL für den Datei-Upload

Die folgende Fehlermeldung wird angezeigt, wenn der lokale Platzhalter nicht erkannt wird.

InvalidJobDocumentException "Undefined placeholder, ${...}, inside of presign url upload parameter"

Die folgende Fehlermeldung wird angezeigt, wenn versucht wird, den lokalen Platzhalter in einer vorsignierten URL zu verwenden, die nicht für den Dateiupload bestimmt ist.

InvalidJobDocumentException "Local placeholder, ${...}, is only valid inside of presign url upload"

Amazon S3-URL ist falsch verschachtelt

Die folgende Fehlermeldung wird angezeigt, wenn die Amazon S3-URL fälschlicherweise in einem anderen Platzhalter verschachtelt ist.

InvalidJobDocumentException "${aws:%s[...]} should not be the second layer pattern."

Paketversion: Artefakt-Verschachtelung

Die folgende Fehlermeldung wird angezeigt, wenn die vorsignierte URL für das Artefakt der Paketversion fälschlicherweise in einem anderen Platzhalter verschachtelt ist.

InvalidJobDocumentException "${aws:iot:package:[...]:artifact:s3-presigned-url} cannot be nested inside another placeholder."

Artefakt der Paketversion fehlt

Die folgende Fehlermeldung wird angezeigt, wenn das Artefakt der Paketversion, auf das verwiesen wird, nicht gefunden wird.

InvalidJobDocumentException "Package %s version %s does not have an associated artifact to generate an S3 presigned url."

Platzhalter für Softwarepaket und Paketversion

Die folgende Fehlermeldung wird angezeigt, wenn der Platzhalter für das Jobdokument für das Softwarepaket und die Paketversion aufgrund mehrerer Softwarepakete und Paketversionen, auf die im destinationPackageVersions Parameter oder auf der Registerkarte Versions-ARN auf der Detailseite der Paketversion verwiesen wird, nicht zu den gewünschten gültigen Werten für die Auftragsbereitstellung aufgelöst werden kann.

InvalidJobDocumentException "Cannot resolve empty package name and version name given multiple elements in destination package versions."

Verwenden Sie ein leeres Softwarepaket und eine leere Paketversion

Die folgende Fehlermeldung wird angezeigt, wenn Sie versuchen, ein leeres Paket oder eine Paketversion ohne die andere in einem Jobdokument zu verwenden.

InvalidJobDocumentException "Empty package name and version name have to be used in pair."

Null: Verwendung im Auftragsdokument

Die folgende Fehlermeldung wird angezeigt, wenn Sie versuchen$null, eine Paketversion im Jobdokument anzugeben. $nullkann nur innerhalb des destinationPackageVersions Parameters verwendet werden, wenn die CreateJob API-Operation verwendet wird.

InvalidJobDocumentException "$null is not allowed to be referenced as a package version in job documents."

Alle Attribute in einer Paketversion

Die folgende Fehlermeldung wird angezeigt, wenn Sie versuchen, alle Attribute in einer Paketversion zu verwenden und sie mit zusätzlichem Text oder Platzhaltern zu umgeben.

Weitere Informationen zur Verwendung aller Attribute in einer Softwarepaketversion finden Sie unter Substitutionsparameter für AWS IoT jobs

InvalidJobDocumentException "The package version attribute placeholder for all attributes has to be a json value by itself and not appended with other strings or nested with other placeholders."

Limit für lokale Platzhalter in vorsignierten URLs für den Datei-Upload

Die folgende Fehlermeldung wird angezeigt, wenn Sie das Limit für die Anzahl der lokalen Platzhalter überschreiten, die in einer vorsignierten URL für den Dateiupload während einer Jobbereitstellung verwendet werden.

Weitere Informationen zur Verwendung einer vorsignierten URL für den Dateiupload während einer Auftragsbereitstellung finden Sie unter Vorsignierte URL für den Datei-Upload

InvalidJobDocumentException "The occurrence of local placeholder %s within S3 presigned url upload placeholder exceeds limit of %d."

Lokale Platzhalter in einem Amazon S3-Bucket

Die folgende Fehlermeldung wird angezeigt, wenn Sie versuchen, im Amazon S3-Bucket-Namen eine lokale Platzhalter-URL für einen vorsignierten URL-Platzhalter zu platzieren, der für den Datei-Upload während einer Auftragsbereitstellung verwendet wird.

Weitere Informationen zur Verwendung einer vorsignierten URL für den Dateiupload während einer Auftragsbereitstellung finden Sie unter Vorsignierte URL für den Datei-Upload

InvalidJobDocumentException "S3 bucket name in presigned url upload is not allowed to contain any placeholders"

Klammern öffnen und schließen

Die folgende Fehlermeldung wird angezeigt, wenn Sie einem Jobdokument ohne die schließende Klammer „}“ einen Parameter oder Platzhalter hinzufügen.

InvalidJobDocumentException "One or more parameters or placeholders are not terminated."

IAM-Rolle mit vorsignierter Amazon S3-URL

Die folgende Fehlermeldung wird angezeigt, wenn Sie versuchen, eine vorsignierte Amazon S3-URL in einem Jobdokument ohne IAM-Rolle zu verwenden.

Weitere Informationen zu vorsignierten Amazon S3-URLs finden Sie unter Arbeiten mit vorsignierten URLs.

InvalidRequestException "presignedUrlConfig role ARN is required to generate an S3 presigned url in job document."

IAM-Rolle mit vorsignierter Amazon S3-URL für das Artefakt der Paketversion

Die folgende Fehlermeldung wird angezeigt, wenn Sie versuchen, eine vorsignierte Amazon S3-URL zu verwenden, die ein Artefakt der Paketversion in einem Jobdokument ohne IAM-Rolle darstellt.

InvalidRequestException "presignedUrlConfig role ARN is required to generate an S3 presigned url in job document for package %s version %s artifact."

Fehlermeldungen zur Stückliste der Software

In diesem Abschnitt werden häufig auftretende Fehler im Zusammenhang mit einer Softwareliste (SBOM) aufgeführt, die mit einer Paketversion verknüpft ist.

Eingabeüberprüfung für die Anfrage zur SBOM Association

Die folgende Fehlermeldung wird angezeigt, wenn der AssociateSbomWithPackageVersion API-Vorgang verwendet wird und der s3Location Parameter Null ist.

InvalidRequestException "Associate request needs to include SBOM reference"

Weitere Informationen zum AssociateSbomWithPackageVersion API-Vorgang finden Sie unter AssociateSbomWithPackageVersion.

Fehler bei der SBOM-Validierung

In diesem Abschnitt werden häufig auftretende Fehler aufgeführt, die bei der ersten Validierung der Softwareliste (SBOM) im Zusammenhang mit einer Softwarepaketversion auftreten.

Die folgende Fehlermeldung wird angezeigt, wenn der AssociateSbomWithPackageVersion API-Vorgang verwendet wird und der Parameter bucket Null ists3Location.

InvalidRequestException "S3 bucket name for SBOM cannot be null"

Die folgende Fehlermeldung wird angezeigt, wenn die Zeichenfolge bucket im s3Location Parameter für den AssociateSbomWithPackageVersion API-Vorgang zu lang ist.

InvalidRequestException "S3 bucket name for SBOM is illegal. String length exceeds limit"

Die folgende Fehlermeldung wird angezeigt, wenn der key Parameter Null ist.

InvalidRequestException "S3 key name for SBOM cannot be null"

Die folgende Fehlermeldung wird angezeigt, wenn die Zeichenfolge key im s3Location Parameter für den AssociateSbomWithPackageVersion API-Vorgang zu lang ist.

InvalidRequestException "S3 key name for SBOM is illegal. String length exceeds limit"

Die folgende Fehlermeldung wird angezeigt, wenn die Zeichenfolge version im s3Location Parameter für den AssociateSbomWithPackageVersion API-Vorgang Null ist.

InvalidRequestException "S3 object version for SBOM cannot be null"

Die folgende Fehlermeldung wird angezeigt, wenn die Zeichenfolge version im s3Location Parameter für den AssociateSbomWithPackageVersion API-Vorgang zu lang ist.

InvalidRequestException "S3 object version for SBOM is illegal. String length exceeds limit"

Die folgende Fehlermeldung wird angezeigt, wenn die Größe der im Amazon S3-Bucket gespeicherten SBOM-ZIP-Archivdatei zu groß ist.

InvalidRequestException "S3 object file size exceeds limit"

Die folgende Fehlermeldung wird angezeigt, wenn Sie den AssociateSbomWithPackageVersion API-Vorgang verwenden und die aktuelle Anzahl der laufenden SBOM-Validierungen bereits das Höchstlimit erreicht hat.

LimitExceededException "Too many ongoing SBOM validation workflows. Please wait and retry"

Probleme beim Zugriff auf die SBOM-Datei im Amazon S3-Bucket

Die folgende Fehlermeldung wird angezeigt, wenn eine andere Entität nicht auf den Amazon S3-Bucket zugreifen kann, weil der Amazon S3-Bucket nicht existiert oder die richtigen Berechtigungen für den Zugriff auf den Amazon S3-Bucket nicht erteilt wurden.

Weitere Informationen zur Richtlinie über die erforderlichen Berechtigungen für den Zugriff auf den Amazon S3-Bucket finden Sie unterAufbewahrung der Stückliste der Software.

InvalidRequestException "SBOM not accessible by the service. Please make sure the bucket exists and S3 permission is granted."

Die folgende Fehlermeldung wird angezeigt, wenn eine andere Entität nicht auf die SBOM-ZIP-Archivdatei im key Parameter zugreift, weil der Amazon S3-Bucket nicht existiert oder nicht die richtigen Berechtigungen für den Zugriff auf im Amazon S3-Bucket gespeicherte Inhalte erteilt wurden.

InvalidRequestException "SBOM not accessible by the service. Please make sure the key exists and S3 permission is granted."

Die folgende Fehlermeldung wird angezeigt, wenn eine andere Entität nicht auf den Amazon S3-Bucket zugreifen kann, weil der Bucket, der Schlüssel und die Versions-ID nicht existieren oder die richtigen Berechtigungen für den Zugriff auf den Amazon S3-Bucket nicht erteilt wurden. Darüber hinaus kann diese Fehlermeldung angezeigt werden, wenn die erteilten Berechtigungen für den Zugriff auf die SBOM-Zip-Archivdatei im Amazon S3-Bucket nicht ausreichen.

InvalidRequestException "SBOM not accessible by the service. Please make sure the bucket/key/version exists and S3 permission is granted."

Die folgende Fehlermeldung wird angezeigt, wenn eine andere Entität nicht auf den Amazon S3-Bucket zugreifen kann, weil sich der Bucket in einer anderen Region befindet.

InvalidRequestException "Cross-region S3 bucket for %s is not supported."

Die folgende Fehlermeldung wird angezeigt, wenn eine andere Entität nicht auf den Amazon S3-Bucket zugreifen kannbucket, weil diekey, oder version Parameter bei der Verwendung des AssociateSbomWithPackageVersion API-Vorgangs falsch geschrieben wurden.

InvalidRequestException "Please make sure SBOM S3 bucket name/key length/version is valid"