View a markdown version of this page

Beheben Sie Fehler bei der Registrierung des AD-Verzeichnisses im Connector - AWS Private Certificate Authority

Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.

Beheben Sie Fehler bei der Registrierung des AD-Verzeichnisses im Connector

Der Connector für die AD-Verzeichnisregistrierung kann aus verschiedenen Gründen fehlschlagen. Wenn die Verzeichnisregistrierung fehlschlägt, erhalten Sie den Fehlergrund in der API-Antwort. Wenn Sie die Konsole verwenden, finden Sie den Grund für den Fehler im Bereich mit den Details zur Verzeichnisregistrierung unter dem Feld Zusätzliche Statusinformationen. In der folgenden Tabelle werden die Fehlerursachen und die empfohlenen Schritte zur Behebung beschrieben.

Status des Fehlers Description Abhilfe
DIRECTORY_ACCESS_DENIED Connector für AD kann nicht auf Ihr Verzeichnis zugreifen.

Der Connector für AD unterstützt nicht das Erstellen einer Verzeichnisregistrierung oder eines Connectors in einer Replikatregion eines Verzeichnisses mit mehreren Regionen AWS Managed Microsoft AD . Wenn Sie versucht haben, eine Verzeichnisregistrierung in einer Replikatregion zu erstellen, löschen Sie die fehlgeschlagene Verzeichnisregistrierung und erstellen Sie eine neue in der primären Region des Verzeichnisses. Erstellen Sie Ihren Connector auch in der primären Region. Informationen zur multiregionalen Replikation finden Sie im AWS Directory Service Administratorhandbuch unter Multi-Region Replikation.

Sie müssen Connector for AD Zugriff auf Ihr Verzeichnis gewähren. Lesen Sie den Schritt 4: IAM-Richtlinie erstellen Abschnitt, um sicherzustellen, dass die Ihrem AWS Konto zugeordnete IAM-Richtlinie Ihnen den Zugriff auf Verzeichnisse und deren Beschreibung ermöglicht. Nachdem Sie Ihrer AWS Rolle die richtigen Berechtigungen erteilt haben, löschen Sie die fehlgeschlagene Verzeichnisregistrierung und erstellen Sie eine neue.

Wenn Sie Connector für AD mit einem AWS Directory Service AD Connector verwenden, stellen Sie sicher, dass das Passwort des AD Connector-Dienstkontos nicht abgelaufen und gültig ist. Informationen zu AD Connector-Dienstkonten finden Sie unter Erste Schritte mit AD Connector im AD Connector-Administrationshandbuch.

DIRECTORY_NOT_ACTIVE Ihr Verzeichnis befindet sich nicht im Active Status.

Ihr Verzeichnis muss sich in dem Active Bundesstaat befinden, in dem Sie eine Verzeichnisregistrierung erstellen können. Beheben Sie das Verzeichnisproblem in AWS Directory Service, löschen Sie dann die fehlgeschlagene Verzeichnisregistrierung und erstellen Sie eine neue.

DIRECTORY_NOT_REACHABLE Connector für AD kann Ihr Verzeichnis nicht erreichen.

Überprüfen Sie das Netzwerk zwischen AWS und Ihrem Verzeichnis, löschen Sie dann die fehlgeschlagene Verzeichnisregistrierung und erstellen Sie ein neues.

DIRECTORY_RESOURCE_NOT_FOUND Connector für AD kann das angegebene Verzeichnis nicht finden.

Stellen Sie sicher, dass Sie die richtige Verzeichnis-ID angeben, löschen Sie dann die fehlgeschlagene Verzeichnisregistrierung und erstellen Sie eine neue mit Ihrer gewünschten Verzeichnis-ID.

DIRECTORY_TYPE_NOT_SUPPORTED Connector für AD unterstützt diesen Verzeichnistyp nicht.

Connector für AD unterstützt AWS Managed Microsoft AD (Standard- und Enterprise-Editionen), die Sie besitzen, und AD Connector-Verzeichnisse. Connector for AD unterstützt weder die Hybrid-Edition von AWS Managed Microsoft AD Verzeichnissen noch Verzeichnisse, die ein anderes Konto mit Ihrem Konto teilt. Erstellen Sie für ein gemeinsam genutztes Verzeichnis die Verzeichnisregistrierung in dem AWS Konto, dem das Verzeichnis gehört.

INTERNAL_FAILURE Beim Connector für AD ist ein interner Fehler aufgetreten.

Bitte versuchen Sie es später erneut. Löschen Sie die fehlgeschlagene Verzeichnisregistrierung und erstellen Sie eine neue.