ListInvitations
Note
End of support notice: Amazon Managed Blockchain will stop accepting new customers on October 29, 2026. Existing customers can continue using Amazon Managed Blockchain until September 29, 2027. After September 29, 2027 you will no longer be able to access Amazon Managed Blockchain. For more information, see Amazon Managed Blockchain availability change.
Returns a list of all invitations for the current AWS account.
Applies only to Hyperledger Fabric.
Request Syntax
GET /invitations?maxResults=MaxResults&nextToken=NextToken HTTP/1.1
URI Request Parameters
The request uses the following URI parameters.
- MaxResults
-
The maximum number of invitations to return.
Valid Range: Minimum value of 1. Maximum value of 100.
- NextToken
-
The pagination token that indicates the next set of results to retrieve.
Length Constraints: Maximum length of 128.
Request Body
The request does not have a request body.
Response Syntax
HTTP/1.1 200
Content-type: application/json
{
"Invitations": [
{
"Arn": "string",
"CreationDate": "string",
"ExpirationDate": "string",
"InvitationId": "string",
"NetworkSummary": {
"Arn": "string",
"CreationDate": "string",
"Description": "string",
"Framework": "string",
"FrameworkVersion": "string",
"Id": "string",
"Name": "string",
"Status": "string"
},
"Status": "string"
}
],
"NextToken": "string"
}
Response Elements
If the action is successful, the service sends back an HTTP 200 response.
The following data is returned in JSON format by the service.
- Invitations
-
The invitations for the network.
Type: Array of Invitation objects
- NextToken
-
The pagination token that indicates the next set of results to retrieve.
Type: String
Length Constraints: Maximum length of 128.
Errors
For information about the errors that are common to all actions, see Common Error Types.
- AccessDeniedException
-
You don't have sufficient access to perform this action.
HTTP Status Code: 403
- InternalServiceErrorException
-
The request processing has failed because of an unknown error, exception or failure.
HTTP Status Code: 500
- InvalidRequestException
-
The action or operation requested is invalid. Verify that the action is typed correctly.
HTTP Status Code: 400
- ResourceLimitExceededException
-
The maximum number of resources of that type already exist. Ensure the resources requested are within the boundaries of the service edition and your account limits.
HTTP Status Code: 429
- ResourceNotFoundException
-
A requested resource doesn't exist. It may have been deleted or referenced incorrectly.
- ResourceName
-
A requested resource doesn't exist. It may have been deleted or referenced inaccurately.
HTTP Status Code: 404
- ThrottlingException
-
The request or operation couldn't be performed because a service is throttling requests. The most common source of throttling errors is creating resources that exceed your service limit for this resource type. Request a limit increase or delete unused resources if possible.
HTTP Status Code: 429
See Also
For more information about using this API in one of the language-specific AWS SDKs, see the following: