View a markdown version of this page

Protocoles et chiffrements pris en charge entre les spectateurs et CloudFront - Amazon CloudFront

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Protocoles et chiffrements pris en charge entre les spectateurs et CloudFront

Lorsque vous avez besoin du protocole HTTPS entre les spectateurs et votre CloudFront diffusion, vous devez choisir une politique de sécurité qui détermine les paramètres suivants :

  • SSL/TLS Protocole minimal CloudFront utilisé pour communiquer avec les spectateurs.

  • Chiffres que CloudFront vous pouvez utiliser pour crypter la communication avec les spectateurs.

Pour choisir une stratégie de sécurité, spécifiez la valeur applicable pour Politique de sécurité ( SSL/TLS version minimale). Le tableau suivant répertorie les protocoles et chiffrements que CloudFront vous pouvez utiliser pour chaque politique de sécurité.

Un utilisateur doit prendre en charge au moins l'un des chiffrements pris en charge pour établir une connexion HTTPS avec. CloudFront CloudFront choisit un chiffrement dans l'ordre indiqué parmi les chiffrements pris en charge par le visualiseur. Consultez également Noms de chiffrement OpenSSL, s2n et RFC.

Stratégie de sécurité
SSLv3 TLSv1 TLSv1_2016 TLSv1.1_2016 TLSv1.2_2018 TLSv1.2_2019 TLSv1.2_2021 TLSv1.2_2025 TLSv1.3_2025
SSL/TLS Protocoles pris en charge
TLSv1.3 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLSv1.2 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLSv1.1 ♦ ♦ ♦ ♦
TLSv1 ♦ ♦ ♦
SSLv3 ♦
TLSv1.3 Chiffrements pris en charge
TLS_AES_128_GCM_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_AES_256_GCM_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_CHACHA20_POLY1305_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
Chiffrements ECDSA pris en charge
ECDHE-ECDSA-AES128-GCM-SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES128-SHA256 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES128-SHA ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES256-GCM-SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-CHACHA20-POLY1305 ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES256-SHA384 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-ECDSA-AES256-SHA ♦ ♦ ♦ ♦
Chiffrements RSA pris en charge
ECDHE-RSA-AES128-GCM-SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES128-SHA256 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES128-SHA ♦ ♦ ♦ ♦
ECDHE-RSA-AES256-GCM-SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-CHACHA20-POLY1305 ♦ ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES256-SHA384 ♦ ♦ ♦ ♦ ♦ ♦
ECDHE-RSA-AES256-SHA ♦ ♦ ♦ ♦
AES128-GCM-SHA256 ♦ ♦ ♦ ♦ ♦
AES256-GCM-SHA384 ♦ ♦ ♦ ♦ ♦
AES128-SHA256 ♦ ♦ ♦ ♦ ♦
AES256-SHA ♦ ♦ ♦ ♦
AES128-SHA ♦ ♦ ♦ ♦
DES-CBC3-SHA ♦ ♦
RC4-MD5 ♦

Noms de chiffrement OpenSSL, s2n et RFC

OpenSSL et s2n utilisent des noms de chiffrement différents de ceux utilisés par les standards TLS (RFC 2246, RFC 4346, RFC 5246, et RFC 8446). Le tableau suivant met en correspondance les noms OpenSSL et s2n avec le nom RFC pour chaque chiffrement.

CloudFront prend en charge les échanges de clés classiques et quantiques sécurisés. Pour les échanges de clés classiques utilisant des courbes elliptiques, CloudFront prend en charge les options suivantes :

  • prime256v1

  • X25519

  • secp384r1

Pour les échanges de clés quantiques sécurisés, prend en CloudFront charge les éléments suivants :

Pour plus d'informations sur les exigences en matière de certificat pour CloudFront, consultezExigences relatives à l'utilisation de SSL/TLS certificats avec CloudFront.

Nom de chiffrement OpenSSL et s2n Nom de chiffrement RFC
TLSv1.3 Chiffrements pris en charge
TLS_AES_128_GCM_SHA256 TLS_AES_128_GCM_SHA256
TLS_AES_256_GCM_SHA384 TLS_AES_256_GCM_SHA384
TLS_CHACHA20_POLY1305_SHA256 TLS_CHACHA20_POLY1305_SHA256
Chiffrements ECDSA pris en charge
ECDHE-ECDSA-AES128-GCM-SHA256 TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256
ECDHE-ECDSA-AES128-SHA256 TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256
ECDHE-ECDSA-AES128-SHA TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA
ECDHE-ECDSA-AES256-GCM-SHA384 TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384
ECDHE-ECDSA-CHACHA20-POLY1305 TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256
ECDHE-ECDSA-AES256-SHA384 TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384
ECDHE-ECDSA-AES256-SHA TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA
Chiffrements RSA pris en charge
ECDHE-RSA-AES128-GCM-SHA256 TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
ECDHE-RSA-AES128-SHA256 TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
ECDHE-RSA-AES128-SHA TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA
ECDHE-RSA-AES256-GCM-SHA384 TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
ECDHE-RSA-CHACHA20-POLY1305 TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256
ECDHE-RSA-AES256-SHA384 TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
ECDHE-RSA-AES256-SHA TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
AES128-GCM-SHA256 TLS_RSA_WITH_AES_128_GCM_SHA256
AES256-GCM-SHA384 TLS_RSA_WITH_AES_256_GCM_SHA384
AES128-SHA256 TLS_RSA_WITH_AES_128_CBC_SHA256
AES256-SHA TLS_RSA_WITH_AES_256_CBC_SHA
AES128-SHA TLS_RSA_WITH_AES_128_CBC_SHA
DES-CBC3-SHA TLS_RSA_WITH_3DES_EDE_CBC_SHA
RC4-MD5 TLS_RSA_WITH_RC4_128_MD5

Schémas de signature pris en charge entre les spectateurs et CloudFront

CloudFront prend en charge les schémas de signature suivants pour les connexions entre les spectateurs etCloudFront.

Politique de sécurité
Schémas de signature SSLv3 TLSv1 TLSv1_2016 TLSv1.1_2016 TLSv1.2_2018 TLSv1.2_2019 TLSv1.2_2021 TLSv1.2_2025 TLSv1.3_2025
TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA224 ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA512 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA224 ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SECP256R1_SHA256 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SECP384R1_SHA384 ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA1 ♦ ♦ ♦ ♦
TLS_SIGNATURE_SCHEME_ECDSA_SHA1 ♦ ♦ ♦ ♦