View a markdown version of this page

Dépanner Amazon EC2 Auto Scaling : échecs de lancement d'instance EC2 - Amazon EC2 Auto Scaling
La configuration demandée n'est actuellement pas prise en charge.Le < nom du groupe de sécurité > n'existe pas. Échec du lancement de l'instance EC2.La paire de < clés associée à votre instance EC2 > n'existe pas. Échec du lancement de l'instance EC2.Le type d'instance que vous avez demandé (type d'<instance>) n'est pas pris en charge dans la zone de disponibilité que vous avez demandée (zone de disponibilité de l'<instance>)...Votre prix de demande Spot de 0,015 est inférieur au prix minimum requis d'exécution de la demande Spot de 0,0735...Nom d'appareil non valide Nom de < l'appareil>/Téléchargement d'un nom d'appareil non valide. Échec du lancement de l'instance EC2.La valeur (<nom associé au périphérique de stockage d'instance>) du paramètre VirtualName n'est pas valide... Échec du lancement de l'instance EC2.Les mappages de périphérique de stockage en mode bloc EBS ne sont pas pris en charge pour les AMI de stockage d'instance.Les groupes de placement ne peuvent pas être utilisés avec des instances de type « type d'<instance > ». Échec du lancement de l'instance EC2.Client.InternalError: erreur du client au lancement.Nous ne disposons pas actuellement d'une > capacité de type d'<instance suffisante dans la zone de disponibilité que vous avez demandée... Échec du lancement de l'instance EC2.La réservation demandée ne dispose pas d’une capacité compatible et disponible suffisante pour cette demande. Échec du lancement de l'instance EC2.Votre numéro de < réservation Capacity Block n'>est pas encore actif. Échec du lancement de l'instance EC2.Il n'y a pas de capacité ponctuelle disponible qui correspond à votre demande. Échec du lancement de l'instance EC2.<nombre d'instances (>instances) sont déjà en cours d'exécution. Échec du lancement de l'instance EC2.

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Dépanner Amazon EC2 Auto Scaling : échecs de lancement d'instance EC2

Cette page fournit des informations sur les instances EC2 dont le lancement échoue, les causes potentielles et les étapes à suivre pour résoudre le problème.

Pour récupérer un message d'erreur, consultez Récupérer un message d'erreur à partir d'activités de mise à l'échelle.

Lorsque des instances EC2 échouent lors du lancement, un ou plusieurs des messages d'erreur suivants peuvent s'afficher :

Problèmes de lancement

La configuration demandée n'est actuellement pas prise en charge.

Cause  : Certaines options de votre modèle de lancement ou de votre configuration de lancement peuvent ne pas être compatibles avec le type d'instance, ou la configuration de l'instance n'est peut-être pas prise en charge dans AWS la région ou les zones de disponibilité que vous avez demandées.

Solution  : essayez une autre configuration d'instance. Pour rechercher un type d'instance qui répond à vos besoins, consultez la section Trouver un type d'instance Amazon EC2 dans le guide de l'utilisateur Amazon EC2.

Pour plus d'informations sur la solution de ce problème, consultez les informations suivantes :

  • Assurez-vous que vous avez choisi une AMI qui est prise en charge par votre type d'instance. Par exemple, si le type d'instance utilise un processeur Arm-based AWS Graviton au lieu d'un processeur Intel Xeon, vous avez besoin d'une Arm-compatible AMI. Pour plus d'informations sur le choix d'un type d'instance compatible, consultez la section Compatibilité pour modifier le type d'instance dans le guide de l'utilisateur Amazon EC2.

  • Vérifiez que le type d'instance est disponible dans vos régions et zones de disponibilité demandées. Les types d'instance de la nouvelle génération peuvent ne pas encore être disponibles dans une région ou une zone de disponibilité donnée. Les types d'instance de génération ancienne peuvent ne pas être disponibles dans les régions et zones de disponibilité les plus récentes. Pour rechercher les types d'instance offerts par emplacement (région ou zone de disponibilité), utilisez la commande describe-instance-type-offerings. Pour plus d'informations, consultez la section Trouver un type d'instance Amazon EC2 dans le guide de l'utilisateur Amazon EC2.

  • Si vous utilisez des instances dédiées ou des hôtes dédiés, assurez-vous que vous avez choisi un type d'instance pris en charge en tant qu'Instance dédiée ou Hôte dédié.

Le < nom du groupe de sécurité > n'existe pas. Échec du lancement de l'instance EC2.

Cause : le groupe de sécurité spécifié dans le modèle de lancement ou la configuration du lancement peut avoir été supprimé.

Solution :

  1. Utilisez la commande describe-security-groups pour obtenir la liste des groupes de sécurité associés au compte.

  2. Dans la liste, sélectionnez le groupe de sécurité à utiliser. Pour créer un groupe de sécurité à la place, utilisez la commande create-security-group.

  3. Créez un modèle de lancement ou une configuration du lancement.

  4. Mettez à jour votre groupe Auto Scaling avec le nouveau modèle de lancement ou la nouvelle configuration du lancement à l'aide de la commande update-auto-scaling-group.

La paire de < clés associée à votre instance EC2 > n'existe pas. Échec du lancement de l'instance EC2.

Cause : la paire de clés utilisée lors du lancement de l'instance peut avoir été supprimée.

Solution :

  1. Utilisez la commande describe-key-pairs pour obtenir la liste des paires de clés disponibles pour vous.

  2. Dans la liste, sélectionnez la paire de clés à utiliser. Pour créer une paire de clés à la place, utilisez la commande create-key-pair.

  3. Créez un modèle de lancement ou une configuration du lancement.

  4. Mettez à jour votre groupe Auto Scaling avec le nouveau modèle de lancement ou la nouvelle configuration du lancement à l'aide de la commande update-auto-scaling-group.

Le type d'instance que vous avez demandé (type d'<instance>) n'est pas pris en charge dans la zone de disponibilité que vous avez demandée (zone de disponibilité de l'<instance>)...

Message d’erreur : le type d’instance demandé (<type d’instance>) n’est pas pris en charge dans la zone de disponibilité demandée (<zone de disponibilité de l’instance>)…Échec du lancement de l’instance EC2.

Cause : les zones de disponibilité indiquées dans le groupe Auto Scaling ne prennent pas en charge le type d’instance que vous avez choisi.

Solution :

  1. Vérifiez quelles zones de disponibilité prennent en charge le type d’instance que vous avez choisi à l’aide de la commande describe-instance-type-offerings ou depuis la console Amazon EC2 en vérifiant la valeur des zones de disponibilité dans le volet réseau de la page Types d’instances.

  2. Mettez à jour ou supprimez le sous-réseau pour toutes les zones non prises en charge dans les paramètres de votre groupe Auto Scaling à l’aide de la commande update-auto-scaling-group. Pour de plus amples informations, veuillez consulter Ajouter une zone de disponibilité.

Votre prix de demande Spot de 0,015 est inférieur au prix minimum requis d'exécution de la demande Spot de 0,0735...

Cause : le prix Spot maximum de votre demande est inférieur au prix Spot pour le type d'instance que vous avez sélectionné.

Solution  : soumettez une nouvelle demande avec un prix maximum Spot plus élevé (éventuellement le On-Demand prix). Auparavant, le prix Spot que vous aviez payé était basé sur des enchères. Aujourd'hui, vous payez le prix Spot actuel. En fixant votre prix maximum plus élevé, cela donne au service Amazon EC2 Spot plus de chances de lancer et de maintenir la quantité de capacité requise.

Nom d'appareil non valide Nom de < l'appareil>/Téléchargement d'un nom d'appareil non valide. Échec du lancement de l'instance EC2.

Cause 1 : les mappages de périphérique de stockage en mode bloc dans le modèle de lancement ou la configuration du lancement peuvent contenir des noms de périphérique de stockage en mode bloc indisponibles ou non pris en charge actuellement.

Solution :

  1. Vérifiez quels noms de périphériques sont disponibles pour votre configuration d'instance spécifique. Pour plus de détails sur la dénomination des appareils, consultez la section Noms des appareils sur les instances Linux dans le guide de l'utilisateur Amazon EC2.

  2. Créez manuellement une instance Amazon EC2 qui ne fait pas partie du groupe Auto Scaling et examinez le problème. Si la configuration du nommage des périphériques de stockage en mode bloc entre en conflit avec les noms d'Amazon Machine Image (AMI), l'instance échouera lors du lancement. Pour plus d'informations, consultez la section Bloquer les mappages d'appareils dans le guide de l'utilisateur Amazon EC2.

  3. Après avoir confirmé que votre instance a été lancée avec succès, utilisez la commande describe-volumes pour voir comment les volumes sont exposés à l'instance.

  4. Créez un modèle de lancement ou une configuration du lancement avec le nom du périphérique répertorié dans la description du volume.

  5. Mettez à jour votre groupe Auto Scaling avec le nouveau modèle de lancement ou la nouvelle configuration du lancement à l'aide de la commande update-auto-scaling-group.

La valeur (<nom associé au périphérique de stockage d'instance>) du paramètre VirtualName n'est pas valide... Échec du lancement de l'instance EC2.

Cause : le format spécifié pour le nom virtuel associé au périphérique de stockage en mode bloc est incorrect.

Solution :

  1. Créez un modèle de lancement ou une configuration du lancement en spécifiant le nom du périphérique dans le paramètre virtualName. Pour plus d'informations sur le format du nom de l'appareil, consultez la section Désignation des appareils sur les instances Linux dans le guide de l'utilisateur Amazon EC2.

  2. Mettez à jour votre groupe Auto Scaling avec le nouveau modèle de lancement ou la nouvelle configuration du lancement à l'aide de la commande update-auto-scaling-group.

Les mappages de périphérique de stockage en mode bloc EBS ne sont pas pris en charge pour les AMI de stockage d'instance.

Cause : les mappages de périphérique de stockage en mode bloc spécifiés dans le modèle de lancement ou la configuration du lancement ne sont pas pris en charge sur l'instance.

Solution :

  1. Créez un modèle de lancement ou une configuration du lancement avec des mappages de périphérique de stockage en mode bloc pris en charge par le type d'instance. Pour plus d'informations, consultez Bloquer le mappage des appareils dans le guide de l'utilisateur Amazon EC2.

  2. Mettez à jour votre groupe Auto Scaling avec le nouveau modèle de lancement ou la nouvelle configuration du lancement à l'aide de la commande update-auto-scaling-group.

Les groupes de placement ne peuvent pas être utilisés avec des instances de type « type d'<instance > ». Échec du lancement de l'instance EC2.

Cause : le groupe de placement du cluster contient un type d'instance qui n'est pas valide.

Solution :

  1. Pour plus d'informations sur les types d'instances valides pris en charge par les groupes de placement, consultez la section Groupes de placement dans le guide de l'utilisateur Amazon EC2.

  2. Suivez les instructions détaillées dans Groupes de placement pour créer un groupe de placement.

  3. Sinon, créez un modèle de lancement ou une configuration du lancement avec le type d'instance pris en charge.

  4. Mettez à jour le groupe Auto Scaling avec un nouveau groupe de placement, un nouveau modèle de lancement ou une nouvelle configuration du lancement grâce à la commande update-auto-scaling-group.

Client.InternalError: erreur du client au lancement.

Problème  : Amazon EC2 Auto Scaling essaie de lancer une instance qui possède un volume EBS chiffré, mais le rôle lié au service n'a pas accès à la clé gérée par le AWS KMS client utilisée pour le chiffrer. Pour de plus amples informations, veuillez consulter Politique de AWS KMS clé requise pour une utilisation avec des volumes chiffrés.

Cause 1 : vous avez besoin d'une politique de clé qui autorise l'utilisation de la clé gérée par le client pour le rôle lié au service approprié.

Solution 1 : autorisez le rôle lié à un service à utiliser la clé gérée par le client de la manière suivante :

  1. Déterminez quel rôle lié à un service utiliser pour ce groupe Auto Scaling.

  2. Mettez à jour la politique de clé sur la clé gérée par le client et autorisez le rôle lié à un service à utiliser la clé gérée par le client.

  3. Mettez à jour le groupe Auto Scaling afin qu'il utilise le rôle lié à un service.

Pour obtenir un exemple de politique de clé qui permet au rôle lié au service d'utiliser la clé gérée par le client, voir Exemple 1 : sections de la politique de clé qui autorisent l'accès à la clé gérée par le client.

Cause 2  : si la clé gérée par le client et le groupe Auto Scaling appartiennent à AWS des comptes différents, vous devez configurer l'accès entre comptes à la clé gérée par le client afin d'autoriser l'utilisation de la clé gérée par le client pour le rôle lié au service approprié.

Solution 2 : autorisez le rôle lié au service dans le compte externe à utiliser la clé gérée par le client dans le compte local comme suit :

  1. Mettez à jour la politique de clé sur la clé gérée par le client pour autoriser le compte de groupe Auto Scaling à accéder à la clé gérée par le client.

  2. Définissez un rôle ou un utilisateur IAM; dans le compte du groupe Auto Scaling capable de créer un octroi.

  3. Déterminez quel rôle lié à un service utiliser pour ce groupe Auto Scaling.

  4. Créez un octroi à la clé gérée par le client avec le rôle lié à un service en tant que principal bénéficiaire.

  5. Mettez à jour le groupe Auto Scaling afin qu'il utilise le rôle lié à un service.

Pour de plus amples informations, veuillez consulter Exemple 2 : sections de la politique de clé autorisant l'accès entre comptes à la clé gérée par le client.

Solution 3 : utilisez une clé gérée par le client dans le même compte AWS que le groupe Auto Scaling.

  1. Copiez et rechiffrez l'instantané avec une autre clé gérée par le client qui appartient au même compte que le groupe Auto Scaling.

  2. Autorisez le rôle lié à un service à utiliser la clé gérée par le client. Consultez les étapes pour obtenir la solution 1.

Nous ne disposons pas actuellement d'une > capacité de type d'<instance suffisante dans la zone de disponibilité que vous avez demandée... Échec du lancement de l'instance EC2.

Message d'erreur : nous ne possédons actuellement pas suffisamment de capacité <type d'instance> dans la zone de disponibilité demandée (<zone de disponibilité demandée>). Le système s'occupera d'allouer de la capacité supplémentaire. Vous pouvez actuellement bénéficier de la capacité <type d'instance> en ne spécifiant pas de zone de disponibilité dans la demande ou en choisissant <liste des zones de disponibilité qui prennent actuellement en charge le type d'instance>. Échec du lancement de l'instance EC2.

Cause : la combinaison type d’instance et zone de disponibilité demandée n’est pas prise en charge pour le moment.

Solution  : Pour résoudre le problème, essayez ce qui suit :

  • Attendez quelques minutes qu’Amazon EC2 Auto Scaling trouve de la capacité pour ce type d’instance dans d’autres zones de disponibilité activées.

  • Étendez votre groupe Auto Scaling à d’autres zones de disponibilité. Pour de plus amples informations, veuillez consulter Ajouter une zone de disponibilité.

  • Suivez les meilleures pratiques d’utilisation d’un ensemble diversifié de types d’instance afin de ne pas dépendre d’un type d’instance spécifique. Pour de plus amples informations, veuillez consulter Groupes Auto Scaling combinant plusieurs types d'instances et options d'achat.

La réservation demandée ne dispose pas d’une capacité compatible et disponible suffisante pour cette demande. Échec du lancement de l'instance EC2.

Cause 1  : vous avez atteint la limite du nombre d'instances que vous pouvez lancer avec une réservation targeted On-Demand de capacité.

Solution 1  : augmentez le nombre d'instances que vous pouvez lancer avec la réservation de targeted On-Demand capacité, ou utilisez un groupe de réservations de capacité afin que tout ce qui dépasse la capacité réservée soit lancé en tant que On-Demand capacité normale. Pour de plus amples informations, veuillez consulter Utilisez les réservations de capacité dans votre groupe Auto Scaling.

Cause 2 : vous avez atteint la limite du nombre d’instances que vous pouvez lancer dans un bloc de capacité.

Avec les blocs de capacité, vous êtes limité par la quantité de capacité initialement achetée. Si le nombre de lancements est plus élevé que prévu et que vous utilisez toute la capacité disponible, cela entraîne l’échec des lancements. Les instances résiliées sont soumises à un long processus de nettoyage avant d’être complètement résiliées. Pendant ce temps, ils ne peuvent pas être réutilisés. Cela peut également provoquer d’échec des lancements. Pour de plus amples informations, veuillez consulter Cible Blocs de capacité ou réservations de capacité interruptibles à partir d'un modèle de lancement.

Solution 2  : pour résoudre le problème, essayez ce qui suit :

  • Conservez la demande telle quelle. Si une instance Capacity Block est en train de se terminer, vous devez attendre plusieurs minutes pour que l'instance finisse de se terminer et que la capacité soit à nouveau disponible. Amazon EC2 Auto Scaling continue à effectuer automatiquement la demande de lancement jusqu’à ce que la capacité devienne disponible.

  • Assurez-vous d’acheter une capacité suffisante pour faire face à votre charge de travail maximale afin de ne pas rencontrer cette erreur fréquemment.

Votre numéro de < réservation Capacity Block n'>est pas encore actif. Échec du lancement de l'instance EC2.

Cause : le bloc de capacité indiqué n’est pas encore actif.

Solution : suivez l’approche recommandée pour les blocs de capacité et utilisez le dimensionnement planifié. Cela vous permet de vous assurer d’augmenter la capacité souhaitée de votre groupe Auto Scaling uniquement lorsque la réservation est active et de la diminuer avant la fin de la réservation.

Il n'y a pas de capacité ponctuelle disponible qui correspond à votre demande. Échec du lancement de l'instance EC2.

Cause : à l'heure actuelle, il n'y a pas assez de capacité de rechange pour répondre à votre demande d'instances Spot.

Solution  : Pour résoudre le problème, essayez ce qui suit :

  • Attendez quelques minutes, car la capacité peut changer fréquemment. Amazon EC2 Auto Scaling continue à effectuer automatiquement la demande de lancement jusqu’à ce que la capacité devienne disponible.

  • Étendez votre groupe Auto Scaling à d’autres zones de disponibilité. Pour de plus amples informations, veuillez consulter Ajouter une zone de disponibilité.

  • Suivez les meilleures pratiques d’utilisation d’un ensemble diversifié de types d’instance afin de ne pas dépendre d’un type d’instance spécifique. Pour de plus amples informations, veuillez consulter Groupes Auto Scaling combinant plusieurs types d'instances et options d'achat.

<nombre d'instances (>instances) sont déjà en cours d'exécution. Échec du lancement de l'instance EC2.

Cause : vous avez atteint la limite du nombre d'instances que vous pouvez lancer dans une région. Lorsque vous créez votre AWS compte, nous fixons des limites par défaut au nombre d'instances que vous pouvez exécuter par région.

Solution  : Pour résoudre le problème, essayez ce qui suit :

  • Vos limites actuelles ne sont pas adaptées à vos besoins, vous pouvez demander une augmentation des quotas par région. Pour plus d'informations, consultez la section Quotas de service Amazon EC2 dans le guide de l'utilisateur Amazon EC2.

  • Envoyez une nouvelle demande avec un nombre réduit d'instances (que vous pouvez augmenter à un stade ultérieur).