Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.
Création d'autorisations Windows Server pour vos machines virtuelles
Après avoir créé un vCenter Connector, vous créez des droits Windows Server pour une ou plusieurs machines virtuelles (VM) exécutées dans votre environnement Amazon EVS. Une fois que vous avez créé un droit, Amazon EVS commence à surveiller l'utilisation des droits Windows Server de la machine virtuelle correspondante.
Prenez note des contraintes d'éligibilité suivantes :
-
Le connecteur vCenter doit être dans un état actif et son vérificateur d'accessibilité doit être dans un état Passé. Pour plus d'informations sur la création d'un connecteur, consultez Création d'un connecteur vCenter.
-
Vous pouvez créer des droits pour un maximum de 100 machines virtuelles en une seule demande.
Vous ajoutez chaque machine virtuelle par son ID de machine virtuelle (Managed Object ID). Pour trouver l'ID d'objet géré d'une machine virtuelle, connectez-vous à vCenter et sélectionnez la machine virtuelle. L'ID de l'objet géré apparaît dans la barre d'adresse du navigateur dans le cadre de l'URL.
Pour créer un droit Amazon EVS
Exemple
Raisons pour lesquelles un droit peut passer à l'état CREATE_FAILED
Lorsque vous créez un droit, Amazon EVS valide la configuration de chaque machine virtuelle. Surveillez l'état de l'admissibilité pour vous assurer qu'elle aboutit. Si la validation d'une machine virtuelle échoue, son statut d'autorisation est défini CREATE_FAILED avec les détails de l'erreur. Après avoir résolu le problème sous-jacent pour cette machine virtuelle, vous devez créer à nouveau le droit.
Note
Les droits de l'CREATE_FAILEDÉtat sont automatiquement supprimés au bout de 90 jours.
La création d'un droit peut échouer pour les raisons suivantes.
VM introuvable
L'ID de machine virtuelle (ID d'objet géré) que vous avez spécifié ne figure pas dans l'inventaire vCenter ciblé par le connecteur.
- Cause
-
L'ID de machine virtuelle est incorrect ou la machine virtuelle n'existe pas dans le dispositif vCenter vers lequel pointe le connecteur.
- Résolution
-
-
Vérifiez que l'ID de machine virtuelle est correct.
-
Vérifiez que la machine virtuelle existe dans le vCenter ciblé par le connecteur.
-
Créez à nouveau le droit.
-
La machine virtuelle est déconnectée, orpheline ou inaccessible
La machine virtuelle spécifiée est déconnectée, orpheline ou inaccessible dans le vCenter.
- Cause
-
Cela est généralement dû à un problème d'hôte ou de réseau sous-jacent.
- Résolution
-
-
Vérifiez l'état de la machine virtuelle dans vCenter.
-
Résolvez le problème d'hôte ou de réseau afin que la machine virtuelle ne soit plus déconnectée, orpheline ou inaccessible.
-
Créez à nouveau le droit.
-
Système d'exploitation client non pris en charge
Le système d'exploitation client configuré dans les paramètres de la machine virtuelle dans vCenter doit être Windows Server 2016 ou version ultérieure. La validation échoue s'il ne s'agit pas de Windows, s'il s'agit d'un système d'exploitation client Windows tel que Windows 10 ou Windows 11 au lieu de Windows Server, ou s'il s'agit d'une version de Windows Server antérieure à 2016.
- Cause
-
Le système d'exploitation client configuré dans les paramètres de la machine virtuelle n'est pas une version de Windows Server prise en charge.
- Résolution
-
-
Vérifiez le système d'exploitation client configuré dans les paramètres de la machine virtuelle dans vCenter.
-
Reconfigurez les paramètres de la machine virtuelle pour spécifier une version de Windows Server prise en charge (2016 ou version ultérieure).
-
Créez à nouveau le droit.
-
Après avoir créé des droits pour vos machines virtuelles Windows, activez Windows Server sur les machines virtuelles autorisées. Consultez la section Activation de Windows Server sur les machines virtuelles autorisées.