View a markdown version of this page

AWS IoT Résolution des problèmes liés au catalogue de packages logiciels de gestion des périphériques - AWS IoT Core

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

AWS IoT Résolution des problèmes liés au catalogue de packages logiciels de gestion des périphériques

Il s'agit de la section de dépannage du catalogue de packages logiciels de gestion des AWS IoT périphériques.

Messages d'erreur de dépannage généraux

Cette section répertorie les erreurs courantes observées tout au long du cycle de vie des versions des packages logiciels.

Erreurs HeadBucket

Les messages d'erreur suivants s'affichent lorsque vous appelez l'opération d'HeadBucketAPI ou la commande head-bucket CLI pour valider le compartiment Amazon S3 utilisé pour le téléchargement de fichiers lors du déploiement d'une tâche.

Pour plus d'informations sur l'utilisation d'un compartiment Amazon S3 pour charger des fichiers lors du déploiement d'une tâche, consultezURL présignée pour le téléchargement de fichiers.

InvalidRoleException "Permission denied when attempting to use role %s to access bucket %s."
InvalidRequestException "Cross region S3 bucket is not supported for presigned url upload placeholder"
InvalidRequestException "S3 bucket in job document presigned url upload placeholder not found"
InvalidRequestException "Given S3 bucket name is invalid."
InvalidRequestException "Provided S3 bucket is not valid: %s. Error: %s"

Amazon S3 GetObject

Le message d'erreur suivant s'affiche lorsqu'un argument non valide est fourni, ce qui entraîne l'échec de l'opération de l'GetObjectAPI Amazon S3.

InvalidRequestException "Provided argument for presigned url is invalid"

Prise en charge de l'ID de version Amazon S3

Lorsque vous demandez l'accès à un compartiment Amazon S3 à l'aide du contrôle de version, assurez-vous d'inclure votre erreur versionId ou l'erreur ci-dessous peut apparaître.

Pour plus d'informations sur les compartiments Amazon S3 utilisant le contrôle de version, voir Utilisation du contrôle de version dans les compartiments Amazon S3

InvalidRequestException "VersionId not found when attempting to access s3 url"

Espaces réservés à l'intérieur d'une URL présignée pour le téléchargement de fichiers

Les messages d'erreur suivants apparaissent lorsque vous rencontrez des problèmes liés à un espace réservé dans une URL présignée utilisée pour charger des fichiers vers un compartiment Amazon S3 de destination lors du déploiement d'une tâche. Pour plus d'informations sur l'utilisation d'un compartiment Amazon S3 pour charger des fichiers lors du déploiement d'une tâche et sur la définition d'un espace réservé local, consultez. URL présignée pour le téléchargement de fichiers

Le message d'erreur ci-dessous s'affiche lorsque l'espace réservé local n'est pas reconnu.

InvalidJobDocumentException "Undefined placeholder, ${...}, inside of presign url upload parameter"

Le message d'erreur ci-dessous s'affiche lorsque vous tentez d'utiliser l'espace réservé local dans une URL présignée qui n'est pas destinée au téléchargement de fichiers.

InvalidJobDocumentException "Local placeholder, ${...}, is only valid inside of presign url upload"

URL Amazon S3 imbriquée de manière incorrecte

Le message d'erreur suivant s'affiche lorsque l'URL Amazon S3 n'est pas correctement imbriquée dans un autre espace réservé.

InvalidJobDocumentException "${aws:%s[...]} should not be the second layer pattern."

Version du paquet : Artifact Nesting

Le message d'erreur suivant s'affiche lorsque l'URL présignée de l'artefact de la version du package est incorrectement imbriquée dans un autre espace réservé.

InvalidJobDocumentException "${aws:iot:package:[...]:artifact:s3-presigned-url} cannot be nested inside another placeholder."

Artefact de version de package manquant

Le message d'erreur suivant s'affiche lorsque l'artefact de la version du package référencé est introuvable.

InvalidJobDocumentException "Package %s version %s does not have an associated artifact to generate an S3 presigned url."

Espaces réservés au package logiciel et à la version du package

Le message d'erreur suivant s'affiche lorsque l'espace réservé au document de travail pour le package logiciel et la version du package ne parvient pas à obtenir les valeurs valides souhaitées pour le déploiement de la tâche en raison de plusieurs packages logiciels et versions de packages référencés dans le destinationPackageVersions paramètre ou dans l'onglet Version ARN de la page de détails de la version du package.

InvalidJobDocumentException "Cannot resolve empty package name and version name given multiple elements in destination package versions."

Utilisation du package logiciel vide et de la version du package

Le message d'erreur suivant s'affiche lorsque vous tentez d'utiliser un package vide ou une version de package sans l'autre dans un document de travail.

InvalidJobDocumentException "Empty package name and version name have to be used in pair."

Utilisation de valeurs nulles dans le document de travail

Le message d'erreur suivant s'affiche lorsque vous tentez de spécifier $null une version de package dans le document de travail. $nullne peut être utilisé qu'à l'intérieur du destinationPackageVersions paramètre lors de l'utilisation de l'opération CreateJob API.

InvalidJobDocumentException "$null is not allowed to be referenced as a package version in job documents."

Tous les attributs d'une version de package

Le message d'erreur suivant s'affiche lorsque vous tentez d'utiliser tous les attributs d'une version de package et de l'entourer de texte supplémentaire ou d'espaces réservés.

Pour plus d'informations sur l'utilisation de tous les attributs d'une version de package logiciel, voir Paramètres de substitution pour AWS IoT jobs

InvalidJobDocumentException "The package version attribute placeholder for all attributes has to be a json value by itself and not appended with other strings or nested with other placeholders."

Limite d'espaces réservés locaux dans l'URL présignée pour le téléchargement de fichiers

Le message d'erreur suivant s'affiche lorsque vous dépassez la limite du nombre d'espaces réservés locaux utilisés dans une URL présignée pour le téléchargement de fichiers lors du déploiement d'une tâche.

Pour plus d'informations sur l'utilisation d'une URL présignée pour le téléchargement de fichiers lors du déploiement d'une tâche, voir URL présignée pour le téléchargement de fichiers

InvalidJobDocumentException "The occurrence of local placeholder %s within S3 presigned url upload placeholder exceeds limit of %d."

Espaces réservés locaux dans un compartiment Amazon S3

Le message d'erreur suivant s'affiche lorsque vous tentez de placer une URL d'espace réservé locale dans le nom du compartiment Amazon S3 pour un espace réservé d'URL présigné utilisé pour le téléchargement de fichiers lors du déploiement d'une tâche.

Pour plus d'informations sur l'utilisation d'une URL présignée pour le téléchargement de fichiers lors du déploiement d'une tâche, voir URL présignée pour le téléchargement de fichiers

InvalidJobDocumentException "S3 bucket name in presigned url upload is not allowed to contain any placeholders"

Supports d'ouverture et de fermeture

Le message d'erreur suivant s'affiche lorsque vous ajoutez un paramètre ou un espace réservé à un document de travail sans accolade fermante «} ».

InvalidJobDocumentException "One or more parameters or placeholders are not terminated."

Rôle IAM avec URL présignée Amazon S3

Le message d'erreur suivant s'affiche lorsque vous tentez d'utiliser une URL présignée Amazon S3 dans un document de travail sans rôle IAM.

Pour plus d'informations sur les URL présignées Amazon S3, consultez la section Utilisation des URL présignées.

InvalidRequestException "presignedUrlConfig role ARN is required to generate an S3 presigned url in job document."

Rôle IAM avec URL présignée Amazon S3 pour Package Version Artifact

Le message d'erreur suivant s'affiche lorsque vous tentez d'utiliser une URL présignée Amazon S3 représentant un artefact de version de package dans un document de travail sans rôle IAM.

InvalidRequestException "presignedUrlConfig role ARN is required to generate an S3 presigned url in job document for package %s version %s artifact."

Messages d'erreur relatifs à la nomenclature logicielle

Cette section répertorie les erreurs courantes associées à une nomenclature logicielle (SBOM) liée à une version de package.

Validation des entrées pour la demande d'association SBOM

Le message d'erreur suivant s'affiche lors de l'utilisation de l'opération AssociateSbomWithPackageVersion API et le s3Location paramètre est nul.

InvalidRequestException "Associate request needs to include SBOM reference"

Pour plus d'informations sur le fonctionnement de l'AssociateSbomWithPackageVersionAPI, consultez AssociateSbomWithPackageVersion.

Erreurs de validation SBOM

Cette section répertorie les erreurs courantes observées lors de la validation initiale de la nomenclature logicielle (SBOM) lorsqu'elle est associée à une version de package logiciel.

Le message d'erreur suivant s'affiche lors de l'utilisation de l'opération AssociateSbomWithPackageVersion API et bucket le s3Location paramètre est nul.

InvalidRequestException "S3 bucket name for SBOM cannot be null"

Le message d'erreur suivant s'affiche lorsque la bucket chaîne du s3Location paramètre pour l'opération AssociateSbomWithPackageVersion d'API est trop longue.

InvalidRequestException "S3 bucket name for SBOM is illegal. String length exceeds limit"

Le message d'erreur suivant s'affiche lorsque le key paramètre est nul.

InvalidRequestException "S3 key name for SBOM cannot be null"

Le message d'erreur suivant s'affiche lorsque la key chaîne du s3Location paramètre pour l'opération AssociateSbomWithPackageVersion d'API est trop longue.

InvalidRequestException "S3 key name for SBOM is illegal. String length exceeds limit"

Le message d'erreur suivant s'affiche lorsque la version chaîne du s3Location paramètre de l'opération AssociateSbomWithPackageVersion d'API est nulle.

InvalidRequestException "S3 object version for SBOM cannot be null"

Le message d'erreur suivant s'affiche lorsque la version chaîne du s3Location paramètre pour l'opération AssociateSbomWithPackageVersion d'API est trop longue.

InvalidRequestException "S3 object version for SBOM is illegal. String length exceeds limit"

Le message d'erreur suivant s'affiche lorsque la taille du fichier d'archive zip SBOM stocké dans le compartiment Amazon S3 est trop importante.

InvalidRequestException "S3 object file size exceeds limit"

Le message d'erreur suivant s'affiche lorsque vous utilisez l'opération d'AssociateSbomWithPackageVersionAPI et que le nombre actuel de validations SBOM en cours est déjà à la limite maximale.

LimitExceededException "Too many ongoing SBOM validation workflows. Please wait and retry"

Problèmes d'accès liés au fichier SBOM dans le compartiment Amazon S3

Le message d'erreur suivant s'affiche lorsqu'une autre entité ne parvient pas à accéder au compartiment Amazon S3 parce que celui-ci n'existe pas ou que les autorisations appropriées n'ont pas été accordées pour accéder au compartiment Amazon S3.

Pour plus d'informations sur la politique d'autorisations requises pour accéder au compartiment Amazon S3, consultezLogiciel de stockage des nomenclatures.

InvalidRequestException "SBOM not accessible by the service. Please make sure the bucket exists and S3 permission is granted."

Le message d'erreur suivant s'affiche lorsqu'une autre entité ne parvient pas à accéder au fichier d'archive zip SBOM dans le key paramètre parce que le compartiment Amazon S3 n'existe pas ou que les autorisations appropriées n'ont pas été accordées pour accéder au contenu stocké dans le compartiment Amazon S3.

InvalidRequestException "SBOM not accessible by the service. Please make sure the key exists and S3 permission is granted."

Le message d'erreur suivant s'affiche lorsqu'une autre entité ne parvient pas à accéder au compartiment Amazon S3 parce que le compartiment, la clé et l'ID de version n'existent pas ou que les autorisations appropriées n'ont pas été accordées pour accéder au compartiment Amazon S3. En outre, ce message d'erreur peut apparaître si les autorisations accordées sont insuffisantes pour accéder au fichier d'archive zip SBOM dans le compartiment Amazon S3.

InvalidRequestException "SBOM not accessible by the service. Please make sure the bucket/key/version exists and S3 permission is granted."

Le message d'erreur suivant s'affiche lorsqu'une autre entité ne parvient pas à accéder au compartiment Amazon S3 car celui-ci se trouve dans une autre région.

InvalidRequestException "Cross-region S3 bucket for %s is not supported."

Le message d'erreur suivant s'affiche lorsqu'une autre entité ne parvient pas à accéder au compartiment Amazon S3 en raison d'une orthographe incorrecte du bucketkey, ou des version paramètres lors de l'utilisation de l'opération d'AssociateSbomWithPackageVersionAPI.

InvalidRequestException "Please make sure SBOM S3 bucket name/key length/version is valid"