View a markdown version of this page

Résoudre les problèmes d'enregistrement du Connector pour les annuaires AD - Autorité de certification privée AWS

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Résoudre les problèmes d'enregistrement du Connector pour les annuaires AD

L'enregistrement du connecteur pour l'annuaire AD peut échouer pour diverses raisons. Lorsque l'enregistrement de l'annuaire échoue, vous recevez la raison de l'échec dans la réponse de l'API. Si vous utilisez la console, vous pouvez trouver la raison de l'échec dans le volet Détails de l'enregistrement dans le répertoire, sous le champ Informations de statut supplémentaires. Le tableau suivant décrit les raisons des défaillances et les étapes recommandées pour les résoudre.

État de défaillance Description Correction
DIRECTORY_ACCESS_DENIED Connector for AD ne peut pas accéder à votre répertoire.

Connector for AD ne prend pas en charge la création d'un enregistrement d'annuaire ou d'un connecteur dans une région réplique d'un AWS Managed Microsoft AD répertoire multirégional. Si vous avez tenté de créer un enregistrement de répertoire dans une région de réplication, supprimez l'enregistrement d'annuaire qui a échoué et créez-en un nouveau dans la région principale du répertoire. Créez également votre connecteur dans la région principale. Pour plus d'informations sur la réplication multirégion, consultez la section Multi-Region Réplication dans le Guide AWS Directory Service d'administration.

Vous devez autoriser Connector for AD à accéder à votre annuaire. Consultez cette Étape 4 : Création d'une politique IAM section pour vous assurer que la politique IAM associée à votre AWS compte vous permet d'accéder aux annuaires et de les décrire. Après avoir accordé les autorisations appropriées à votre AWS rôle, supprimez l'enregistrement du répertoire qui a échoué et créez-en un nouveau.

Si vous utilisez Connector for AD avec un connecteur AWS Directory Service AD, assurez-vous que le mot de passe du compte de service AD Connector n'est pas expiré et qu'il est valide. Pour plus d'informations sur les comptes de service AD Connector, consultez la section Démarrage avec AD Connector dans le Guide d'administration d'AD Connector.

DIRECTORY_NOT_ACTIVE Votre répertoire n'est pas dans l'ActiveÉtat.

Votre répertoire doit être en Active état de créer un enregistrement dans l'annuaire. Résolvez le problème de répertoire dans AWS Directory Service, puis supprimez l'échec de l'enregistrement du répertoire et créez-en un nouveau.

DIRECTORY_NOT_REACHABLE Connector for AD ne peut pas accéder à votre répertoire.

Vérifiez le réseau entre AWS et votre répertoire, puis supprimez l'échec de l'enregistrement du répertoire et créez-en un nouveau.

DIRECTORY_RESOURCE_NOT_FOUND Connector for AD ne trouve pas le répertoire spécifié.

Assurez-vous de spécifier l'ID de répertoire correct, puis supprimez l'enregistrement de répertoire qui a échoué et créez-en un nouveau en utilisant l'ID de répertoire que vous souhaitez.

DIRECTORY_TYPE_NOT_SUPPORTED Connector for AD ne prend pas en charge ce type de répertoire.

Connector for AD prend en charge AWS Managed Microsoft AD (éditions Standard et Enterprise) que vous possédez, ainsi que les annuaires AD Connector. Connector for AD ne prend pas en charge l'édition hybride AWS Managed Microsoft AD ou les annuaires qu'un autre compte partage avec le vôtre. Pour un répertoire partagé, créez l'enregistrement du répertoire dans le AWS compte propriétaire de l'annuaire.

INTERNAL_FAILURE Le connecteur pour AD a rencontré une défaillance interne.

Réessayez ultérieurement. Supprimez l'enregistrement du répertoire qui a échoué et créez-en un nouveau.