View a markdown version of this page

Résoudre les problèmes liés à l'échec de création du connecteur AD SPN - Autorité de certification privée AWS

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Résoudre les problèmes liés à l'échec de création du connecteur AD SPN

La création d'un nom principal de service (SPN) peut échouer pour diverses raisons. Lorsque la création du SPN échoue, vous recevez la raison de l'échec dans la réponse de l'API. Si vous utilisez la console, la raison de l'échec est affichée sur la page des détails du connecteur, dans le champ Détails de statut supplémentaires du conteneur Service principal name (SPN). Le tableau suivant décrit les raisons des défaillances et les étapes recommandées pour les résoudre.

État de défaillance Description Correction
DIRECTORY_ACCESS_DENIED Connector for AD ne peut pas accéder à votre répertoire.

Accordez à Connector for AD l'accès à votre annuaire. Pour un exemple de politique IAM qui inclut des autorisations qui accordent l'accès à l'annuaire, consultezÉtape 4 : Création d'une politique IAM.

DIRECTORY_NOT_REACHABLE Connector for AD ne peut pas accéder à votre répertoire.

Vérifiez le réseau entre AWS et votre répertoire, puis essayez à nouveau de créer un SPN.

DIRECTORY_RESOURCE_NOT_FOUND Connector for AD ne trouve pas le répertoire spécifié.

Assurez-vous de spécifier l'ID de répertoire correct, puis supprimez le connecteur défaillant et créez-en un nouveau en utilisant l'ID de répertoire que vous souhaitez.

INTERNAL_FAILURE Le connecteur pour AD a rencontré une défaillance interne.

Réessayez ultérieurement.

SPN_EXISTS_ON_DIFFERENT_AD_OBJECT Le nom principal du service (SPN) existe sur un autre objet Active Directory.

Supprimez le SPN de l'objet Active Directory et essayez de créer à nouveau le SPN.

SPN_LIMIT_EXCEEDED Connector for AD ne peut pas créer le SPN car vous avez atteint la limite de SPN par répertoire. Le nombre maximum de SPN par répertoire est de 10.

Supprimez un ou plusieurs SPN de votre compte et essayez à nouveau de créer le SPN.