Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.
Résoudre les problèmes de stockage et de chiffrement
Cette section décrit les solutions possibles aux problèmes de stockage et de chiffrement.
Rubriques
Résoudre les problèmes liés aux politiques relatives aux compartiments Amazon S3 chiffrés
Description
Vous disposez d'un compartiment Amazon S3 chiffré que vous utilisez comme espace de stockage pour votre serveur Transfer Family. Si vous essayez de télécharger un fichier sur le serveur, le message d'erreur s'afficheCouldn't close
file: Permission denied.
Et si vous consultez les journaux du serveur, les erreurs suivantes s'affichent :
ERROR Message="Access denied" Operation=CLOSE Path=/bucket/user/test.txt BytesIn=13 ERROR Message="Access denied"
Cause
La politique applicable à votre utilisateur IAM n'est pas autorisé à accéder au compartiment chiffré.
Solution
Vous devez spécifier des autorisations supplémentaires dans votre politique pour accorder les autorisations requises AWS Key Management Service (AWS KMS). Pour en savoir plus, consultez Protection et chiffrement des données.
Résoudre les exceptions ResourceNotFound
Description
Vous recevez un message d'erreur indiquant que la ressource est introuvable. Par exemple, si vous exécutezUpdateServer, l'erreur suivante peut s'afficher :
An error occurred (ResourceNotFoundException) when calling the UpdateServer operation: Unknown server
Cause
La réception d'un ResourceNotFoundException message peut avoir plusieurs raisons. Dans la plupart des cas, la ressource que vous avez spécifiée dans votre commande d'API n'existe pas. Si vous avez spécifié une ressource existante, la cause la plus probable est que votre région par défaut est différente de celle de votre ressource. Par exemple, si votre région par défaut est us-east-1 et que votre serveur Transfer Family se trouve dans us-east-2, vous recevrez une exception de ressource inconnue.
Pour plus de détails sur la définition d'une région par défaut, voir Configuration rapide avec aws configure.
Solution
Ajoutez un paramètre de région à votre commande d'API pour spécifier explicitement où trouver une ressource particulière.
aws transfer -describe-server --server-idserver-id--region us-east-2