View a markdown version of this page

Résolution des problèmes de VM Import/Export - VM Import/Export

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Résolution des problèmes de VM Import/Export

Lorsque vous importez ou exportez une machine virtuelle (VM), la plupart des erreurs se produisent en raison d'une tentative d'exécution non prise en charge. Pour éviter ces erreurs, veillez à vérifier attentivement les exigences et les limites.

Une tâche d'importation peut s'arrêter avant de se terminer, puis échouer. Vous pouvez obtenir des informations sur la tâche d'importation qui semble s'être arrêtée en raison d'un échec avant qu'elle ne reprenne completed son statut. Pour recueillir ces informations, utilisez la commande appropriée à l'opération d'importation que vous avez utilisée pour décrire les détails de la tâche de conversion en cours :

Erreurs d'importation d'image

Code d'erreur : InvalidParameter, Message d'erreur : Message : Le format du paramètre disk-image-size=0 n'est pas valide

Le format de l'image spécifié n'est pas pris en charge. Réessayez l'opération avec l'un des formats d'image pris en charge suivants : VHD, VHDX, VMDK ou brut.

Une erreur client (MalformedPolicyDocument) s'est produite lors de l'appel de l' CreateRoleopération : erreurs de syntaxe dans la politique

Vous devez inclure le préfixe file:// avant le nom du document de stratégie.

ClientError: échec de la validation du disque [Erreur d'analyse du fichier OVF : OVA avec des fichiers de disque fragmentés n'est pas pris en charge]

Import/Export La machine virtuelle ne prend pas en charge l'importation de disques séparés en plusieurs fichiers. Vérifiez le format du disque et retentez l'opération avec le disque de la machine virtuelle sous forme de fichier unique.

ClientError: échec de la validation du disque [Format de fichier VMDK non pris en charge]

Le fichier VMDK doit être optimisé pour le streaming. Pour de plus amples informations, veuillez consulter Formats d'image pris en charge par VM Import/Export.

ClientError: plusieurs fichiers grub/menu .lst différents ont été trouvés

La machine virtuelle Import/Export a détecté des fichiers dupliqués au cours de la tâche d'importation pour au moins l'un des éléments suivants : grub.cfggrub.conf, oumenu.lst. Les machines virtuelles dotées de configurations à double démarrage ne sont pas prises en charge. Pour de plus amples informations, veuillez consulter Limitations relatives aux ressources importées avec une machine virtuelle Import/Export.

La fonction du service vmimport n'existe pas ou ne dispose pas d'autorisations suffisantes pour que le service continue

La fonction du service VM Import est manquant ou incorrect. Vous pouvez également recevoir cette erreur si l'utilisateur, groupe ou rôle qui tente de démarrer l'importation ne dispose pas de privilèges d'accès suffisants sur les ressources Amazon EC2.

Cette erreur peut également se produire si l'utilisateur qui appelle ImportImage a l'autorisation Decrypt, mais que le rôle vmimport n'en dispose pas. Si vous utilisez Server-Side le chiffrement avec AWS KMS—Managed Keys (SSE-KMS) pour sécuriser vos données au repos dans Amazon S3, vous devez attribuer une Decrypt autorisation supplémentaire à votre rôle de service, comme indiqué dans le code JSON suivant :

{ "Sid":"Allow vmimport to decrypt SSE-KMS key", "Effect":"Allow", "Principal":{ "AWS":[ "arn:aws:iam::accountid:role/vmimport" ] }, "Action":[ "kms:Decrypt" ], "Resource":"*" }

Erreurs d'importation d'instances

Code d'erreur : InvalidParameter, Message d'erreur : Message : Le format du paramètre disk-image-size=0 n'est pas valide

Le format de l'image spécifié n'est pas pris en charge. Réessayez l'opération avec l'un des formats d'image pris en charge suivants : OVA, VHD, VMDK ou brut.

Client.Unsupported: Aucune partition démarrable n'a été trouvée. (Service : AmazonEC2 ; Code de statut : 400 ; Code d'erreur : Unsupported ; ID de demande : <ID_demande>)

Le volume racine est partitionné par GUID Partition Table (GPT). Les volumes partitionnés par GPT ne sont pas pris en charge. Convertissez le volume racine en une partition MBR et réessayez.

ClientError: Les pieds de page ne sont pas identiques

Vous avez tenté d'importer un VHD de différenciation, ou une erreur s'est produite lors de la création du VHD. Réexportez votre machine virtuelle et réessayez de l'importer dans Amazon EC2.

ClientError: Les données non compressées ont une longueur non valide

Le fichier VMDK est corrompu. Vous pouvez essayer de réparer ou de recréer le fichier VMDK ou utiliser un autre fichier.

ERREUR : le compartiment < MyBucketName > ne se trouve pas dans la région < RegionName >, il se trouve dans < RegionName >

Le compartiment Amazon Simple Storage Service (Amazon S3) ne se trouve pas dans le même compartiment Région AWS que l'instance que vous souhaitez importer. Essayez d'ajouter l'option --ignore-region-affinity qui ignore si la région du compartiment correspond à celle où la tâche d'importation a été créée. Vous pouvez également créer un compartiment S3 à l'aide de la console Amazon Simple Storage Service et définir la région sur la région dans laquelle vous souhaitez importer la machine virtuelle. Exécutez à nouveau la commande et spécifiez le compartiment que vous venez de créer.

ERREUR : Le fichier utilise un algorithme de compression non pris en charge 0

Le VMDK a été créé à l'aide du format OVA au lieu du format OVF. Créez le VMDK au format OVF.

Emplacement de source S3 non valide

La syntaxe de la commande ou le nom du compartiment S3 est incorrect. Créez un compartiment S3 dans la région appropriée uniquement pour l'importation de machines virtuelles et téléchargez les fichiers de machine virtuelle à la racine du compartiment.

Le compartiment S3 n'est pas local par rapport à la région

Le compartiment S3 utilisé pour l'importation de machines virtuelles doit se trouver dans le même Région AWS emplacement que celui où vous souhaitez importer la machine virtuelle.

ClientError: Système d'exploitation inconnu/Fichiers de système d'exploitation manquants

Le système d'exploitation n'est pas reconnu. Vérifiez que votre système d'exploitation est répertorié comme support dans la machine virtuelle Import/Export Exigences relatives aux ressources que vous importez avec une machine virtuelle Import/Export.

Erreurs VM Export

Client.UnsupportedOperation: plusieurs volumes sont attachés à cette instance. Veuillez supprimez les volumes en trop.

Détachez des volumes autres que le volume racine et réessayez. Si vous avez besoin de données provenant des volumes, vous pouvez les copier dans le volume racine ou importer les volumes vers Amazon EBS.

Client.NotExportable: Cette instance ne peut pas être exportée. <RequestID>(Service : AmazonEC2 ; Code d'état : 400 ; Code d'erreur : NotExportable ; Numéro de demande :)

Vous ne pouvez exporter que certaines instances. Pour de plus amples informations, veuillez consulter Considérations relatives à l'exportation d'instance.

Erreur de démarrage d'instances : Valeur non valide <ID_instance> pour instanceId. L'instance n'a pas de volume attaché à la racine (/dev/sda1).

Vous avez tenté de démarrer l'instance avant l'achèvement du processus d'importation de machine virtuelle (VM Import) et de toutes les tâches de conversion. Attendez que le processus VM Import et toutes les tâches de conversion soient complètement terminés, puis démarrez l'instance.

Une erreur s'est produite (InvalidParameter) lors de l'appel de l' CreateInstanceExportTaskopération : l'objet S3 donné n'est pas local à la région.

L'instance EC2 et le compartiment S3 doivent se trouver dans la même région Région AWS. Vous devez également vous assurer que la commande create-instance-export-task est exécutée dans la même région que celle où vos ressources sont exportées. Vous spécifiez la région à l'aide du paramètre --region. Pour plus d'informations, veuillez consulter les options de ligne de commande AWS CLI dans le Guide de l'utilisateur AWS Command Line Interface .

Erreurs de machine virtuelle Windows

ClientError: Booter Networking failure/instance n'est pas accessible. Veuillez réessayer après l'installation de .Net framework 3.5 SP1 ou supérieur.

EC2 Config Service nécessite Microsoft .NET Framework 3.5 Service Pack 1 ou ultérieur. Installez Microsoft .NET Framework 3.5 Service Pack 1 ou ultérieur sur votre machine virtuelle Windows et réessayez.

FirstBootFailure: Cette demande d'importation a échoué car l'instance Windows n'a pas pu démarrer et établir la connectivité réseau.

Lorsque vous recevez le message d'erreur FirstBootFailure, cela signifie que votre image de disque virtuel n'a pas pu effectuer l'une des étapes suivantes :

  • Effectuez un démarrage et démarrez Windows.

  • Installez la mise en réseau Amazon EC2 et les pilotes de disque.

  • Utilisez une interface DHCP-configured réseau pour récupérer une adresse IP.

  • Activez Windows en utilisant la licence en volume Amazon EC2 Windows.

Les bonnes pratiques suivantes peuvent vous aider à éviter des échecs de premier démarrage Windows :

  • Désactivez les logiciels antivirus et anti-logiciels espions et les pare-feu — Ces types de logiciels peuvent empêcher l'installation de nouveaux services ou pilotes Windows ou l'exécution de fichiers binaires inconnus. Les logiciels et pare-feu peuvent être réactivés après l'importation.

  • Ne durcissez pas votre système d'exploitation - Les configurations de sécurité, parfois appelées durcissement, peuvent empêcher une installation imprévue de pilotes Amazon EC2. De nombreux paramètres de configuration Windows peuvent empêcher l'importation. Ces paramètres peuvent être réappliqués après l'importation.

  • Désactivez ou supprimez plusieurs partitions démarrables — Si votre machine virtuelle est démarrée et vous demande de choisir une partition de démarrage à utiliser, l'importation peut échouer.

Cette incapacité pour l'image de disque virtuel à démarrer et à établir la connectivité réseau peut être due à l'une des causes suivantes:

TCP/IP la mise en réseau et le DHCP ne sont pas activés

Cause  : le TCP/IP réseau et le DHCP doivent être activés.

Résolution  : Assurez-vous que la TCP/IP mise en réseau est activée. Pour plus d'informations, consultez la section Modifier TCP/IP les paramètres sur le site Web de support Microsoft. Assurez-vous que DHCP est activé. Pour de plus amples informations, consultez le Protocole DHCP (Dynamic Host Configuration Protocol) sur le site web de Microsoft.

Le rôle Hyper-V serveur est installé

Cause  : L'importation d'une machine virtuelle sur laquelle le Hyper-V rôle est installé n'est pas prise en charge.

Solution  : supprimez le Hyper-V rôle de la machine virtuelle et réessayez l'importation.

Un volume dont Windows a besoin est absent de la machine virtuelle

Cause : L'importation d'une machine virtuelle dans Amazon EC2 importe uniquement le disque de démarrage, tous les autres disques doivent être détachés et Windows doit pouvoir démarrer avant l'importation de la machine virtuelle. Par exemple, Active Directory stocke souvent la base de données Active Directory sur le lecteur D:\. Un contrôleur de domaine ne peut pas démarrer si la base de données Active Directory est absente ou inaccessible.

Résolution : Détachez les disques secondaires et réseau attachés à la machine virtuelle Windows avant d'exporter celle-ci. Déplacez les éventuelles bases de données Active Directory des lecteurs ou partitions secondaires vers la partition Windows principale. Pour plus d'informations, consultez le message d'erreur « Les services d'annuaire ne peuvent pas démarrer » lorsque vous démarrez votre contrôleur de SBS-based domaine Windows-based ou votre contrôleur de domaine sur le site Web de support Microsoft.

Windows démarre toujours dans Options de récupération système

Cause : Windows peut démarrer dans Options de récupération système pour différentes raisons, notamment si Windows est importé dans un environnement virtualisé à partir d'une machine physique, ce qui est également qualifié de processus de conversion physique-virtuel (P2V).

Résolution : Assurez-vous que Windows démarre dans une invite de connexion avant d'effectuer l'exportation et de préparer l'importation. N'importez-pas des instances Windows virtualisées issues d'une machine physique.

La machine virtuelle a été créée à l'aide d'un processus de conversion physique-à-virtuel (P2V)

Cause : Une conversion P2V a lieu lorsqu'une image de disque est créée en effectuant le processus d'installation Windows sur une machine physique, puis en important une copie de cette installation Windows dans une machine virtuelle. Les machines virtuelles créées à la suite d'une conversion P2V ne sont pas prises en charge par les machines virtuelles. Import/Export La machine virtuelle prend Import/Export uniquement en charge les images Windows installées de manière native dans la machine virtuelle source.

Résolution : Installez Windows dans un environnement virtualisé et migrez votre logiciel installé vers cette nouvelle machine virtuelle.

Échec d'activation de Windows

Cause : Lors du démarrage, Windows détecte un changement de matériel et tente une activation. Pendant la procédure d'importation, nous essayons de faire passer le mécanisme d'octroi de licence de Windows à une licence de volume fournie par Amazon Web Services. Toutefois, si le processus d'activation de Windows ne réussit pas, l'importation échoue.

Résolution : Veillez à ce que la version de Windows que vous importez prenne en charge l'octroi de licence de volume. Cela peut ne pas être le cas des versions Bêta ou d'évaluation de Windows.

Aucune partition démarrable trouvée

Cause : Lors du processus d'importation d'une machine virtuelle, nous n'avons pas pu trouver de partition de démarrage.

Résolution : Veillez à ce que le disque que vous importez présente une partition de démarrage.

Erreurs VM Linux

ClientError: Configuration non valide - Impossible de lire fstab

Les machines virtuelles Linux dotées de volumes à double démarrage ou de plusieurs /etc répertoires ne sont pas prises en charge.

ClientError: BLSC-style GRUB a été trouvé, mais impossible de détecter le noyau par défaut

La machine virtuelle ne Import/Export peut pas détecter le noyau par défaut. Cela peut se produire lorsqu'il a été déplacé hors du fichier grub.cfg principal. Vous pouvez définir la configuration sur $saved_entry et vous assurer que grubenv contient l'entrée bootloader par défaut.

ClientError: Nous n'avons pas pu lire vos importations initramfs/initrd pour déterminer les pilotes dont votre importation a besoin pour fonctionner dans EC2

Nous n'avons pas pu lire les fichiers requis lors de l'importation de votre machine virtuelle Linux pour la préparer à s'exécuter en tant qu'instance dans Amazon EC2. Vous pouvez exécuter la commande lsinitramfs pour vérifier l'intégrité du fichier. Par exemple, vous pouvez utiliser la commande suivante :

lsinitramfs /boot/initrd.img-5.4.0-77-generic 2>&1 | less

Si des erreurs sont renvoyées dans la sortie, vous pouvez essayer de reconstruire le fichier initramfs pour résoudre le problème et réimporter la machine virtuelle.

ClientError: Configuration non prise en charge - L'activation du groupe de volumes logiques a échoué

Un volume logique sur votre image de disque virtuel n'a pas pu être activé. Cela peut être le signe d'une corruption de fichier ou de disque. Vérifiez les images de disque chargées.

ClientError: Configuration non prise en charge - Plusieurs répertoires ont été trouvés

Les machines virtuelles Linux avec des volumes de démarrage multiple ou plusieurs répertoires /etc ne sont pas pris en charge.

ClientError: Version du noyau non prise en charge

La version du noyau utilisée par le système d'exploitation n'est pas prise en charge. Vérifiez que votre importation répond aux exigences répertoriées pour le système d'exploitation. Pour de plus amples informations, veuillez consulter Systèmes d'exploitation pris en charge par VM Import/Export.

Linux n'est pas pris en charge sur l'instance demandée

Des machines virtuelles Linux peuvent être importées dans certains types d'instances spécifiques. Réessayez avec l'un des types d'instances pris en charge suivants.

  • Usage général : t2.micro | t2.small | t2.medium | m3.medium | m3.large | m3.xlarge | m3.2xlarge

  • Optimisées pour le calcul  : c3.large | c3.xlarge | c3.2xlarge | c3.4xlarge | c3.8xlarge | cc1.4xlarge | cc2.8xlarge

  • Mémoire optimisée : r3.large | r3.xlarge | r3.2xlarge | r3.4xlarge | r3.8xlarge | cr1.8xlarge

  • Stockage optimisé : i2.xlarge | i2.2xlarge | i2.4xlarge | i2.8xlarge | hi1.4xlarge | hi1.8xlarge

L'importation ou l'exportation échoue en raison de liens symboliques entre les partitions

La machine virtuelle Import/Export peut échouer pour les images dont les fichiers sont des liens symboliques relatifs pointant vers une partition différente. Lors de l'importation ou de l'exportation, le service analyse les partitions de disque indépendamment, de sorte qu'il ne peut pas suivre les liens symboliques relatifs qui franchissent les limites des partitions.

Un exemple courant est Rocky Linux 8 en mode UEFI, où se /boot/grub2/grubenv trouve un lien symbolique vers un fichier sur la partition système EFI. Cependant, tout lien symbolique relatif faisant référence à un fichier sur une autre partition peut provoquer ce problème.

Pour résoudre ce problème, remplacez tous les liens symboliques relatifs concernés par une copie du fichier auquel ils font référence. Après avoir effectué la modification, recréez l'image disque ou l'AMI et recommencez l'opération.