View a markdown version of this page

AWS IoT Risoluzione dei problemi relativi al catalogo dei pacchetti software di gestione dei dispositivi - AWS IoT Core

Le traduzioni sono generate tramite traduzione automatica. In caso di conflitto tra il contenuto di una traduzione e la versione originale in Inglese, quest'ultima prevarrà.

AWS IoT Risoluzione dei problemi relativi al catalogo dei pacchetti software di gestione dei dispositivi

Questa è la sezione relativa alla risoluzione dei problemi del AWS IoT Device Management Software Package Catalog.

Messaggi di errore generali per la risoluzione dei problemi

Questa sezione elenca gli errori più comuni riscontrati durante il ciclo di vita della versione del pacchetto software.

HeadBucket errors (Errori CloudTrail)

I seguenti messaggi di errore vengono visualizzati quando si richiama l'operazione HeadBucket API o il comando head-bucket CLI per convalidare il bucket Amazon S3 utilizzato per il caricamento dei file durante l'implementazione di un processo.

Per ulteriori informazioni sull'utilizzo di un bucket Amazon S3 per caricare file durante una distribuzione di lavoro, consulta. URL prefirmato per il caricamento dei file

InvalidRoleException "Permission denied when attempting to use role %s to access bucket %s."
InvalidRequestException "Cross region S3 bucket is not supported for presigned url upload placeholder"
InvalidRequestException "S3 bucket in job document presigned url upload placeholder not found"
InvalidRequestException "Given S3 bucket name is invalid."
InvalidRequestException "Provided S3 bucket is not valid: %s. Error: %s"

Amazon S3 GetObject

Il seguente messaggio di errore si verifica quando viene fornito un argomento non valido, causando il fallimento dell'operazione dell'API Amazon GetObject S3.

InvalidRequestException "Provided argument for presigned url is invalid"

Supporto per l'ID di versione di Amazon S3

Quando richiedi l'accesso a un bucket Amazon S3 utilizzando il controllo della versione, assicurati di includere il tuo errore versionId o potrebbe comparire il seguente errore.

Per ulteriori informazioni sui bucket Amazon S3 che utilizzano il controllo delle versioni, consulta Using versioning in Amazon S3 buckets https://docs.aws.amazon.com/AmazonS3/latest/userguide/Versioning.html

InvalidRequestException "VersionId not found when attempting to access s3 url"

Segnaposto all'interno di un URL prefirmato per il caricamento dei file

I seguenti messaggi di errore vengono visualizzati quando si riscontrano problemi con un segnaposto all'interno di un URL prefirmato utilizzato per caricare file in un bucket Amazon S3 di destinazione durante una distribuzione di lavoro. Per ulteriori informazioni sull'utilizzo di un bucket Amazon S3 per caricare file durante l'implementazione di un processo e su cosa sia un segnaposto locale, consulta. URL prefirmato per il caricamento dei file

Il seguente messaggio di errore viene visualizzato quando il segnaposto locale non viene riconosciuto.

InvalidJobDocumentException "Undefined placeholder, ${...}, inside of presign url upload parameter"

Il messaggio di errore riportato di seguito viene visualizzato quando si tenta di utilizzare il segnaposto locale in un URL prefirmato non destinato al caricamento di file.

InvalidJobDocumentException "Local placeholder, ${...}, is only valid inside of presign url upload"

URL Amazon S3 annidato in modo errato

Il seguente messaggio di errore viene visualizzato quando l'URL di Amazon S3 è erroneamente annidato all'interno di un altro segnaposto.

InvalidJobDocumentException "${aws:%s[...]} should not be the second layer pattern."

Versione del pacchetto Artifact Nesting

Il seguente messaggio di errore viene visualizzato quando l'URL prefirmato dell'artefatto della versione del pacchetto è erroneamente annidato all'interno di un altro segnaposto.

InvalidJobDocumentException "${aws:iot:package:[...]:artifact:s3-presigned-url} cannot be nested inside another placeholder."

Manca un elemento relativo alla versione del pacchetto

Il seguente messaggio di errore viene visualizzato quando l'elemento della versione del pacchetto di riferimento non viene trovato.

InvalidJobDocumentException "Package %s version %s does not have an associated artifact to generate an S3 presigned url."

Segnaposto del pacchetto software e della versione del pacchetto

Il seguente messaggio di errore viene visualizzato quando il segnaposto del documento di lavoro per il pacchetto software e la versione del pacchetto non riesce a restituire i valori validi desiderati per la distribuzione del lavoro a causa di più pacchetti software e versioni del pacchetto a cui si fa riferimento nel destinationPackageVersions parametro o nella scheda ARN della versione della versione del pacchetto nella pagina dei dettagli della versione del pacchetto.

InvalidJobDocumentException "Cannot resolve empty package name and version name given multiple elements in destination package versions."

Utilizzo del pacchetto software e della versione del pacchetto vuoti

Il seguente messaggio di errore viene visualizzato quando si tenta di utilizzare un pacchetto o una versione del pacchetto vuota senza l'altra in un documento di lavoro.

InvalidJobDocumentException "Empty package name and version name have to be used in pair."

Uso nullo nel documento di lavoro

Il seguente messaggio di errore viene visualizzato quando si tenta di specificare $null come versione del pacchetto nel documento di lavoro. $nullpuò essere utilizzato solo all'interno del destinationPackageVersions parametro quando si utilizza l'operazione CreateJob API.

InvalidJobDocumentException "$null is not allowed to be referenced as a package version in job documents."

Tutti gli attributi in una versione del pacchetto

Il seguente messaggio di errore viene visualizzato quando si tenta di utilizzare tutti gli attributi in una versione del pacchetto e di circondarli con testo o segnaposto aggiuntivi.

Per ulteriori informazioni sull'utilizzo di tutti gli attributi in una versione del pacchetto software, vedere Parametri di sostituzione per AWS IoT jobs

InvalidJobDocumentException "The package version attribute placeholder for all attributes has to be a json value by itself and not appended with other strings or nested with other placeholders."

Limite di segnaposto locale nell'URL prefirmato per il caricamento dei file

Il seguente messaggio di errore viene visualizzato quando si supera il limite di segnaposti locali utilizzati in un URL prefirmato per il caricamento dei file durante la distribuzione di un lavoro.

Per ulteriori informazioni sull'utilizzo di un URL prefirmato per il caricamento di file durante l'implementazione di un lavoro, consulta URL prefirmato per il caricamento dei file

InvalidJobDocumentException "The occurrence of local placeholder %s within S3 presigned url upload placeholder exceeds limit of %d."

Segnaposto locali in un bucket Amazon S3

Il seguente messaggio di errore viene visualizzato quando si tenta di inserire un URL segnaposto locale nel nome del bucket Amazon S3 per un segnaposto URL prefirmato utilizzato per il caricamento di file durante una distribuzione di lavoro.

Per ulteriori informazioni sull'utilizzo di un URL prefirmato per il caricamento di file durante l'implementazione di un lavoro, consulta URL prefirmato per il caricamento dei file

InvalidJobDocumentException "S3 bucket name in presigned url upload is not allowed to contain any placeholders"

Apertura e chiusura delle parentesi

Il seguente messaggio di errore viene visualizzato quando si aggiunge un parametro o un segnaposto a un documento di lavoro senza la parentesi graffa «}».

InvalidJobDocumentException "One or more parameters or placeholders are not terminated."

Ruolo IAM con Amazon S3 Presigned URL

Il seguente messaggio di errore viene visualizzato quando si tenta di utilizzare un URL prefirmato di Amazon S3 in un documento di lavoro senza un ruolo IAM.

Per ulteriori informazioni sugli URL prefirmati di Amazon S3, consulta Lavorare con gli URL prefirmati.

InvalidRequestException "presignedUrlConfig role ARN is required to generate an S3 presigned url in job document."

Ruolo IAM con l'URL prefirmato di Amazon S3 per Package Version Artifact

Il seguente messaggio di errore viene visualizzato quando si tenta di utilizzare un URL prefirmato di Amazon S3 che rappresenta un artefatto della versione del pacchetto in un documento di lavoro senza un ruolo IAM.

InvalidRequestException "presignedUrlConfig role ARN is required to generate an S3 presigned url in job document for package %s version %s artifact."

Messaggi di errore relativi alla distinta base del software

Questa sezione elenca gli errori più comuni associati a una distinta base del software (SBOM) collegata a una versione del pacchetto.

Convalida dell'input per la richiesta di associazione SBOM

Quando si utilizza l'operazione AssociateSbomWithPackageVersion API, viene visualizzato il seguente messaggio di errore e il s3Location parametro è nullo.

InvalidRequestException "Associate request needs to include SBOM reference"

Per ulteriori informazioni sul funzionamento dell'AssociateSbomWithPackageVersionAPI, vedere AssociateSbomWithPackageVersion.

Errori di convalida SBOM

Questa sezione elenca gli errori più comuni riscontrati durante la convalida iniziale della distinta base del software (SBOM) quando associati a una versione del pacchetto software.

Il seguente messaggio di errore viene visualizzato quando si utilizza l'operazione AssociateSbomWithPackageVersion API e bucket nel parametro è null. s3Location

InvalidRequestException "S3 bucket name for SBOM cannot be null"

Il seguente messaggio di errore viene visualizzato quando la stringa bucket nel s3Location parametro per l'operazione AssociateSbomWithPackageVersion API è troppo lunga.

InvalidRequestException "S3 bucket name for SBOM is illegal. String length exceeds limit"

Il seguente messaggio di errore viene visualizzato quando il key parametro è nullo.

InvalidRequestException "S3 key name for SBOM cannot be null"

Il seguente messaggio di errore viene visualizzato quando la stringa key nel s3Location parametro per l'operazione AssociateSbomWithPackageVersion API è troppo lunga.

InvalidRequestException "S3 key name for SBOM is illegal. String length exceeds limit"

Il seguente messaggio di errore viene visualizzato quando la stringa version nel s3Location parametro per l'operazione AssociateSbomWithPackageVersion API è nulla.

InvalidRequestException "S3 object version for SBOM cannot be null"

Il seguente messaggio di errore viene visualizzato quando la stringa version nel s3Location parametro per l'operazione AssociateSbomWithPackageVersion API è troppo lunga.

InvalidRequestException "S3 object version for SBOM is illegal. String length exceeds limit"

Il seguente messaggio di errore viene visualizzato quando la dimensione del file di archivio zip SBOM archiviato nel bucket Amazon S3 è troppo grande.

InvalidRequestException "S3 object file size exceeds limit"

Il seguente messaggio di errore viene visualizzato quando si utilizza l'operazione AssociateSbomWithPackageVersion API e il numero attuale di convalide SBOM in corso è già al limite massimo.

LimitExceededException "Too many ongoing SBOM validation workflows. Please wait and retry"

Problemi di accesso con il file SBOM nel bucket Amazon S3

Il seguente messaggio di errore viene visualizzato quando un'altra entità non riesce ad accedere al bucket Amazon S3 perché il bucket Amazon S3 non esiste o non sono state concesse le autorizzazioni appropriate per l'accesso al bucket Amazon S3.

Per ulteriori informazioni sulla politica delle autorizzazioni richieste per accedere al bucket Amazon S3, consulta. Distinzione dei materiali del software: archiviazione

InvalidRequestException "SBOM not accessible by the service. Please make sure the bucket exists and S3 permission is granted."

Il seguente messaggio di errore viene visualizzato quando un'altra entità non riesce ad accedere al file di archivio zip SBOM nel key parametro perché il bucket Amazon S3 non esiste o non sono state concesse le autorizzazioni appropriate per accedere ai contenuti archiviati nel bucket Amazon S3.

InvalidRequestException "SBOM not accessible by the service. Please make sure the key exists and S3 permission is granted."

Il seguente messaggio di errore viene visualizzato quando un'altra entità non riesce ad accedere al bucket Amazon S3 perché il bucket, la chiave e l'ID della versione non esistono o non sono state concesse le autorizzazioni appropriate per accedere al bucket Amazon S3. Inoltre, questo messaggio di errore può apparire se le autorizzazioni concesse non sono sufficienti per accedere al file di archivio zip SBOM nel bucket Amazon S3.

InvalidRequestException "SBOM not accessible by the service. Please make sure the bucket/key/version exists and S3 permission is granted."

Il seguente messaggio di errore viene visualizzato quando un'altra entità non riesce ad accedere al bucket Amazon S3 perché il bucket si trova in un'altra regione.

InvalidRequestException "Cross-region S3 bucket for %s is not supported."

Il seguente messaggio di errore viene visualizzato quando un'altra entità non riesce ad accedere al bucket Amazon S3 a causa della digitazione errata dei version parametri bucketkey,, o quando si utilizza l'operazione API. AssociateSbomWithPackageVersion

InvalidRequestException "Please make sure SBOM S3 bucket name/key length/version is valid"