View a markdown version of this page

Windows Server の使用権限のトラブルシューティング - Amazon Elastic VMware サービス

翻訳は機械翻訳により提供されています。提供された翻訳内容と英語版の間で齟齬、不一致または矛盾がある場合、英語版が優先します。

Windows Server の使用権限のトラブルシューティング

このトピックでは、Windows Server の使用権限で発生する可能性がある一般的な問題とその解決方法について説明します。

使用権限のステータスは です AT_RISK

エンタイトルメントは、関連付けられた vCenter コネクタが到達可能性チェックに失敗AT_RISKしたとき (つまり、vCenter コネクタ到達可能性チェックのステータスが Failed と表示される) にステータスを入力します。この障害は、影響を受ける vCenter Server アプライアンスのすべての Windows Server 仮想マシン (VMs) の使用権限に影響します。

vCenter 到達可能性チェックが開始されてから 8 時間が接続の復元に失敗します。

  • 8 時間の猶予期間内に接続を復元すると、Amazon EVS はすべての失効イベントを回復し、それ以上のアクションなしで Windows Server VM の使用権限を維持します。

  • 接続が 8 時間の猶予期間内に復元されない場合、Amazon EVS はエンタイトルメントを削除し、ステータスを に変更してENTITLEMENT_REMOVED、Personal Health Dashboard 通知を送信します。Windows Server のライセンス使用状況の追跡は、接続が失われた時点で停止します。

この問題を解決するには、以下を確認してください。

  • コネクタの状態がアクティブで、到達可能性チェックのステータスが失敗であることを確認します。

  • AWS Secrets Manager に保存されているアプライアンスの認証情報が最新で正しいことを確認します。認証情報が変更された場合は、更新します。詳細については、vCenter コネクタ認証情報のローテーション」を参照してください。

  • サービスアクセスサブネットから DNS サーバーにアクセスできること、アプライアンス FQDN の DNS レコードが有効であること、重複するホスト名または IP アドレスが存在しないことを確認します。

  • ファイアウォールルールで、管理 VM VLAN サブネットへの HTTPS/SSH アクセスと DNS サーバーへの TCP/UDP アクセスが許可されていることを確認します。

  • アプライアンスが実行中でアクセス可能であることを確認します。

このガイダンスに従っても問題を解決できない場合は、 AWS サポートに連絡してサポートを受けることをお勧めします。

使用権限のステータスは です ENTITLEMENT_REMOVED

ENTITLEMENT_REMOVED ステータスのエンタイトルメントは、Amazon EVS が VM のエンタイトルメントを削除したことを示します。エンタイトルメントが削除されると、Amazon EVS は影響を受ける VM の Windows Server ライセンス使用状況の追跡を停止します。

注記

ENTITLEMENT_REMOVED ステータスが 90 日間維持されているエンタイトルメントは自動的に削除されます。

ENTITLEMENT_REMOVED ステータスは、次のシナリオから発生する可能性があります。

  • vCenter コネクタの到達可能性の障害は 8 時間の猶予期間を超えて未解決のままであるため、使用権限は から AT_RISK に移動しましたENTITLEMENT_REMOVED。詳細については、「使用権限のステータスは AT_RISK」を参照してください。

  • VM が切断されているか、孤立しているか、アクセスできないことは、通常、基盤となるホストまたはネットワークの問題を示します。

  • VM が vCenter インベントリに存在しなくなりました。

  • VM ゲスト OS がサポート対象外のバージョンに変更されました。Amazon EVS は Windows Server 2016 以降をサポートしています。

使用権限を復元するには、まず使用権限のエラーの詳細を確認して、削除の具体的な原因を特定します。次に、原因に基づいて、次の操作を行います。

  1. vCenter 到達可能性の失敗が猶予期間を超えたために使用権限が削除された場合は、vCenter Server 接続を復元します。

  2. VM が切断、孤立、またはアクセスできないために使用権限が削除された場合は、vCenter の VM の接続状態を確認し、VM が準拠状態に戻るように根本的な問題を解決します。ホストが vCenter への接続を失い、vSphere HA が別のホスト上の VM の復旧に失敗すると、VM が切断される可能性があります。ストレージ接続の問題や移行の中断により、VM が孤立する可能性があります。

  3. VM が vCenter インベントリに存在しなくなったために使用権限が削除された場合は、vCenter で VM を復元します。

  4. VM にサポートされていないゲスト OS があるためエンタイトルメントが削除された場合は、ゲスト OS をサポートされているバージョンに更新します。Amazon EVS は Windows Server 2016 以降をサポートしています。

VCF 環境の根本的な問題を解決すると、Amazon EVS は影響を受けるエンタイトルメントを検証し、その直後に自動的に復元します。権限は、VMs がコンプライアンスを復元したことを EVS が正常に検証した時点から再開されます。

このガイダンスに従っても問題を解決できない場合は、 AWS サポートに連絡してサポートを受けることをお勧めします。