View a markdown version of this page

Aurora MySQL 데이터베이스 엔진 업데이트 2026-08-27(버전 3.13.0, MySQL 8.0.45와 호환) - Amazon Aurora

기계 번역으로 제공되는 번역입니다. 제공된 번역과 원본 영어의 내용이 상충하는 경우에는 영어 버전이 우선합니다.

Aurora MySQL 데이터베이스 엔진 업데이트 2026-08-27(버전 3.13.0, MySQL 8.0.45와 호환)

버전: 3.13.0

이제 Aurora MySQL 3.13.0을 정식 버전으로 사용할 수 있으며 MySQL 8.0.45와 호환됩니다. 커뮤니티 변경 사항에 대한 자세한 내용은 MySQL 웹 사이트의 MySQL 8.0 릴리스 정보를 참조하세요. MySQL

Aurora MySQL 버전 3의 새로운 기능에 대한 자세한 내용은 Aurora MySQL 버전 3은 MySQL 8.0과 호환을 참조하세요.

Aurora MySQL 버전 3과 Aurora MySQL 버전 2의 차이점에 대한 자세한 내용은 Aurora MySQL 버전 2와 Aurora MySQL 버전 3의 비교를 참조하세요.

Aurora MySQL 버전 3과 MySQL 8.0 Community Edition의 비교 내용은 Amazon Aurora 사용 설명서의 Aurora MySQL 버전 3과 MySQL 8.0 Community Edition 비교를 참조하세요.

현재 지원되는 Aurora MySQL 버전 2 클러스터에서 Aurora MySQL 버전 3.13.0 클러스터로 업그레이드하는 방법은 제로 가동 중지 패치(ZDP)를 사용하여 현재 위치 업그레이드를 수행하거나, 스냅샷을 복원하거나, Amazon RDS 블루/그린 배포를 사용하여 관리형 블루/그린 업그레이드를 시작하는 세 가지 방법 중 하나로 가능합니다.

Aurora MySQL 버전 3으로의 업그레이드 계획에 대한 자세한 내용은 Aurora MySQL 클러스터의 메이저 버전 업그레이드 계획을 참조하세요. 일반 업그레이드 정보는 Amazon Aurora 사용 설명서의 Aurora MySQL DB 클러스터 업그레이드를 참조하세요.

문제 해결 정보는 Amazon Aurora 사용 설명서의 Aurora MySQL 현재 위치 업그레이드 문제 해결을 참조하세요.

질문이나 우려 사항이 있는 경우 커뮤니티 포럼 및를 통해를 지원 사용할 수 있습니다지원. 자세한 내용은 Amazon Aurora 사용 설명서의 DB 클러스터 유지 관리를 참조하세요.

개선 사항

보안 수정

이 릴리스에는 다음과 같은 심각도가 높은 CVEs.

이 릴리스에는 다음과 같은 중간 심각도 CVEs.

가용성 개선

  • 동시 작업(예: 성능 스키마 쿼리DROP PARTITION, 전체 텍스트 검색 최적화 또는 통계 수집)이 동일한 테이블에 액세스하는 ADD PARTITION 동안 ALTER TABLE ... REORGANIZE PARTITION, 또는를 실행할 때 데이터베이스 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 를 사용하여 열이 추가된 테이블ALTER TABLE ... REORGANIZE PARTITION에서 performance_schema.data_lock_waits 또는에 대한 쿼리가 동시에 performance_schema.data_locks 실행될 때 데이터베이스 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다ALGORITHM=INSTANT.

  • 하위 파티션 순서를 변경하는 ALTER TABLE ... REORGANIZE PARTITION SQL 문을 처리하는 동안 라이터 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 라이터 인스턴스의 DDL 작업이 리더 인스턴스의 특정 SQL 문을 차단하거나 종료할 수 있는 문제를 수정했습니다. 영향을 받는 문에는 UPDATE 또는 performance_schema 테이블TRUNCATE과 같은 쓰기 작업과 임시 테이블 및 작업에 대한 쓰기 JOIN 작업이 포함되었습니다.

  • SQL 문 처리 후 임시 테이블을 정리하는 동안 글로벌 데이터베이스 전환 작업 중에 데이터베이스 라이터 인스턴스가 예기치 않게 다시 시작될 수 있는 문제를 수정했습니다. 이렇게 다시 시작하면 전환 완료 시간이 길어질 수 있습니다.

  • 새 데이터베이스 클러스터 생성이 실패하여 클러스터를 삭제하고 다시 생성해야 하는 문제를 수정했습니다.

  • out-of-memory(OOM) 방지 메커니즘에서 중요한 메모리 압력에서 메모리 복구를 시도하는 동안 데이터베이스 인스턴스가 다시 시작될 수 있는 문제를 해결했습니다.

  • 가상 열에 인덱스가 있는 테이블의 실행 취소 레코드를 제거하는 동안 라이터 인스턴스가 다시 시작될 때 라이터 인스턴스가 반복적으로 다시 시작될 수 있는 문제를 수정했습니다.

  • 라이터 인스턴스가 binlog가 활성화된 상태에서 대규모 트랜잭션을 커밋할 때 읽기 전용 복제본이 다시 시작될 수 있는 문제를 수정했습니다. 이 문제로 인해 대용량 트랜잭션이 포함된 binlog 파일을 읽을 때 오류가 발생할 수도 있습니다.

  • Aurora serverless 조정 작업 중에 InnoDB 버퍼 풀 크기 조정이 지연되어 데이터베이스 인스턴스가 응답하지 않고 다시 시작될 수 있는 문제를 수정했습니다.

  • 라이터 인스턴스가 실행 취소 로그를 강제로 제거하는 동안 다시 시작한 후 리더 인스턴스가 반복적으로 다시 시작될 수 있는 문제를 수정했습니다.

  • 로컬 또는 글로벌 쓰기 전달이 활성화된 상태에서 리더 DB 인스턴스가 다시 시작될 때 라이터 DB 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 병렬 쿼리 요청을 사용하는 하위 쿼리가 완료 시 올바르게 닫히지 않은 경우 리더 인스턴스에서 예기치 않은 데이터베이스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 쓰기 전달을 통해 라이터에 전달되는 이진 프로토콜 준비 문을 실행할 때 복제본 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 동시 쓰기 작업이 많을 때 내부 타이밍 충돌로 인해 라이터 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 향상된 binlog가 활성화된 경우 데이터베이스 인스턴스가 다시 시작될 수 있는 문제를 수정했습니다.

  • 복제본의 연결을 잠시 끊었다가 라이터에 다시 연결하여 복제 지연()이 일시적으로 급증할 수 있는 버그를 수정했습니다AuroraReplicaLag.

  • 드문 경우지만 데이터베이스가 예기치 않게 다시 시작될 수 있는 Aurora 스토리지 데몬 문제를 수정했습니다.

  • 여러 스레드를 사용하여 리더 인스턴스에 라이터 인스턴스의 변경 사항을 적용하여 Aurora 물리적 복제의 성능을 개선했습니다.

일반적인 개선 사항

  • 쓰기 전달이 활성화된 상태에서가 로 aurora_replica_read_consistency 설정된 리더 세션이 최근에 커밋된 변경 사항을 읽지 global 못하는 문제를 해결했습니다.

  • 공간 GIS 쿼리가 명시적 SRID 주석으로 선언된 열에서 Z 순서 공간 인덱스를 사용할 때 엔진이 다시 시작될 수 있는 문제를 수정했습니다.

  • 쓰기 전달이 활성화된 경우 라이터 인스턴스Aborted_clients에서 정상적인 리더 연결 해제가 잘못 증가할 수 있는 문제를 수정했습니다.

  • 버퍼 풀 크기 조정 또는 페이지 제거 작업 중에 지속적 SQL 문을 임시 테이블에서 읽을 때 데이터베이스 인스턴스가 다시 시작될 수 있는 자주 발생하지 않는 문제를 수정했습니다.

  • replica_preserve_commit_order 설정을 올바르게 적용하도록 향상된 Binlog가 활성화된 binlog 복제본의 커밋 순서를 수정했습니다. 이러한 순서 지정 동작은 비의존적 트랜잭션의 순서 지정에만 적용되므로 데이터 무결성에 영향을 미치거나 트랜잭션 간에 충돌을 일으키지 않았습니다.

  • 범위 비교 및와 ORDER BY DESC 함께를 사용할 때 요청된 내림차순이 아닌 오름차순으로 쿼리 결과가 반환될 수 있는 문제를 수정했습니다LIMIT.

  • 시스템 테이블의 DML 작업이 오래된 자동 증가 값을 참조할 때 데이터베이스 서버 업그레이드 중에 발생할 수 있는 클러스터 가용성 문제를 수정했습니다.

  • aurora_in_memory_relaylog 고정된 캐시 크기(128MB)보다 큰 binlog 이벤트를 처리할 때 복제 오류가 발생할 수 있는 문제를 수정했습니다.

  • INPLACE 알고리즘을 사용할 때 라이터의 특정 온라인 DDL 작업 중에 독자가 ERROR 1146 (테이블을 찾을 수 없음)을 보고하는 문제를 수정했습니다.

  • 제로 가동 중지 패치 적용(ZDP) 또는 제로 가동 중지 재시작(ZDR) 작업 중에 인스턴스 가용성이 지연될 수 있는 문제를 해결했습니다.

  • 제로 가동 중지 업그레이드 후 연결 상태가 유지되지 않아 예기치 않은 동작이 발생할 수 있는 문제를 수정했습니다.

  • 쓰기 전달 중에 리더 인스턴스 다시 시작 시 라이터 인스턴스에 고립된 전달 세션이 남아 해당 세션을 종료하면 라이터가 다시 시작될 수 있는 문제를 수정했습니다.

업그레이드 및 마이그레이션

  • 데이터베이스 클러스터 복제 작업을 완료하는 데 시간이 오래 걸릴 수 있는 문제를 수정했습니다.

MySQL Community Edition 버그 수정 통합

이 릴리스에는 8.0.45까지의 모든 커뮤니티 버그 수정이 포함되어 있습니다. 자세한 내용은 Aurora MySQL 3.x 데이터베이스 엔진 업데이트를 통해 수정한 MySQL 버그 단원을 참조하십시오.

  • MySQL 8.0.42에서 준비된 문 또는 저장 프로시저를 사용하여 분할된 테이블에 삽입하는 데 실패할 수 있는 회귀가 수정되었습니다ERROR 1748("지정된 파티션 세트와 일치하지 않는 행 찾기"). 이는 파티션 키 열에서를 사용할 때 발생했습니다DEFAULT CURRENT_TIMESTAMP. 준비 시간에 파티션 정리를 수행하면 현재 타임스탬프를 기반으로 파티션이 잠겼지만 나중에 다시 실행하면 타임스탬프가 다른 파티션에 매핑될 수 있습니다. 참조: MySQL 업스트림 버그#119784.