As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.
Atualizações do banco de dados Amazon Aurora PostgreSQL Limitless
Aqui você pode encontrar informações sobre as versões do Amazon Aurora PostgreSQL Limitless Database. O Limitless Database fornece escalabilidade horizontal automatizada para processar milhões de transações de gravação por segundo e gerencia petabytes de dados, mantendo a simplicidade de operar em um único banco de dados. Com o Limitless Database, você pode se concentrar na criação de aplicativos de alta escala sem precisar criar e manter soluções complexas para escalar seus dados em várias instâncias de banco de dados para suportar suas cargas de trabalho.
Para obter mais informações, consulte Como usar o banco de dados Amazon Aurora PostgreSQL Limitless no Guia do usuário do Amazon Aurora.
O Amazon Amazon Aurora PostgreSQL Limitless Database segue a mesma política de ciclo de vida da versão do mecanismo do Aurora PostgreSQL. Para obter mais informações, consulte Calendários de lançamento do Aurora PostgreSQL.
Tópicos
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.13-limitless
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.11-limitless
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.10-limitless
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.9-ilimitado
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.8-ilimitado
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.6-ilimitado
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.4-ilimitado
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.13-limitless
Essa versão do banco de dados Aurora PostgreSQL Limitless é compatível com o PostgreSQL 16.13. https://www.postgresql.org/docs/release/16.13/
Versões e patches
Banco de dados Aurora PostgreSQL Limitless 16.13.102, 3 de setembro de 2026
Correções de bugs
-
Foi corrigido um impasse distribuído entre
GRANTouREVOKEsobre uma tabela e leituras ou gravações simultâneas da mesma tabela. -
Foi corrigido um problema em que um nó em um grupo de fragmentos podia ser reiniciado repetidamente ao recuperar uma transação distribuída em andamento devido à incompatibilidade de OID com o objeto do banco de dados. Isso tornou o nó indisponível e exigiu intervenção manual.
-
Foi corrigido um problema em que, em casos raros, um roteador continuava usando informações desatualizadas do gravador após um failover. As solicitações de gravação roteadas por esse roteador foram rejeitadas.
Banco de dados Aurora PostgreSQL Limitless 16.13.101, 13 de julho de 2026
Correções de bugs
-
Foi corrigido um problema com o bloqueio de caminho rápido que poderia aumentar a contenção. LWLock:LockManager
Banco de dados Aurora PostgreSQL Limitless 16.13.100, 25 de abril de 2026
Recursos
-
Foi adicionado suporte para
DELETEoperações em loteINSERTe comRETURNINGcláusula.UPDATE -
Foi adicionada uma função virtual para mostrar se uma transação preparada está desanexada.
Aprimoramentos
-
Desempenho aprimorado para transações de extrato único usando o protocolo de consulta estendido.
-
Melhor desempenho de leitura com otimização futura do tempo de confirmação para leitores MVCC baseados em tempo.
-
Desempenho aprimorado para
SELECTconsultas de fragmento único ao buscar todas as linhas de resultados de uma só vez, em vez de em lotes. Essa otimização é ativada por padrão e pode ser controlada com ords_aurora.limitless_fetch_allparâmetro. -
Melhor desempenho de transações distribuídas ao permitir a afinidade de back-end de confirmação em duas fases por padrão.
-
Melhor desempenho de
INSERTdeclarações de várias linhas comRETURNINGcláusula, permitindo a otimização de inserções em lote quando aRETURNINGlista consiste em referências de coluna*e coluna. -
Redução dos picos de extensão do registro de confirmação por meio da extensão proativa do segmento.
Correções de bugs
-
Foi corrigido um problema em que
SELECTas consultas falhavam quando um atributo de tabela fragmentada era referenciado em uma função. -
Foi corrigido um problema em que a chamada
nextvalem uma sequência dentro de uma transação explícita bloqueavanextvalchamadas simultâneas na mesma sequência quando a chamada acionava uma atualização em partes. A atualização permaneceuAccessExclusiveLockna sequência até o término da transação principal, em vez de liberá-la quando a atualização em partes foi concluída. -
Corrigido um travamento causado pelo alinhamento do SIMD.
-
Corrigido um problema em que as consultas ficavam suspensas indefinidamente ao recuperar resultados de nós fragmentados sob certas condições de conexão.
-
Foi corrigido um problema em que as conexões do cliente e do banco de dados não eram redefinidas corretamente em caso de tempo limite de conexão RPC e conexões interrompidas.
-
Corrigido um problema em que
DROP DATABASEaFORCEopção falhava intermitentemente com.database is being accessed by other users -
Redução dos bloqueios distribuídos gerados pelo autovacuum com operações de tabela
DDL. -
Corrigido um problema em que
CREATE SEQUENCEfalhavanot enough values to create distributed sequenceao usar um intervalo de sequência estreito (como osmallinttipo ou um pequenoMAXVALUE) com umINCREMENT BYvalor maior que 1. O ajuste automático do tamanho do bloco não levou em conta o valor do incremento, portanto, não conseguiu reduzir o tamanho do bloco o suficiente para caber no intervalo da sequência.
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.11-limitless
Essa versão do banco de dados Aurora PostgreSQL Limitless é compatível com o PostgreSQL 16.11. https://www.postgresql.org/docs/release/16.11/
Versões e patches
Banco de dados Aurora PostgreSQL Limitless 16.11.102, 1º de setembro de 2026
Correções de bugs
-
Foi corrigido um impasse distribuído entre
GRANTouREVOKEsobre uma tabela e leituras ou gravações simultâneas da mesma tabela. -
Foi corrigido um problema em que um nó em um grupo de fragmentos podia ser reiniciado repetidamente ao recuperar uma transação distribuída em andamento devido à incompatibilidade de OID com o objeto do banco de dados. Isso tornou o nó indisponível e exigiu intervenção manual.
-
Foi corrigido um problema em que, em casos raros, um roteador continuava usando informações desatualizadas do gravador após um failover. As solicitações de gravação roteadas por esse roteador foram rejeitadas.
-
Corrigido um problema em que as consultas ficavam suspensas indefinidamente ao recuperar resultados de um nó fragmentado. Isso ocorreu depois que a conexão com esse nó foi redefinida ou parou de responder.
-
Foi corrigido um problema em que os erros retornados ao solicitar um novo trecho para uma sequência global eram classificados incorretamente. Uma sequência que atingiu seu último valor foi relatada como uma falha de conexão. Uma falha transitória também pode
nextvalimpedir o retorno de novos valores.
Banco de dados Aurora PostgreSQL Limitless 16.11.101, 9 de junho de 2026
Correções de bugs
-
Foi corrigido um problema em que um índice exclusivo não garantia exclusividade quando criado com uma classe de operador personalizada.
-
Corrigido um problema em que
FORCEa opçãoDROP DATABASEcom falhadatabase is being accessed by other users. -
Foi corrigido um problema em que a incompatibilidade de versões entre nós ocorria após a atualização devido à versão obsoleta da extensão em cache.
Banco de dados Aurora PostgreSQL Limitless 16.11.100, 25 de fevereiro de 2026
Recursos
-
Adicionado suporte para instruções
ALTER VIEW ... OWNER TO .... -
Adicionado suporte para
pg_prewarmextensão.
Aprimoramentos
-
EXPLAINSaída aprimorada paraSELECTdeclaraçõesINSERT INTOwith. -
Desempenho de consulta aprimorado para
ENUMuso. -
Mensagens de erro
INSERT INTOaprimoradas para declarações. A mensagem agora aponta valores onde falhou.
Correções de bugs
-
Foi corrigido um problema em que
SELECTas instruções ficavam paralisadas quando o atributo de tabela fragmentada era referenciado em uma função e unido. -
Corrigido
UNIQUEe comPRIMARY KEYrestrições quando usado com aINCLUDEcláusula em que todas as colunas (tanto as de restrição quanto as incluídas) foram tratadas incorretamente. Isso fez com que a estrutura do índice fosse diferente da definição original da tabela.
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.10-limitless
Essa versão do banco de dados Aurora PostgreSQL Limitless é compatível com o PostgreSQL 16.10. https://www.postgresql.org/docs/release/16.10/
Versões e patches
Banco de dados ilimitado Aurora PostgreSQL 16.10.101
Aprimoramentos
-
EXPLAINSaída aprimorada paraINSERT INTOcomSELECT.
Correções de bugs
-
Corrigida uma falha ao unir uma tabela com uma função de retorno de conjunto que faz referência às colunas da tabela.
-
Foi corrigida uma falha causada por problemas de alinhamento do SIMD com funções genéricas de invólucro.
Banco de dados Aurora PostgreSQL Limitless 16.10.100, 24 de fevereiro de 2026
Recursos
-
Foi adicionado suporte para ENUM como tipo de chave de fragmento.
-
Foi adicionado suporte para
CHECKrestrições envolvendo literais e expressões. Para obter mais informações, consulte Restrições. -
Foi adicionado suporte para
VIEWs com restrições de chave estrangeira. Para obter mais informações, consulte Chaves estrangeiras. -
Foi adicionado suporte para Advisory Locks. Para obter mais informações, consulte o tópico sobre Bloqueios consultivos
na documentação do PostgreSQL. -
Foi adicionado suporte para
pg_dumpepg_restorepara migrações de banco de dados. Você pode despejar dos bancos de dados do Aurora Limitless e restaurar para outros clusters do Aurora Limitless ou bancos de dados PostgreSQL regulares. Esse suporte inclui a preservação de configurações fragmentadas e de tabelas de referência ao migrar entre clusters do Aurora Limitless usando funções de captura de metadados. Para obter mais informações, consulte Backup e restauração do banco de dados Amazon Aurora PostgreSQL Limitless.
Aprimoramentos
-
Desempenho aprimorado para pesquisas de esquemas e tabelas.
-
Desempenho aprimorado para divisão de fragmentos.
-
Desempenho aprimorado para consultas
INSERT INTOeUPDATEconsultas.
Correções de bugs
-
Foi corrigido um problema com as concessões de privilégios que falhava
invalid role OID: 0quando todos os privilégiosGRANTeram tornados públicos. -
Corrigido um problema com
EXPLAINeUPDATEconsultas que falharam comwrong number of parameters for prepared statement. -
Corrigido um problema com
CREATE TABLEo qual falhou comduplicate key value violates unique constraint. -
Corrigido um problema em que o banco de dados permanecia inutilizável após o
DROP DATABASEJDBC. -
Corrigido um problema com
UPDATEconsultas em tabelas distribuídas que falhavam comrelation * does not exist. -
Corrigido um problema com
SELECTconsultas com conversões de tipos que falhavam comcannot cast type cstring to text[]. -
Corrigido um problema
CREATE DATABASEque falhavaconnection_limit requires an integer valuequando também era configuradoconnection_limit. -
Transformação de tabela fixa de tabela padrão para tabela distribuída ou tabela de referência para manter as políticas de segurança em nível de linha.
-
Foram corrigidos problemas de exatidão e vazamento de dados nas políticas de segurança em nível de linha (RLS). Recomendamos descartar e recriar todas as políticas de RLS existentes.
-
DROP POLICYDeclaração fixa quando usada comIF EXISTS. -
Resultado incorreto corrigido ao selecionar a coluna
tableoiddo sistema. Otableoidé o OID da tabela, que é uma identificação distinta dada ao objeto do banco de dados por um determinado sistema. Se a consulta estiver qualificada para otimização de fragmento único, elatableoidserá obtida do fragmento. Caso contrário, otableoidserá obtido do roteador conectado. Roteadores diferentes podem resultar em diferentestableoidpara a mesma consulta. -
Atualização de estatísticas corrigida para tabelas com tipos definidos pelo usuário.
-
Corrigido um problema com
CREATE TABLEo qual falhavaFATAL: Unexpected error occurred while committing transactionquando estavadebug_parallel_querydefinido comoon.
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.9-ilimitado
Essa versão do Aurora PostgreSQL Limitless Database é compatível com o PostgreSQL 16.9. https://www.postgresql.org/docs/release/16.9/
Versões e patches
Banco de dados Aurora PostgreSQL Limitless 16.9.103, 11 de fevereiro de 2026
Aprimoramentos
-
EXPLAINSaída aprimorada paraINSERT INTOcomSELECT.
Correções de bugs
-
Corrigido um problema em que
SELECTas instruções não retornavam quando o atributo de tabela fragmentada era referenciado em uma função e unido.
Banco de dados Aurora PostgreSQL Limitless 16.9.102, 21 de novembro de 2025
Aprimoramentos
-
Desempenho aprimorado para divisão de fragmentos.
-
Mensagens de erro aprimoradas quando as consultas falham durante atualizações (menores) devido a versões inconsistentes da instância.
Correções de bugs
-
Corrigido um problema em que o banco de dados permanecia inutilizável após o
DROP DATABASEJDBC. -
Foi corrigido um problema com concessões de privilégios que falhava
invalid role OID: 0quando todos os privilégiosGRANTeram tornados públicos. -
Corrigido um problema com
SELECTconsultas com conversões de tipos que falhavam comcannot cast type cstring to text[]. -
Corrigido um problema
CREATE DATABASEque falhavaconnection_limit requires an integer valuequando também era configuradoconnection_limit. -
Transformação de tabela fixa de tabela padrão para tabela distribuída ou tabela de referência para manter as políticas de segurança em nível de linha.
-
Foram corrigidos problemas de exatidão e vazamento de dados nas políticas de segurança em nível de linha (RLS). Recomendamos descartar e recriar todas as políticas de RLS existentes.
-
DROP POLICYDeclaração fixa quando usada comIF EXISTS. -
Resultado incorreto corrigido ao selecionar a coluna
tableoiddo sistema. Otableoidé o OID da tabela, que é uma identificação distinta dada ao objeto do banco de dados por um determinado sistema. Se a consulta estiver qualificada para otimização de fragmento único, elatableoidserá obtida do fragmento. Caso contrário, otableoidserá obtido do roteador conectado. Roteadores diferentes podem resultar em diferentestableoidpara a mesma consulta. -
Foi corrigido um problema em que os processos internos não estavam mais funcionando corretamente após a revogação do
CONNECTprivilégio para funções internas do sistema. -
Atualização de estatísticas corrigida para tabelas com tipos definidos pelo usuário.
-
Foi corrigido um caso extremo na resolução de uma transação preparada.
Banco de dados Aurora PostgreSQL Limitless 16.9.101, 6 de novembro de 2025
Correções de bugs
-
Foi corrigido um problema em que as tabelas não eram excluídas em fragmentos quando
CREATEALTER, eDROPas instruções eram executadas repetidamente usando instruções preparadas por meio de drivers JDBC ou ODBC (por exemplo, quando usadaspreferQueryMode=extendedCacheEverythingem JDBC), ou quandoCREATEALTER, e asDROPinstruções eram executadas como parte de ou.PROCEDUREFUNCTION -
Foram corrigidos resultados incorretos ao consultar tabelas usando
UNIQUE INDEXescaneamentos enquanto a tabela tinha quebrado cadeias de Heap-Only tuplas (HOT) de declarações.UPDATE -
Foi corrigido um problema em que nós íntegros eram substituídos desnecessariamente, causando indisponibilidade do sistema.
Banco de dados Aurora PostgreSQL Limitless 16.9.100, 5 de setembro de 2025
Recursos
-
O suporte adicionado para
CREATE INDEX IF NOT EXISTS. -
Adicionado suporte para SEQUÊNCIAS na
pgstattupleextensão. -
Foi adicionado suporte para a extensão hstore. Observe que as colunas hstore não podem ser usadas como chaves fragmentadas em tabelas fragmentadas.
-
Foi adicionado suporte para a extensão auto_explain.
Aprimoramentos
-
Redução do período de espera necessário entre
CREATE DATABASEas operaçõesDROP DATABASEe ao usar o mesmo nome de banco de dados. -
Desempenho aprimorado
DELETEeUPDATEoperações envolvendo semi-junção e anti-junção. -
Desempenho aprimorado para
INSERT INTO ... SELECT FROMdeclarações com expressões ou projeções que podem ser reduzidas a fragmentos -
Mensagens de erro aprimoradas para bloqueios detectados com consultas envolvidas listadas na seção DETALHES.
Correções de bugs
-
Foi corrigido um problema em que o pool de trabalhadores em segundo plano poderia ser completamente esgotado pelos processos internos do banco de dados.
-
Foi corrigido um problema em que funções não imutáveis em extensões falhavam inesperadamente com erros de permissão negada.
-
O tempo de confirmação fixo é um erro inválido.
-
Foi corrigido um problema em que
INSERT INTOfalhava após o inícioROLLBACKde umaREAD ONLYtransação com o erroERRO: falha ao executar consulta remota com mensagem: o modo de leitura e gravação da transação deve ser definido antes de qualquer consulta. -
Foi corrigido um problema em que
SELECTas consultas falhavam comERRO: falha ao executar a consulta remota com mensagem: os agrupamentos não são suportados pelo tipo inteiro. -
Corrigido um problema em que
DELETE FROMfalhava comERRO: falha ao executar a consulta remota. -
Foi corrigido um problema em que expressões em
DEFAULT/CHECKrestrições podiam gerar dados de preenchimento incorretos para linhas existentes. Esse problema é visto especificamente quando a expressão na restrição depende de parênteses. -
Foi corrigido um problema com
EXECUTEas instruçõesPREPAREe que falhavam com a mensagem devinculação que fornecia 2 parâmetros, mas a instrução preparada requer 1quando aPREPAREinstrução usava menos parâmetros do que a declarada. -
Corrigido um problema em que
RESETards_aurora.limitless_explain_optionsconfiguração não era refletida corretamente naEXPLAINsaída.
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.8-ilimitado
Essa versão do banco de dados Aurora PostgreSQL Limitless é compatível com o PostgreSQL 16.8. https://www.postgresql.org/docs/release/16.8/
Versões e patches
Banco de dados Aurora PostgreSQL Limitless 16.8.104, 12 de maio de 2026
Banco de dados Aurora PostgreSQL Limitless 16.8.103, 30 de outubro de 2025
Banco de dados Aurora PostgreSQL Limitless 16.8.102, 13 de outubro de 2025
Banco de dados Aurora PostgreSQL Limitless 16.8.101, 30 de junho de 2025
Banco de dados Aurora PostgreSQL Limitless 16.8.100, 8 de maio de 2025
Banco de dados Aurora PostgreSQL Limitless 16.8.104, 12 de maio de 2026
Correções de bugs
-
Corrigido um vazamento no descritor de arquivo.
rds_aurora_limitless_get_max_connections
Banco de dados Aurora PostgreSQL Limitless 16.8.103, 30 de outubro de 2025
Correções de bugs
-
Foi corrigido um problema com concessões de privilégios que falhava
invalid role OID: 0quando todos os privilégiosGRANTeram tornados públicos. -
Corrigido um problema com
SELECTconsultas com conversões de tipos que falhavam comcannot cast type cstring to text[]. -
Corrigido um problema
CREATE DATABASEque falhavaconnection_limit requires an integer valuequando também era configuradoconnection_limit. -
Resultado incorreto corrigido ao selecionar a coluna
tableoiddo sistema. Otableoidé o OID da tabela, que é uma identificação distinta dada ao objeto do banco de dados por um determinado sistema. Se a consulta estiver qualificada para otimização de fragmento único, elatableoidserá obtida do fragmento. Caso contrário, otableoidserá obtido do roteador conectado. Roteadores diferentes podem resultar em diferentestableoidpara a mesma consulta. -
Foi corrigido um caso extremo na resolução de uma transação preparada.
Banco de dados Aurora PostgreSQL Limitless 16.8.102, 13 de outubro de 2025
Correções de bugs
-
Foi corrigido um problema em que as tabelas não eram excluídas em fragmentos quando
CREATEALTER, eDROPas instruções eram executadas repetidamente usando instruções preparadas por meio de drivers JDBC ou ODBC (por exemplo, quando usadaspreferQueryMode=extendedCacheEverythingem JDBC), ou quandoCREATEALTER, e asDROPinstruções eram executadas como parte de ou.PROCEDUREFUNCTION -
Foram corrigidos resultados incorretos ao consultar tabelas usando
UNIQUE INDEXescaneamentos enquanto a tabela tinha quebrado cadeias de Heap-Only tuplas (HOT) de declarações.UPDATE -
Foi corrigido um problema em que nós íntegros eram substituídos desnecessariamente, causando indisponibilidade do sistema.
Banco de dados Aurora PostgreSQL Limitless 16.8.101, 30 de junho de 2025
Aprimoramentos
-
Mensagens de erro aprimoradas para bloqueios detectados, agora listando as consultas envolvidas na
DETAILseção. -
Foi adicionado suporte para subconsulta contendo tableoide como lista de destino.
Correções de bugs
-
Corrigido o resultado da consulta
ANALYZESQL para incluir também tabelas externas. -
Foram corrigidos vários problemas que poderiam levar à reinicialização do banco de dados.
-
Foi corrigido um problema com
EXECUTEdeclaraçõesPREPAREe que falhavam incorretamente com a mensagem devinculação que fornecia 2 parâmetros, mas a instrução preparada requer 1quando aPREPAREinstrução usava menos parâmetros do que o declarado. -
Foram corrigidos vários problemas nas operações de vácuo, levando ao aumento do consumo de espaço.
-
Corrigido um problema com
INSERTextratos após reverter umaREAD_ONLYtransação. -
Corrigido um problema em que
DELETEdeclarações comRETURNINGcláusula falhavam.
Banco de dados Aurora PostgreSQL Limitless 16.8.100, 8 de maio de 2025
Recursos
-
Foi adicionado suporte para a
ltreeextensão.ltreecolunas de tipo de dados não podem ser usadas como chaves fragmentadas em tabelas fragmentadas. -
Foi adicionado suporte para a
btree_gistextensão no banco de dados Aurora PostgreSQL Limitless. As restrições de exclusão usando o índice GIST não são suportadas. Por exemplo, o comando a seguir não é suportado:CREATE TABLE zoo ( cage INTEGER, animal TEXT, EXCLUDE USING GIST (cage WITH =, animal WITH <>) );
Aprimoramentos
-
Melhor desempenho de consulta nesses cenários:
-
Consultas com cláusulas de intervalo.
-
Acesso a várias tuplas com chaves de fragmento diferentes do mesmo fragmento.
-
Exclua e atualize operações envolvendo junções semi e antiuniões.
-
-
Nodos de varredura externos assíncronos aprimorados com capacidade de pré-busca.
-
Tolerância de falhas de detecção de impasse reforçada.
Correções de bugs
-
Foi corrigido um problema em que os back-ends do banco de dados paravam de responder aos sinais do sistema, o que poderia fazer com que as operações do DROP DATABASE travassem.
-
Foi corrigida uma condição de corrida no processamento em segundo plano do log de confirmação (obstrução) que fazia com que o tempo de confirmação fosse um erro inválido.
-
Foi corrigido um problema que poderia causar falhas inesperadas durante as operações automáticas de análise de tabelas.
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.6-ilimitado
Essa versão do Aurora PostgreSQL Limitless Database é compatível com o PostgreSQL 16.6. https://www.postgresql.org/docs/release/16.6/
Versões e patches
Banco de dados Aurora PostgreSQL Limitless 16.6.103, 13 de outubro de 2025
Correções de bugs
-
Foi corrigido um problema em que as tabelas não eram excluídas em fragmentos quando
CREATEALTER, eDROPas instruções eram executadas repetidamente usando instruções preparadas por meio de drivers JDBC ou ODBC (por exemplo, quando usadaspreferQueryMode=extendedCacheEverythingem JDBC), ou quandoCREATEALTER, e asDROPinstruções eram executadas como parte de ou.PROCEDUREFUNCTION -
Foram corrigidos resultados incorretos ao consultar tabelas usando
UNIQUE INDEXescaneamentos enquanto a tabela tinha quebrado cadeias de Heap-Only tuplas (HOT) de declarações.UPDATE -
Foi corrigido um problema em que nós íntegros eram substituídos desnecessariamente, causando indisponibilidade do sistema.
Banco de dados Aurora PostgreSQL Limitless 16.6.102, 30 de junho de 2025
Aprimoramentos
-
As mensagens de erro aprimoradas para bloqueios detectados agora listam as consultas envolvidas no.
DETAIL -
Aprimorou o algoritmo de detecção de impasse de distribuição para ser arbitrariamente resiliente a falhas de rede ou de nós.
-
Foi adicionado suporte para subconsulta contendo tableoide como lista de destino.
Correções de bugs
-
Corrigido o resultado da consulta
ANALYZESQL para incluir tabelas externas. -
Foram corrigidos vários problemas que poderiam levar à reinicialização do banco de dados.
-
Foi corrigido um problema com
EXECUTEdeclaraçõesPREPAREe que falhavam incorretamente com a mensagem devinculação que fornecia 2 parâmetros, mas a instrução preparada requer 1quando aPREPAREinstrução usa menos parâmetros do que a declarada. -
Foram corrigidos vários problemas nas operações de vácuo, levando ao aumento do consumo de espaço.
-
Corrigido um problema com
INSERTextratos após reverter umaREAD_ONLYtransação. -
Corrigido um problema em que
DELETEas declarações com aRETURNINGcláusula falhavam. -
Casos corrigidos em que expressões em
CHECKrestriçõesDEFAULT/podem gerar resultados incorretos, especificamente quando a expressão na restrição depende de parênteses para gerar o resultado correto.
Banco de dados Aurora PostgreSQL Limitless 16.6.101, 17 de abril de 2025
Esta versão inclui patches do Aurora PostgreSQL até 16.6.3. https://docs.aws.amazon.com/AmazonRDS/latest/AuroraPostgreSQLReleaseNotes/AuroraPostgreSQL.Updates.html#aurorapostgresql-versions-version1663x-1663
Correções de bugs
-
Foram corrigidos vários problemas que poderiam levar a breves períodos de indisponibilidade.
-
Corrigido um problema de exatidão quando
limitless_minimum_adaptive_fetch_sizedefinido como menor que o valor padrão (100). -
Tratamento aprimorado de erros para consultar o atributo tableóide de uma relação no Aurora PostgreSQL Limitless Database, considerando que ele pode ter valores diferentes entre os nós em.
DBShardGroup -
Corrigido um problema de permissão que pode ocorrer durante o uso
rds_aurora.limitless_active_shard_key. Isso resolve erros de permissão ao recuperar dados. -
Corrigida uma condição de corrida na operação de entupimento em segundo plano que pode fazer com que o cliente receba o tempo de confirmação, é um erro inválido.
-
Execução otimizada de funções distribuídas com chave fragmentada de comprimento variável. Anteriormente, os roteadores executavam funções distribuídas, mas agora elas são executadas localmente em um único fragmento, de acordo com a chave do fragmento.
-
Corrigido um erro ao executar
update/deleteem tabelas padrão unindo tabelas de referência. -
Foi corrigido um problema em que qualquer usuário podia invocar funções internas ilimitadas específicas.
-
Foi corrigido um problema que levava à reversão incorreta da subtransação durante a falha do nó.
-
Foram corrigidos problemas em que expressões com parênteses aninhados nas
DEFAULT/CHECKrestrições podiam gerar resultados incorretos.
Banco de dados Aurora PostgreSQL Limitless 16.6.100, 24 de janeiro de 2025
Recursos
-
O banco de dados Aurora PostgreSQL Limitless agora oferece suporte ao Aurora PostgreSQL versão 16.6.
-
Agora você pode instalar e usar a
btree_ginextensão. -
O comando
DISCARDData Manipulation Language (DML) é suportado.
Aprimoramentos
-
Melhor desempenho de consulta com melhores recursos de pushdown para consultas que incluem tabelas de referência em subconsultas. Esse aprimoramento otimiza a execução da consulta, resultando potencialmente em um desempenho mais rápido para consultas complexas que envolvem junções de tabelas de referência em subconsultas.
-
Melhorou o tratamento de erros para
pg_advisory_lock. Anteriormente, as tentativas de usar esse recurso incompatível não geravam uma mensagem de erro explícita, o que poderia levar a um comportamento inesperado. Agora, os usuários receberão uma notificação de erro clara ao tentar usarpg_advisory_lock, garantindo maior clareza e evitando consequências não intencionais.
Correções de bugs
-
Corrigido um problema em que certos
CREATE TABLEcomandosALTER TABLEe falhavam com o erro:Não é possível separar a instrução fornecida. -
Foi corrigido um problema em que um
ALTER TABLEcomando com umaDEFAULTrestriçãoNOT NULLor falhava quando continha funções inseguras para serem enviadas para fragmentos (como funções voláteis), exigindo o preenchimento de dados nas linhas existentes.
Problemas conhecidos
-
Definir a
rds_aurora.limitless_minimum_adaptive_fetch_sizevariável pode causar resultados incorretos.
Banco de dados Amazon Aurora PostgreSQL Limitless versão 16.4-ilimitado
Essa versão do Aurora PostgreSQL Limitless Database é compatível com o PostgreSQL 16.4. https://www.postgresql.org/docs/release/16.4/
Versões e patches
Banco de dados Aurora PostgreSQL Limitless 16.4.106, 13 de outubro de 2025
Correções de bugs
-
Foi corrigido um problema em que as tabelas não eram excluídas em fragmentos quando
CREATEALTER, eDROPas instruções eram executadas repetidamente usando instruções preparadas por meio de drivers JDBC ou ODBC (por exemplo, quando usadaspreferQueryMode=extendedCacheEverythingem JDBC), ou quandoCREATEALTER, e asDROPinstruções eram executadas como parte de ou.PROCEDUREFUNCTION -
Foram corrigidos resultados incorretos ao consultar tabelas usando
UNIQUE INDEXescaneamentos enquanto a tabela tinha quebrado cadeias de Heap-Only tuplas (HOT) de declarações.UPDATE -
Foi corrigido um problema em que nós íntegros eram substituídos desnecessariamente, causando indisponibilidade do sistema.
Banco de dados Aurora PostgreSQL Limitless 16.4.105, 17 de abril de 2025
Correções de bugs
-
Corrigidos vários problemas que poderiam levar a breves períodos de indisponibilidade.
-
Foi corrigido um problema que resultava em resultados incorretos para consultas anti-junção contendo um predicado em uma relação externa.
-
Foi adicionada a capacidade de pushdown para as seguintes funções do sistema:
pg_char_to_encodingpg_encoding_to_chartextanycatanytextcat
-
Tratamento aprimorado de erros
pg_advisory_lockno Aurora PostgreSQL Limitless Database. Com essa alteração, você recebe uma notificação de erro clara ao tentar usarpg_advisory_lock. -
Foi corrigido um problema em que adicionar uma expressão com parênteses aninhados nas
DEFAULT/CHECKrestrições poderia gerar resultados incorretos.
Banco de dados Aurora PostgreSQL Limitless 16.4.104, 19 de novembro de 2024
Correções de bugs
-
Foi corrigido um problema em que bloqueios podiam ocorrer no processamento de instruções da Linguagem de Definição de Dados (DDL) durante
CREATE INDEX CONCURRENTLYa execução. -
Foi corrigido um problema em que um erro na resolução de impasse distribuído podia bloquear a detecção de impasses distribuídos subsequentes.
-
Foi corrigido um problema em que declarações DDL com instruções DML (Data Manipulation Language) subjacentes (como
CREATE TABLE ASou solicitando uma tabela com dados) resultavam em erros se ards_aurora.limitless_active_shard_keyvariável fosse usada em uma sessão. -
Foi corrigido um problema em que uma operação de divisão de fragmentos resultava em um erro.
-
Foi corrigido um problema em que o
rds_aurora.limitless_alter_table_type_shardedprocedimento para converter o tipo de tabela em fragmentado falhava se ards_aurora.limitless_alter_table_type_shardedvariável fosse definida. -
Foi corrigido um problema na lógica de separação de objetos polimórficos que fazia com que consultas inválidas não produzissem erros quando a conversão implícita da transmissão de dados fazia com que versões incorretas do objeto fossem usadas.
Problemas conhecidos
-
Um problema pode ocorrer quando parte de uma consulta é convertida em uma condição esquerda ou anti-junção. Nesses casos, se a relação interna não tiver resultados, uma linha nula será usada.
-
Pode ocorrer um problema quando a adição de uma coluna com uma
DEFAULTrestriçãoNOT NULLor, que contém funções não seguras para enviar para fragmentos (como funções voláteis), exige o preenchimento de dados em linhas existentes. -
Um problema pode ocorrer quando a lógica de separação para preparar consultas em fragmentos não usa parênteses sempre que possível. Isso pode levar a erros quando
COLLATEusado em consultas.
Banco de dados Aurora PostgreSQL Limitless 16.4.103, 31 de outubro de 2024
A versão 16.4.103 é a versão GA do Aurora PostgreSQL Limitless Database.
Para obter informações sobre essa versão, consulte Usando o banco de dados Amazon Aurora PostgreSQL Limitless no Guia do usuário do Amazon Aurora.