View a markdown version of this page

Solução de problemas de integração do Amazon EFS - Amazon Relational Database Service

Solução de problemas de integração do Amazon EFS

A instância de banco de dados do RDS para Oracle monitora a conectividade com um sistema de arquivos Amazon EFS. Quando o monitoramento detecta um problema, ele pode tentar corrigi-lo e publicar um evento no console do RDS. Para ter mais informações, consulte Visualizar eventos do Amazon RDS.

Utilize as informações desta seção para ajudar a diagnosticar e corrigir problemas comuns ao trabalhar com a integração do Amazon EFS.

Notificação Descrição Ação

The EFS for RDS Oracle instance instance_name isn't available on the primary host. NFS port 2049 of your EFS isn't reachable.

A instância de banco de dados não pode se comunicar com o sistema de arquivos EFS.

Verifique o seguinte:

  • O sistema de arquivos EFS existe.

  • O grupo de segurança anexado ao destino de montagem do EFS tem uma regra de entrada para permitir o grupo de segurança ou a sub-rede de rede da instância de banco de dados do RDS para Oracle em TCP/2049 (tipo NFS).

The EFS isn't reachable.

Ocorreu um erro durante a instalação da opção EFS_INTEGRATION.

Verifique o seguinte:

  • O sistema de arquivos EFS existe.

  • O grupo de segurança anexado ao destino de montagem do EFS tem uma regra de entrada para permitir o grupo de segurança ou a sub-rede de rede da instância de banco de dados do RDS para Oracle em TCP/2049 (tipo NFS).

  • O atributo enableDnsSupport está ativado para sua VPC.

  • Você está usando o servidor DNS fornecido pela Amazon em sua VPC. A integração do Amazon EFS não funciona com um DNS DHCP personalizado.

The associated role with your DB instance wasn't found.

Ocorreu um erro durante a instalação da opção EFS_INTEGRATION.

Associe um perfil do IAM à instância de banco de dados do RDS para Oracle.

The associated role with your DB instance wasn't found.

Ocorreu um erro durante a instalação da opção EFS_INTEGRATION. O RDS para Oracle foi restaurado a partir de um snapshot de banco de dados com a configuração da opção USE_IAM_ROLE de TRUE.

Associe um perfil do IAM à instância de banco de dados do RDS para Oracle.

The associated role with your DB instance wasn't found.

Ocorreu um erro durante a instalação da opção EFS_INTEGRATION. O RDS para Oracle foi criado por meio de um modelo completo do CloudFormation com a configuração da opção USE_IAM_ROLE de TRUE.

Como solução alternativa, realize as seguintes etapas:

  1. Crie uma instância de banco de dados com o perfil do IAM e o grupo de opções padrão.

  2. Em uma atualização de pilha subsequente, adicione o grupo de opções personalizadas com a opção EFS_INTEGRATION.

PLS-00302: component 'CREATE_DIRECTORY_EFS' must be declared

Esse erro pode ocorrer quando você está usando uma versão do RDS para Oracle não compatível com o Amazon EFS.

Você deve estar usando a instância de banco de dados do RDS para Oracle versão 19.0.0.0.ru-2022-07.rur-2022-07.r1 ou posteriores.

Read access of your EFS is denied. Check your file system policy.

Sua instância de banco de dados não pode ler o sistema de arquivos EFS.

Seu sistema de arquivos EFS deve permitir acesso de leitura por meio do perfil do IAM ou no nível do sistema de arquivos EFS.

Não aplicável

Sua instância de banco de dados não pode gravar no sistema de arquivos EFS.

Siga as seguintes etapas:

  1. O sistema de arquivos EFS deve estar montado em uma instância do Amazon EC2.

  2. Dê ao others grupo acesso de gravação ao seu usuário do RDS. A técnica mais simples é executar o comando chmod 777 no diretório superior do sistema de arquivos EFS.