As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.
Solucionar problemas de falhas de registro de diretórios do Connector for AD
O conector para registro do diretório AD pode falhar por vários motivos. Quando o registro do diretório falhar, você receberá o motivo da falha na resposta da API. Se você estiver usando o console, poderá encontrar o motivo da falha no painel de detalhes do registro do diretório, no campo Informações adicionais de status. A tabela a seguir descreve os motivos da falha e as etapas recomendadas para resolução.
| Status de falha | Description | Correção |
|---|---|---|
DIRECTORY_ACCESS_DENIED |
O Connector for AD não consegue acessar seu diretório. |
O Connector for AD não oferece suporte à criação de um registro de diretório ou de um conector em uma região de réplica de um diretório multirregional AWS Managed Microsoft AD . Se você tentou criar um registro de diretório em uma região de réplica, exclua o registro de diretório que falhou e crie um novo na região primária do diretório. Crie seu conector também na região primária. Para obter informações sobre replicação em várias regiões, consulte Multi-Region replicação no Guia de Administração. AWS Directory Service Você deve conceder ao Connector for AD acesso ao seu diretório. Consulte a Etapa 4: criar uma política do IAM seção para garantir que a política do IAM associada à sua AWS conta permita acessar e descrever diretórios. Depois de conceder as permissões corretas à sua AWS função, exclua o registro do diretório que falhou e crie um novo. Se você usar o Connector for AD com um AWS Directory Service AD Connector, certifique-se de que a senha da conta de serviço do AD Connector não tenha expirado e seja válida. Para obter informações sobre as contas de serviço do AD Connector, consulte Introdução ao AD Connector no Guia de administração do AD Connector. |
DIRECTORY_NOT_ACTIVE |
Seu diretório não está no Active estado. |
Seu diretório deve estar no |
DIRECTORY_NOT_REACHABLE |
O Connector for AD não pode acessar seu diretório. |
Verifique a rede entre AWS e seu diretório e, em seguida, exclua o registro do diretório que falhou e crie um novo. |
DIRECTORY_RESOURCE_NOT_FOUND |
O Connector for AD não consegue encontrar o diretório especificado. |
Certifique-se de especificar a ID de diretório correta e, em seguida, exclua o registro de diretório que falhou e crie um novo usando a ID de diretório pretendida. |
DIRECTORY_TYPE_NOT_SUPPORTED |
O Connector for AD não oferece suporte a esse tipo de diretório. |
O Connector for AD suporta AWS Managed Microsoft AD (edições Standard e Enterprise) que você possui e os diretórios do AD Connector. O Connector for AD não oferece suporte à edição híbrida AWS Managed Microsoft AD ou aos diretórios que outra conta compartilha com a sua. Para um diretório compartilhado, crie o registro do diretório na AWS conta proprietária do diretório. |
INTERNAL_FAILURE |
O conector para AD sofreu uma falha interna. |
Tente novamente mais tarde. Exclua o registro do diretório que falhou e crie um novo. |