View a markdown version of this page

Aurora MySQL 数据库引擎更新 2026-08-27(版本 3.13.0,兼容 MySQL 8.0.45) - Amazon Aurora

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

Aurora MySQL 数据库引擎更新 2026-08-27(版本 3.13.0,兼容 MySQL 8.0.45)

版本:3.13.0

Aurora MySQL 3.13.0 现已正式发布并与 MySQL 8.0.45 兼容。有关社区变更的更多信息,请参阅 MySQL 网站上的 MySQL 8.0 发行说明。

有关 Aurora MySQL 版本 3 中的新功能的详细信息,请参阅与 MySQL 8.0 兼容的 Aurora MySQL 版本 3。

有关 Aurora MySQL 版本 3 和 Aurora MySQL 版本 2 之间的区别,请参阅比较 Aurora MySQL 版本 2 和 Aurora MySQL 版本 3。

有关 Aurora MySQL 版本 3 与 MySQL 8.0 社区版的比较,请参阅《Amazon Aurora 用户指南》中的 Aurora MySQL 版本 3 与 MySQL 8.0 社区版的比较。

您可以通过以下三种方式之一从任何当前支持的 Aurora MySQL 版本 2 集群升级到 Aurora MySQL 版本 3.13.0 集群:使用零停机补丁 (ZDP) 执行就地升级、还原快照或使用 Amazon RDS 部署启动托管 blue/green 升级。 Blue/Green

有关计划升级到 Aurora MySQL 版本 3 的信息,请参阅规划 Aurora MySQL 集群的主要版本升级。有关一般升级信息,请参阅 A mazon Aurora 用户指南中的升级 Aurora MySQL 数据库集群。

有关故障排除信息,请参阅《Amazon Aurora 用户指南》中的 Aurora MySQL 就地升级故障排除。

如果您有任何问题或疑虑, 支持 可以在社区论坛上找到,也可以通过以下方式获得支持。有关更多信息,请参阅《Amazon Aurora 用户指南》中的维护 Aurora 数据库集群。

改进

安全修复

此版本修复了以下高严重性 CVE:

此版本修复了以下中等严重性 CVE:

可用性改进

  • 修复了在执行时或并发操作(例如性能架构查询ALTER TABLE ... REORGANIZE PARTITIONDROP PARTITION、全文搜索优化或ADD PARTITION统计信息收集)访问同一个表时可能导致数据库实例重新启动的问题。

  • 修复了在使用ALGORITHM=INSTANT添加了列的表ALTER TABLE ... REORGANIZE PARTITION上运行查询performance_schema.data_lock_waits或同时performance_schema.data_locks运行查询时,可能会导致数据库实例重新启动的问题。

  • 修复了在处理更改子分区顺序的 ALTER TABLE ... REORGANIZE PARTITION SQL 语句时可能导致写入器实例重新启动的问题。

  • 修复了写入器实例上的 DDL 操作可能会阻止或终止读取器实例上的某些 SQL 语句的问题。受影响的语句包括对表的写入操作,例如UPDATETRUNCATE对performance_schema表的写入操作,以及对临时表的写入JOIN操作和操作。

  • 修复了在处理 SQL 语句后清理临时表时,数据库写入器实例在全局数据库切换操作期间可能意外重启的问题。这种重启可能会导致更长的切换完成时间。

  • 修复了可能导致新数据库集群创建失败,需要删除并重新创建集群的问题。

  • 修复了内存不足 (OOM) 避免机制中的一个问题,该问题可能导致数据库实例在临界内存压力下尝试恢复内存时重新启动。

  • 修复了在为虚拟列上有索引的表清除撤消记录时,写入器实例重新启动时可能导致写入器实例反复重启的问题。

  • 修复了当写入器实例在启用 binlog 的情况下提交大型事务时可能导致只读副本重新启动的问题。此问题还可能导致读取包含大型事务的二进制日志文件时出错。

  • 修复了在Aurora serverless扩展操作期间延迟调整 InnoDB 缓冲池大小可能导致数据库实例无响应并重新启动的问题。

  • 修复了在写入器实例强制清除撤消日志时,读取器实例在重启后可能会反复重启的问题。

  • 修复了在启用本地或全局写入转发时读取器数据库实例重新启动时可能导致写入器数据库实例重新启动的问题。

  • 修复了当使用并行查询请求的子查询在完成时未正确关闭时,可能导致读取器实例上的数据库意外重启的问题。

  • 修复了在执行通过写入转发转发给写入器的二进制协议准备语句时,副本实例可能会重新启动的问题。

  • 修复了在高度并发写入操作期间由于内部计时冲突而可能导致写入器实例重启的问题。

  • 修复了启用增强二进制日志时可能导致数据库实例重新启动的问题。

  • 修复了一个错误,该错误可能会使副本短暂断开连接并重新连接到写入器,从而导致复制延迟暂时出现峰值 (AuroraReplicaLag)。

  • 修复了 Aurora 存储守护程序中的一个问题,该问题在极少数情况下可能导致数据库意外重启。

  • 通过使用多线程将写入器实例的更改应用于读取器实例,提高了 Aurora 物理复制的性能。

常规改进

  • 修复了启用写入转发后,aurora_replica_read_consistency设置为的读取器会话global可能无法读取最新提交的更改的问题。

  • 修复了当空间 GIS 查询在使用显式 SRID 注解声明的列上使用 Z-order 空间索引时可能导致引擎重新启动的问题。

  • 修复了启用写入转发时,写入器实例Aborted_clients上正常断开的读取器连接可能不正确地增加的问题。

  • 修复了在调整缓冲池大小或页面逐出操作期间从临时表读取正在进行的 SQL 语句时可能导致数据库实例重新启动的罕见问题。

  • 修复了启用增强型 Binlog 的二进制日志副本的提交顺序以正确执行该设置。replica_preserve_commit_order这种排序行为不会影响数据完整性或导致事务之间的冲突,因为它仅适用于非依赖事务的排序。

  • 修复了在使用ORDER BY DESC范围比较和时可能导致查询结果按升序而不是按请求的降序返回的问题。LIMIT

  • 修复了数据库服务器升级期间系统表上的 DML 操作引用过时的自动增量值时可能出现的集群可用性问题。

  • 修复了处理大于aurora_in_memory_relaylog固定缓存大小 (128 MB) 的二进制日志事件时可能导致复制错误的问题。

  • 修复了读者在使用INPLACE算法时在写入器上执行某些在线 DDL 操作期间报告ERROR 1146(未找到表)的问题。

  • 修复了在零停机时间补丁 (ZDP) 或零停机时间重启 (ZDR) 操作期间可能导致实例可用性延迟的问题。

  • 修复了零停机时间升级后在某些情况下无法保留连接状态的问题,这可能会导致意外行为。

  • 修复了在写入转发期间,读取器实例重启可能会在写入器实例上留下孤立转发会话的问题,而终止该会话可能导致写入器重启。

升级和迁移

  • 修复了可能导致数据库集群克隆操作需要很长时间才能完成的问题。

集成了 MySQL 社区版本错误修复

此版本修复了直到 8.0.45(含)在内的所有社区错误。有关更多信息,请参阅 由 Aurora MySQL 3.x 数据库引擎更新修复的 MySQL 错误。

  • 修复了 MySQL 8.0.42 中引入的回归问题,即使用准备好的语句或存储过程插入分区表可能会失败ERROR 1748(“发现一行与给定分区集不匹配”)。当分区键列使用时,会发生这种情况DEFAULT CURRENT_TIMESTAMP。在准备时进行分区修剪会根据当前时间戳锁定分区,但在随后重新执行时,时间戳可能会映射到不同的分区。参考:MySQL 上游错误 #119784 。