View a markdown version of this page

亚马逊 Aurora PostgreSQL 无限数据库更新 - Amazon Aurora

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

亚马逊 Aurora PostgreSQL 无限数据库更新

在这里,您可以找到有关亚马逊 Aurora PostgreSQL 无限数据库版本的信息。Limitless Database 提供自动水平扩展功能,可每秒处理数百万个写入事务,并管理 PB 的数据,同时保持在单个数据库内操作的简便性。借助 Limitless Database,您可以专注于构建大规模应用程序,而不必构建和维护复杂的解决方案,从而跨多个数据库实例扩展数据以支持您的工作负载。

有关更多信息,请参阅亚马逊 Aurora 用户指南中的使用亚马逊 Aurora PostgreSQL 无限数据库。

亚马逊亚马逊 Aurora PostgreSQL 无限数据库遵循与 Aurora PostgreSQL 相同的引擎版本生命周期政策。有关更多信息,请参阅 Aurora PostgreSQL 的发布日历。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.13-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.13 兼容。有关 PostgreSQL 16.13 中改进的更多信息,请参阅 Aurora PostgreSQL 16.13。

Aurora PostgreSQL 无限数据库 16.13.102,2026 年 9 月 3 日

错误修复

  • 修复了表之间GRANT或表REVOKE上的分布式死锁以及同一个表的并发读取或写入问题。

  • 修复了由于数据库对象的 OID 不匹配导致分片组中的节点在恢复正在进行的分布式事务时可能会重复重启的问题。这使该节点不可用,需要手动干预。

  • 修复了在极少数情况下,路由器在故障转移后继续使用过时的写入器信息的问题。通过该路由器路由的写入请求被拒绝。

Aurora PostgreSQL 无限数据库 16.13.101,2026 年 7 月 13 日

错误修复

  • 修复了可能导致 LWLock:LockManager 争用加剧的快速路径锁定问题。

Aurora PostgreSQL 无限数据库 16.13.100,2026 年 4 月 25 日

功能

  • 增加了对带有RETURNING子句的批处理INSERTUPDATE、和DELETE操作的支持。

  • 添加了一个虚拟函数来显示准备好的交易是否已分离。

增强功能

  • 使用扩展查询协议提高了单语句事务的性能。

  • 通过未来对基于时间的 MVCC 读取器的提交时间进行优化,提高了读取性能。

  • 通过一次提取所有结果行(而不是成批获取)来提高单分区SELECT查询的性能。默认情况下,此优化处于启用状态,可使用rds_aurora.limitless_fetch_all参数进行控制。

  • 通过默认启用两阶段提交后端关联性来提高分布式事务性能。

  • 通过在RETURNING列表包含和列引用时启用批量插入优化,提高了带RETURNING子句的多行INSERT语句*的性能。

  • 通过主动分段扩展减少提交日志扩展峰值。

错误修复

  • 修复了在函数中引用分片表属性时SELECT查询崩溃的问题。

  • 修复了当调用触发区块刷新时,nextval对显式事务中的序列进行nextval调用会阻止对同一序列进行并发调用的问题。刷新会一直AccessExclusiveLock保持序列直到父事务结束,而不是在区块更新完成时将其释放。

  • 修复了由 SIMD 对齐导致的崩溃。

  • 修复了在特定连接条件下从分片节点检索结果时查询无限期挂起的问题。

  • 修复了在 RPC 连接超时和连接中断时无法正确重置客户端和数据库连接的问题。

  • 修复了 with FORCE 选项DROP DATABASE间歇性失败的问题。database is being accessed by other users

  • 减少了通过表DDL操作自动清理产生的分布式死锁。

  • 修复了使用INCREMENT BY值大于 1 的窄序列范围(例如smallint类型或小序列范围MAXVALUE)not enough values to create distributed sequence时CREATE SEQUENCE失败的问题。自动区块大小调整没有考虑到增量值,因此它无法将区块大小缩小到足以适应序列范围。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.11-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.11 兼容。有关 PostgreSQL 16.11 中改进的更多信息,请参阅 Aurora PostgreSQL 16.11。

Aurora PostgreSQL 无限数据库 16.11.102,2026 年 9 月 1 日

错误修复

  • 修复了表之间GRANT或表REVOKE上的分布式死锁以及同一个表的并发读取或写入问题。

  • 修复了由于数据库对象的 OID 不匹配导致分片组中的节点在恢复正在进行的分布式事务时可能会重复重启的问题。这使该节点不可用,需要手动干预。

  • 修复了在极少数情况下,路由器在故障转移后继续使用过时的写入器信息的问题。通过该路由器路由的写入请求被拒绝。

  • 修复了从分片节点检索结果时查询无限期挂起的问题。这是在重置与该节点的连接或停止响应之后发生的。

  • 修复了为全局序列请求新区块时返回的错误被错误分类的问题。已达到其最后一个值的序列被报告为连接失败。暂时性故障也可能停止nextval返回新值。

Aurora PostgreSQL 无限数据库 16.11.101,2026 年 6 月 9 日

错误修复

  • 修复了使用自定义运算符类创建唯一索引时无法保证唯一性的问题。

  • 修复了DROP DATABASE使用FORCE选项失败的问题database is being accessed by other users。

  • 修复了由于缓存扩展版本过时导致升级后出现跨节点版本不匹配的问题。

Aurora PostgreSQL 无限数据库 16.11.100,2026 年 2 月 25 日

功能

  • 增加了对 ALTER VIEW ... OWNER TO ... 语句的支持。

  • 增加了对pg_prewarm扩展的支持。

增强功能

  • 增强了 with SELECT 语句INSERT INTO的EXPLAIN输出。

  • 增强了查询性能,便于ENUM使用。

  • 增强了INSERT INTO语句的错误消息。该消息现在指出了失败的数值。

错误修复

  • 修复了在函数中引用分片表属性并进行连接时SELECT语句死锁的问题。

  • 当与所有列(包括PRIMARY KEY约束列UNIQUE和包含列)都被错误处理的INCLUDE子句一起使用时,修复了和约束条件。这导致索引结构与原始表定义不同。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.10-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.10 兼容。有关 PostgreSQL 16.10 中改进的更多信息,请参阅 Aurora PostgreSQL 16.10。

Aurora PostgreSQL 无限数据库 16.10.101

增强功能

  • 增强了 EXPLAIN with INSERT INTO 的输出SELECT。

错误修复

  • 修复了使用引用表列的集合返回函数加入表时出现的崩溃问题。

  • 修复了通用包装器函数的 SIMD 对齐问题导致的崩溃。

Aurora PostgreSQL 无限数据库 16.10.100,2026 年 2 月 24 日

功能

  • 添加了对 ENUM 作为分片密钥类型的支持。

  • 增加了对涉及文字和表达式的CHECK约束的支持。有关更多信息,请参阅约束。

  • 增加了对具有外键约束的 VIEW s 的支持。有关更多信息,请参阅外键。

  • 增加了对咨询锁的支持。有关更多信息,请参阅 PostgreSQL 文档中的咨询锁。

  • 增加了对pg_dump数据库迁移pg_restore的支持。您可以从 Aurora Limitless 数据库中进行转储,然后恢复到其他 Aurora Limitless 集群或常规 PostgreSQL 数据库。这种支持包括使用元数据捕获函数在 Aurora Limitless 集群之间迁移时保留分片和参考表配置。有关更多信息,请参阅备份和恢复 Amazon Aurora PostgreSQL 无限数据库。

增强功能

  • 提高了架构和表查询的性能。

  • 提高了分片拆分的性能。

  • 提高了INSERT INTO和UPDATE查询的性能。

错误修复

  • 修复了所有权限公开invalid role OID: 0时权限授予失败的问题。GRANT

  • 修复了EXPLAIN和UPDATE查询失败的问题wrong number of parameters for prepared statement。

  • 修复CREATE TABLE了失败的问题duplicate key value violates unique constraint。

  • 修复了DROP DATABASE通过 JDBC 之后数据库仍然无法使用的问题。

  • 修复了对分布式表进行UPDATE查询时失败的问题relation * does not exist。

  • 修复了使用类型转换的SELECT查询失败的问题cannot cast type cstring to text[]。

  • 修复了同时进行CREATE DATABASE设置connection_limit requires an integer value时失败的问题connection_limit。

  • 修复了从标准表到分布式表或参考表的表转换问题,以保持行级安全策略。

  • 修复了行级安全 (RLS) 策略中的正确性和数据泄露问题。我们建议删除并重新创建任何现有 RLS 策略。

  • 与一起使用时的固定DROP POLICY语句IF EXISTS。

  • 修复了选择tableoid系统列时的错误结果。tableoid是表的 OID,它是给定系统赋予数据库对象的独特标识。如果查询符合单分片优化的条件,则tableoid将从分片中获取。否则,tableoid将从连接的路由器获取。不同的路由器可能会tableoid对同一个查询产生不同的结果。

  • 修复了用户定义类型的表格的统计数据更新。

  • 修复了CREATE TABLE当设置debug_parallel_query为FATAL: Unexpected error occurred while committing transaction时失败的问题on。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.9-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.9 兼容。有关 PostgreSQL 16.9 中改进的更多信息,请参阅 Aurora PostgreSQL 16.9。

Aurora PostgreSQL 无限数据库 16.9.103,2026 年 2 月 11 日

增强功能

  • 增强了 EXPLAIN with INSERT INTO 的输出SELECT。

错误修复

  • 修复了在函数中引用分片表属性并进行连接时SELECT语句不返回的问题。

Aurora PostgreSQL 无限数据库 16.9.102,2025 年 11 月 21 日

增强功能

  • 提高了分片拆分的性能。

  • 改进了在(次要)升级期间由于实例版本不一致而导致查询失败时的错误消息。

错误修复

  • 修复了DROP DATABASE通过 JDBC 之后数据库仍然无法使用的问题。

  • 修复了所有权限公开invalid role OID: 0时权限授予失败的问题。GRANT

  • 修复了使用类型转换的SELECT查询失败的问题cannot cast type cstring to text[]。

  • 修复了同时进行CREATE DATABASE设置connection_limit requires an integer value时失败的问题connection_limit。

  • 修复了从标准表到分布式表或参考表的表转换问题,以保持行级安全策略。

  • 修复了行级安全 (RLS) 策略中的正确性和数据泄露问题。我们建议删除并重新创建任何现有 RLS 策略。

  • 与一起使用时的固定DROP POLICY语句IF EXISTS。

  • 修复了选择tableoid系统列时的错误结果。tableoid是表的 OID,它是给定系统赋予数据库对象的独特标识。如果查询符合单分片优化的条件,则tableoid将从分片中获取。否则,tableoid将从连接的路由器获取。不同的路由器可能会tableoid对同一个查询产生不同的结果。

  • 修复了撤消内部系统角色的CONNECT权限后内部流程无法正常运行的问题。

  • 修复了用户定义类型的表格的统计数据更新。

  • 修复了解决准备交易中的一个极端情况。

Aurora PostgreSQL 无限数据库 16.9.101,2025 年 11 月 6 日

错误修复

  • 修复了DROP以下情况:在CREATEALTER、和分片上不删除表以及通过 JDBC 或 ODBC 驱动程序使用预准备语句重复执行语句的问题(例如,preferQueryMode=extendedCacheEverything在 JDBC 中使用时),或何时CREATEALTER、和DROP语句作为或的一部分执行。PROCEDURE FUNCTION

  • 修复了在表中断语句中的 Heap-Only 元组 (HOT) 链的情况下使用UNIQUE INDEX扫描查询表时出现的UPDATE错误结果。

  • 修复了不必要地更换了运行状况良好的节点从而导致系统不可用的问题。

Aurora PostgreSQL 无限数据库 16.9.100,2025 年 9 月 5 日

功能

  • 增加了对 CREATE INDEX IF NOT EXISTS 的支持。

  • 在pgstattuple扩展中添加了对序列的支持。

  • 增加了对 hstore 扩展的支持。请注意,hstore 列不能用作分片表中的分片键。

  • 增加了对 auto_explain 扩展的支持。

增强功能

  • 使用相同的数据库名称时,减少了DROP DATABASE和CREATE DATABASE操作之间所需的等待时间。

  • 提高了涉及半连接DELETE和反连接的UPDATE操作的性能。

  • 提高了带有可向下推送到分片的表达式或投影INSERT INTO ... SELECT FROM语句的性能

  • 改进了详细信息部分中列出的相关查询中检测到的死锁的错误消息。

错误修复

  • 修复了数据库内部进程可能完全耗尽后台工作池的问题。

  • 修复了扩展中的不可变函数因权限拒绝错误而意外失败的问题。

  • 修复了提交时间无效的错误。

  • 修复了以下问题:READ ONLY交易结束后INSERT INTO失败,错误为:无法执行远程查询,并显示消息:必须在任何查询之前设置事务读写模式。ROLLBACK

  • 修复了SELECT查询失败并出现 ERROR: 无法执行远程查询并显示消息:整数类型不支持排序规则的问题。

  • 修复了因 ER ROR: DELETE FROM 无法执行远程查询而失败的问题。

  • 修复了DEFAULT/CHECK约束条件中的表达式可能为现有行生成不正确的回填数据的问题。当约束条件中的表达式依赖于括号时,就会出现此问题。

  • 修复了绑定消息失败的PREPARE和EXECUTE语句提供了 2 个参数的问题,但是当该语句使用的参数少于其PREPARE声明的参数时,准备好的语句需要 1 个参数。

  • 修复了 o RESET f rds_aurora.limitless_explain_options 设置未正确反映在EXPLAIN输出中的问题。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.8-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.8 兼容。有关 PostgreSQL 16.8 中改进的更多信息,请参阅 Aurora PostgreSQL 16.8。

Aurora PostgreSQL 无限数据库 16.8.104,2026 年 5 月 12 日

错误修复

  • 修复了文件描述符泄漏的问题。rds_aurora_limitless_get_max_connections

Aurora PostgreSQL 无限数据库 16.8.103,2025 年 10 月 30 日

错误修复

  • 修复了所有权限公开invalid role OID: 0时权限授予失败的问题。GRANT

  • 修复了使用类型转换的SELECT查询失败的问题cannot cast type cstring to text[]。

  • 修复了同时进行CREATE DATABASE设置connection_limit requires an integer value时失败的问题connection_limit。

  • 修复了选择tableoid系统列时的错误结果。tableoid是表的 OID,它是给定系统赋予数据库对象的独特标识。如果查询符合单分片优化的条件,则tableoid将从分片中获取。否则,tableoid将从连接的路由器获取。不同的路由器可能会tableoid对同一个查询产生不同的结果。

  • 修复了解决准备交易中的一个极端情况。

Aurora PostgreSQL 无限数据库 16.8.102,2025 年 10 月 13 日

错误修复

  • 修复了DROP以下情况:在CREATEALTER、和分片上不删除表以及通过 JDBC 或 ODBC 驱动程序使用预准备语句重复执行语句的问题(例如,preferQueryMode=extendedCacheEverything在 JDBC 中使用时),或何时CREATEALTER、和DROP语句作为或的一部分执行。PROCEDURE FUNCTION

  • 修复了在表中断语句中的 Heap-Only 元组 (HOT) 链的情况下使用UNIQUE INDEX扫描查询表时出现的UPDATE错误结果。

  • 修复了不必要地更换了运行状况良好的节点从而导致系统不可用的问题。

Aurora PostgreSQL 无限数据库 16.8.101,2025 年 6 月 30 日

增强功能

  • 改进了检测到的死锁的错误消息,现在DETAIL在本节中列出了相关的查询。

  • 增加了对包含 tableoid 作为目标列表的子查询的支持。

错误修复

  • 修复了 ANALYZE SQL 查询结果,使其也包括外部表。

  • 修复了多个可能导致数据库重启的问题。

  • 修复了绑定消息失败的PREPARE和EXECUTE语句的问题,该语句提供了 2 个参数,但是当语句使用的参数少于PREPARE声明的参数时,准备好的语句需要 1 个。

  • 修复了真空操作中导致空间消耗增加的多个问题。

  • 修复了回滚READ_ONLY交易后的INSERT语句问题。

  • 修复了带有RETURNING子句的DELETE语句失败的问题。

Aurora PostgreSQL 无限数据库 16.8.100,2025 年 5 月 8 日

功能

  • 增加了对ltree扩展的支持。ltree数据类型列不能用作分片表中的分片键。

  • 在 Aurora PostgreSQL 无限数据库中添加了对btree_gist扩展的支持。不支持使用 GIST 索引的排除约束。例如,不支持以下命令:

    CREATE TABLE zoo ( cage INTEGER, animal TEXT, EXCLUDE USING GIST (cage WITH =, animal WITH <>) );

增强功能

  • 提高了以下场景下的查询性能:

    • 带有范围子句的查询。

    • 使用来自同一个分片的不同分片密钥访问多个元组。

    • 删除和更新涉及半联接和反连接的操作。

  • 具有预取功能的增强型异步外部扫描节点。

  • 增强了死锁检测容错能力。

错误修复

  • 修复了数据库后端停止响应系统信号的问题,这可能导致 DROP DATABASE 操作挂起。

  • 修复了提交日志 (clog) 后台处理中导致提交时间为无效错误的竞争条件。

  • 修复了在自动表格分析操作期间可能导致意外崩溃的问题。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.6-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.6 兼容。有关 PostgreSQL 16.6 中改进的更多信息,请参阅 Aurora PostgreSQL 16.6。

Aurora PostgreSQL 无限数据库 16.6.103,2025 年 10 月 13 日

错误修复

  • 修复了DROP以下情况:在CREATEALTER、和分片上不删除表以及通过 JDBC 或 ODBC 驱动程序使用预准备语句重复执行语句的问题(例如,preferQueryMode=extendedCacheEverything在 JDBC 中使用时),或何时CREATEALTER、和DROP语句作为或的一部分执行。PROCEDURE FUNCTION

  • 修复了在表中断语句中的 Heap-Only 元组 (HOT) 链的情况下使用UNIQUE INDEX扫描查询表时出现的UPDATE错误结果。

  • 修复了不必要地更换了运行状况良好的节点从而导致系统不可用的问题。

Aurora PostgreSQL 无限数据库 16.6.102,2025 年 6 月 30 日

增强功能

  • 现在,针对检测到的死锁的错误消息进行了改进,其中列出了相关的查询。DETAIL

  • 改进了分布式死锁检测算法,使其能够任意适应网络或节点故障。

  • 增加了对包含 tableoid 作为目标列表的子查询的支持。

错误修复

  • 修复了 ANALYZE SQL 查询结果以包含外部表。

  • 修复了可能导致数据库重启的多个问题。

  • 修复了绑定消息失败的PREPARE和EXECUTE语句的问题,该语句提供 2 个参数,但是当该语句使用的参数少于PREPARE声明的参数时,准备好的语句需要 1 个。

  • 修复了真空操作中导致空间消耗增加的多个问题。

  • 修复了回滚READ_ONLY交易后的INSERT语句问题。

  • 修复了带有RETURNING子句的DELETE语句失败的问题。

  • 修复了DEFAULT/CHECK约束条件中的表达式可能生成错误结果的情况,特别是当约束条件中的表达式依赖于括号来生成正确的结果时。

Aurora PostgreSQL 无限数据库 16.6.101,2025 年 4 月 17 日

此版本包括 16.6.3 之前的 Aurora PostgreSQL 补丁。

错误修复

  • 修复了可能导致短暂不可用的多个问题。

  • 修复了设置limitless_minimum_adaptive_fetch_size为低于默认值 (100) 时的正确性问题。

  • 考虑到在 Aurora PostgreSQL 无限数据库中的各个节点之间可能具有不同的值,增强了在 Aurora PostgreSQL 无限数据库中查询关系的表类属性的错误处理。DBShardGroup

  • 修复了使用时可能出现的权限问题rds_aurora.limitless_active_shard_key。这解决了检索数据时的权限错误。

  • 修复了阻塞后台操作中的争用条件,该条件可能导致客户端收到提交时间无效错误。

  • 使用可变长度的分片密钥优化分布式函数的执行。以前,路由器执行分布式功能,但现在根据分片密钥在本地单个分片上执行。

  • 修复了update/delete在标准表联接参考表上执行时出现的错误。

  • 修复了任何用户都可以调用特定的内部无限函数的问题。

  • 修复了在节点崩溃期间导致子事务回滚不正确的问题。

  • 修复了DEFAULT/CHECK约束条件中嵌套括号的表达式可能生成错误结果的问题。

Aurora PostgreSQL 无限数据库 16.6.100,2025 年 1 月 24 日

功能

  • Aurora PostgreSQL 无限数据库现在支持 Aurora PostgreSQL 版本 16.6。

  • 现在,您可以安装和使用该btree_gin扩展程序。

  • 支持DISCARD数据操作语言 (DML) 命令。

增强功能

  • 对于子查询中包含参考表的查询,具有更好的下推功能,从而提高了查询性能。此增强功能优化了查询执行,有可能提高涉及子查询中引用表连接的复杂查询的性能。

  • 增强了的错误处理pg_advisory_lock。以前,尝试使用此不受支持的功能不会生成明确的错误消息,这可能会导致意外行为。现在,用户在尝试使用时将收到明确的错误通知pg_advisory_lock,从而确保更高的清晰度并防止意想不到的后果。

错误修复

  • 修复了某些CREATE TABLE命令因错误ALTER TABLE而失败的问题:无法解析给定语句。

  • 修复了以下问题:当带有NOT NULL或DEFAULT约束条件的ALTER TABLE命令包含不安全的向下推送到分片的函数(例如易失性函数),需要在现有行中回填数据时,该命令会失败。

已知问题

  • 设置rds_aurora.limitless_minimum_adaptive_fetch_size变量可能会导致不正确的结果。

亚马逊 Aurora PostgreSQL 无限数据库版本 16.4-limitless

此版本的 Aurora PostgreSQL 无限数据库与 PostgreSQL 16.4 兼容。有关 PostgreSQL 16.4 中改进的更多信息,请参阅 Aurora PostgreSQL 16.4。

Aurora PostgreSQL 无限数据库 16.4.106,2025 年 10 月 13 日

错误修复

  • 修复了DROP以下情况:在CREATEALTER、和分片上不删除表以及通过 JDBC 或 ODBC 驱动程序使用预准备语句重复执行语句的问题(例如,preferQueryMode=extendedCacheEverything在 JDBC 中使用时),或何时CREATEALTER、和DROP语句作为或的一部分执行。PROCEDURE FUNCTION

  • 修复了在表中断语句中的 Heap-Only 元组 (HOT) 链的情况下使用UNIQUE INDEX扫描查询表时出现的UPDATE错误结果。

  • 修复了不必要地更换了运行状况良好的节点从而导致系统不可用的问题。

Aurora PostgreSQL 无限数据库 16.4.105,2025 年 4 月 17 日

错误修复

  • 修复了可能导致短时间不可用的多个问题。

  • 修复了导致包含外部关系谓词的反连接查询结果不正确的问题。

  • 为以下系统功能增加了向下推功能:

    • pg_char_to_encoding

    • pg_encoding_to_char

    • textanycat

    • anytextcat

  • 增强了 Aurora PostgreSQL 无限数据库pg_advisory_lock中的错误处理。进行此更改后,您在尝试使用时会收到明确的错误通知pg_advisory_lock。

  • 修复了在DEFAULT/CHECK约束条件中添加带有嵌套括号的表达式可能会生成错误结果的问题。

Aurora PostgreSQL 无限数据库 16.4.104,2024 年 11 月 19 日

错误修复

  • 修复了运行时处理数据定义语言 (DDL) 语句时CREATE INDEX CONCURRENTLY可能发生死锁的问题。

  • 修复了分布式死锁解析中的错误可能会阻止后续分布式死锁检测的问题。

  • 修复了如果在会话中使用rds_aurora.limitless_active_shard_key变量,则带有底层数据操作语言 (DML) 语句(例如CREATE TABLE AS或调用包含数据的表)的 DDL 语句会导致错误的问题。

  • 修复了分片拆分操作导致错误的问题。

  • 修复了设置rds_aurora.limitless_alter_table_type_sharded变量后将表格类型转换为分片的rds_aurora.limitless_alter_table_type_sharded过程失败的问题。

  • 修复了多态对象解析逻辑中的一个问题,该问题导致传递数据的隐式转换导致使用不正确的对象版本时,无效查询不会产生错误。

已知问题

  • 当查询的一部分转换为左连接或反连接条件时,可能会出现问题。在这些情况下,如果内部关系没有结果,则使用空行。

  • 添加带有NOT NULL或DEFAULT约束条件的列时,可能会出现问题,该列包含无法向下推送到分片的函数(例如易失性函数),需要在现有行中回填数据。

  • 当准备分片查询的解析逻辑尽可能不使用括号时,可能会出现问题。在查询中使用时COLLATE,这可能会导致错误。

Aurora PostgreSQL 无限数据库 16.4.103,2024 年 10 月 31 日

版本 16.4.103 是 Aurora PostgreSQL 无限数据库的 GA 版本。

有关此版本的信息,请参阅亚马逊 Aurora 用户指南中的使用亚马逊 Aurora PostgreSQL 无限数据库。