本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。
问题排查
本章详细介绍了创建或管理 Amazon EVS 环境时遇到的一些常见问题。
博通和 AWS 支持指导
AWS 为亚马逊 EVS 及其相关基础设施服务提供支持,包括 VMware 云基金会 (VCF)。有关 VCF-specific 配置指导或与其他 VMware 产品(例如 Aria Suite、HCX 或 NSX)相关的问题,您也可以使用您的博通支持权直接联系博通。有关更多信息,请参阅 Broadcom 支持门户
对失败的环境状态检查进行故障排除
Amazon EVS 会自动检查您的环境以发现问题。您可以查看环境的状态,以确定具体和可检测的问题。
查看环境状态检查信息
使用亚马逊 EVS 控制台调查受损环境
-
打开亚马逊 EVS 控制台。
-
在导航窗格中,选择 “环境”,然后选择您的环境。
-
选择 “详细信息” 选项卡以查看环境概述。
-
检查环境状态。将鼠标悬停在此字段上可展开弹出窗口,其中包含每个环境状态检查的单独结果。
可访问性检查失败
可访问性检查可验证亚马逊 EVS 与 SDDC 管理器之间是否存在永久连接。如果 Amazon EVS 无法访问环境,则此项检查将失败。
如果此项检查失败,Amazon EVS 将无法再访问 SDDC 管理器来验证环境状态,也无法再将主机添加到环境中。可访问性故障还将导致许可证密钥重复使用和密钥覆盖检查失败,而主机计数检查返回未知响应。
为确保可访问性,请检查以下内容:
-
确保您的证书有效且未过期。可以使用 SDDC 管理器用户界面或 vSphere 客户端来管理 VCF 环境中的证书。部署后,建议您替换 VMware Cloud Foundation 管理域的所有证书。有关更多信息,请参阅 VMware Cloud Foundation 文档中的 “在 VMware 云基础中
管理证书”。 -
确保可从服务访问子网访问您的 DNS 服务器,DNS 记录有效,并且不存在重复的主机名或 IP 地址。
-
如果您想创建自己的防火墙规则,请遵循以下准则:
-
允许 TCP/UDP 访问 DNS 服务器。
-
允许 HTTPS/SSH 访问主机管理 VLAN 子网。
-
允许 HTTPS/SSH 访问管理虚拟机 VLAN 子网。
-
如果您在遵循本指南后仍无法解决问题,我们建议您联系 AWS 支持部门寻求进一步的帮助。
主机数量检查失败
此检查用于验证您的环境是否满足 VCF 部署拓扑所要求的最低主机数量。
如果此检查失败,请添加主机,以使您的环境满足最低要求。有关按 VCF 版本和部署拓扑统计的最低主机数量要求,请参阅 VMware Cloud Foundation 文档
密钥重复使用检查失败
此检查可验证另一个 Amazon EVS 环境是否正在使用 VCF 许可证密钥。VCF 许可证只能用于一个 Amazon EVS 环境。如果您在环境创建请求中提供已被其他环境使用的 VCF 许可证密钥,则此检查将失败。
如果此项检查失败,您将收到错误响应,提示无法创建 Amazon EVS 环境。要解决此问题,请在 SDDC 管理器中审核许可证设置,并将所有以前使用的许可证替换为未使用的许可证。
重要
使用 SDDC 管理器用户界面管理 VCF 解决方案和 vSAN 许可证密钥。亚马逊 EVS 要求您在 SDDC 管理器中维护有效的 VCF 解决方案和 vSAN 许可证密钥,服务才能正常运行。虽然必须使用 vSphere Client 将密钥分配给您的主机和 vSAN 集群,但必须确保这些密钥也出现在 SDDC Manager 用户界面的许可屏幕上。
密钥覆盖率检查失败
此项检查可验证分配给 vCenter 服务器的 VCF 许可证密钥是否为所有已部署的主机分配了足够的 vCPU 内核和 vSAN 存储容量(TiB)。
如果此项检查失败,您将收到错误响应,提示无法创建 Amazon EVS 环境。密钥覆盖失败可能表示存在以下问题之一:
-
VCF 许可证未正确地分配给 vCenter 服务器。必须在 vCenter 服务器的评估期到期或当前分配的许可证到期之前,将许可证分配给该服务器。如果这是问题所在,请在 SDDC 管理器中审核许可证分配情况。
-
当前的 VCF 许可证不包括 vCPU 内核和 vSAN 存储容量需求。VCF 解决方案密钥(包括最低核心数量)和 vSAN 许可证密钥(包括最低 vSAN 容量)的要求因实例类型而异。有关配置的特定阈值,请参阅VCF 订阅。如果这是问题所在,请在 SDDC 管理器中添加 vSAN 许可证,直到满足使用需求为止。
如果上述操作无法解决问题,请联系 AWS 支持部门寻求进一步的帮助。
重要
使用 SDDC 管理器用户界面管理 VCF 解决方案和 vSAN 许可证密钥。亚马逊 EVS 要求您在 SDDC 管理器中维护有效的 VCF 解决方案和 vSAN 许可证密钥,服务才能正常运行。虽然必须使用 vSphere Client 将密钥分配给您的主机和 vSAN 集群,但必须确保这些密钥也出现在 SDDC Manager 用户界面的许可屏幕上。
此主机上的 vSphere HA 代理无法到达隔离地址
<IPv6 address>在 vCenter 用户界面中,选择 ESX 主机后,您将看到消息 “此主机上的 vSphere HA 代理无法到达隔离地址”。
此错误消息表示主机上的 vSphere HA 代理无法到达 vSphere HA 用于心跳检查的默认 IPv6 隔离地址。该错误消息并不表示存在问题,仅在亚马逊 EVS 目前不支持 IPv6 时才会出现。亚马逊 EVS 不支持 IPV6 不会影响 vSphere HA 的核心功能。
ESX 主机群集的 vSAN 升级预检查失败
尝试使用 SDDC 管理器升级 ESX 主机群集时,与 vSAN 磁盘相关的预检查可能会失败。这是因为亚马逊 EVS 使用 vSAN 快速存储架构 (ESA),而升级预检查不适用于 vSAN ESA。有关更多信息,请参阅有关此主题https://knowledge.broadcom.com/external/article/369423/upgrade-prechecks-fails-with-esxi-cluste.html
添加由于集群映像不兼容而导致的主机故障
问题
当您将主机添加到环境时,该主机拥有 EVS 自定义供应商插件的最新可用版本。如果您的环境使用带有较旧插件版本的主机,则添加新主机将失败,并显示新主机与您的集群映像不兼容的错误。要修复此问题,必须使用 vSphere 生命周期管理器从新添加的主机中提取最新的可用插件版本。
解决方案
执行以下步骤。
-
转到 VMware vCenter Server 中的主机和集群清单。
-
通过创建临时空集群从新添加的主机中提取插件。
-
在 “基础知识” 下,选择 “从 vCenter 清单中的现有主机导入映像”,然后创建集群。将所有其他设置保留为默认设置。
-
使用提取的映像创建此临时集群后,您可以删除该临时集群。该插件现在将在您的 vSphere 生命周期管理器库中提供。
-
转到您的环境集群并选择更新选项卡。
-
编辑您的集群映像并将插件版本更改为新提取的版本。
-
选择保存。
-
在 SDDC 管理器中,重试失败的添加主机任务。这将修复您的集群主机,将所有主机更新到最新的附加版本。集群映像修复需要重新启动主机。
在主机调试期间,SDDC 管理器未通过 VCF 主机验证
问题
如果您在 Amazon EVS 环境部署后更新了 ESX 版本,则在 VCF 主机验证期间,SDDC 管理器可能会在佣金主机步骤中失败。要修复此问题,必须使用 vSphere 生命周期管理器在新添加的主机上升级 ESX。
解决方案
执行以下步骤。
重要
这些步骤需要临时将主机添加到 SDDC 管理器之外的 vCenter。使用 vSphere 生命周期管理器执行除 ESX 升级之外的任何操作都可能会使您的主机无法使用,并且需要您删除和创建新的 Amazon EVS 主机。
-
转到 VMware vCenter Server 中的主机和集群清单。
-
将主机临时添加到您的虚拟数据中心,确保选择 “使用映像管理主机” 。ESX 升级完成后,将在后续步骤中移除该主机。有关更多信息,请参见《vSphere》文档中的
如何将主机添加到 vSphere 数据中心或文件夹。 -
将主机添加到 vSphere 后,升级主机上的 ESX 版本。这可以在房东的 “更新” 选项卡中完成。编辑主机映像以匹配集群的 ESX 版本。
-
升级完成后,将主机从 vCenter 清单中移除。有关更多信息,请参见《vSphere》文档中的如何从您的 vCenter 服务器实例
中删除 ESX 主机。 -
在 SDDC 管理器中为您的主机分配佣金。有关更多信息,请参阅 VMware Cloud Foundation 文档中的
佣金主机。 -
调试主机后,使用 SDDC Manager 将主机添加到您的集群中。
对 Windows 服务器授权进行故障排除
有关解决 Windows 服务器授权问题的帮助,请参阅Windows 服务器授权疑难解答。