本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。
解决 Lightsail Connect 错误
本指南解释了通过浏览器连接到 Lightsail 实例时可能看到的错误代码,以及您可以做些什么来重新连接。在下面的列表中找到你遇到的错误代码,然后完成其步骤。
512(服务器错误)
这是什么意外:发生了意外错误,无法完成连接。
可能的原因:间歇性的网络或互联网问题,或连接重置。
操作:
-
确保您的互联网连接稳定。
-
刷新 Lightsail Connect 会话。
514 (UPSTREAM_TIMEOUT)
这是什么意思:等待响应时连接超时。
可能的原因:连接期间网络中断。
操作:
-
确保您的互联网连接稳定。
-
刷新 Lightsail Connect 会话。
515(UPSTREAM_ERROR)
这意味着什么:无法完成与您的实例的连接。
可能的原因:您的实例资源不足,或者仍在启动且尚未准备好连接。当您的实例的防火墙规则被阻止时,也可能发生这种情况 SSH/RDP。有关防火墙规则的更多信息,请参阅在 Lightsail 中使用防火墙控制实例流量。
操作:
-
如果实例最近启动或重新启动,请稍等片刻,让实例准备好连接,然后重试。
-
SSH/RDP 从 Lightsail Connect 验证您的实例的防火墙规则是否允许。
-
如果缺少必需的规则,请按照以下说明进行添加:向 Lightsail 实例添加防火墙规则
-
添加所需规则后重试连接。
-
-
按照以下说明重启实例,然后重试:启动、停止或重启你的 Lightsail 实例
516(未找到资源)
这意味着什么:Lightsail Connect 找不到您的实例。
可能的原因:您的实例可能已被删除,或者出现临时问题。
操作:
-
确认该实例在 Lightsail 控制台中仍然存在。如果已删除,请连接到其他实例。
-
稍等片刻,然后尝试再次连接。
-
在 Lightsail 控制台中检查您的实例的状态。如果它仍在启动,请等到它正在运行,然后重试。如果它已停止,请启动它并等待它运行后再连接。启动、停止或重启你的 Lightsail 实例
-
重启实例,然后重新连接。
519(上游未找到)
这意味着什么:Lightsail 无法访问您的实例。
可能的原因:无法访问该实例,通常是因为它仍在启动或尚未响应。
操作:
-
如果该实例最近启动或重新启动,请等待几分钟使其完成启动,然后再次尝试连接。
-
确认该实例正在 Lightsail 控制台中运行。
-
重启实例,然后再次尝试连接。有关说明,请参阅启动、停止或重启你的 Lightsail 实例。
521(会话冲突)
这是什么意思:您的会话因另一个会话接管而结束。一次只允许一个 RDP 会话。
根本原因:第二个 RDP 会话被打开到同一个实例,例如在另一个浏览器选项卡中,它取代了第一个会话。
操作:
-
关闭你不想使用的会话,然后在你想保留的会话中重新连接。
-
避免向同一 Windows 实例打开多个 RDP 会话。
523(会话已关闭)
这意味着什么:您的实例上的会话已结束,因此连接已关闭。
可能的原因:最常见的是实例被重启或停止。也可能是由于会话被注销所致。
操作:
-
如果实例正在重启或停止,请等待其完成,然后重新连接。
-
如果该实例仍然没有响应,请重启它并重试。启动、停止或重启你的 Lightsail 实例
524(UPSTREAM_NLA_身份验证_失败)
这是什么意思:RDP 身份验证失败。提供的密码被您的实例拒绝。您通常会看到 “密码无效” 消息。
可能的原因:实例密码已更改,输入的凭证不再匹配。
操作:
-
Re-enter 该实例的正确当前密码。
-
如果您最近更改了密码,请使用新密码。
-
525(已超出连接截止日期)
这意味着什么:您已达到 Lightsail Connect 允许进行单个会话的最大时长,因此 Lightsail Connect 关闭了与您的实例的连接。
根本原因:会话已达到 Lightsail Connect 设定的连接时间限制。
操作:
-
重新连接以启动新会话。
767(UPSTREAM_HOSTKEY_MISMATCH)
这意味着什么:您的实例提供的 SSH 主机密钥与我们存档的主机密钥不匹配。
可能的原因:实例上的 SSH 主机密钥已更改,例如重新生成或手动更改密钥时。
操作:
-
如果您最近对实例进行了更改并预计其主机密钥会发生变化,则这是预期的。在对话框中,选择 “重置记录” 以更新 Lightsail 存档的主机密钥;然后连接将自动恢复。
-
如果对话框要求您稍后再试,请等待几分钟,然后重新连接。
768(客户机错误请求)
这是什么意思:无法启动连接,因为请求无效。
可能的原因:这通常是临时问题或浏览器端的问题,与您的实例无关。
操作:
-
刷新浏览器选项卡,然后从实例的连接页面重新启动连接。
-
如果实例最近启动或更改了状态,请等待一两分钟,然后重试。启动、停止或重启你的 Lightsail 实例
769(未经授权的客户端)
这意味着什么:对实例的身份验证失败。您提供的 SSH 密钥已被您的实例拒绝。
可能的原因:在创建实例后不久,在实例准备接受 Lightsail Connect 会话之前,您可能会看到这一点。
操作:
-
如果您最近创建或启动了实例,请等待几分钟,然后再次尝试连接。
771 (CLIENT_FORBIDDEN)
这是什么意思:访问连接被拒绝。
可能的原因:通常是暂时的权限问题。
操作:
-
稍等片刻,然后尝试再次连接。
776 (CLIENT_TIMEOUT)
这意味着什么:您的浏览器停止响应 Lightsail Connect 服务器,因此连接已关闭。
可能的原因:浏览器限制或冻结了背景 tab/window,当选项卡最小化或留在后台时,这种情况很常见。
操作:
-
保持连接选项卡处于活动状态并处于前台。
-
重新连接以恢复会话。
-
避免在长时间会话期间让浏览器暂停选项卡。
797(客户太多)
这是什么意思:你打开的并发会话太多了。最大值为五个 SSH 会话和每个实例一个 RDP 会话。
根本原因:打开超出允许限制的其他会话。
操作:
-
在打开新会话之前关闭现有会话。
-
确保每个实例保持在五个 SSH /一个 RDP 会话以内。