View a markdown version of this page

對 Lightsail Connect 錯誤進行故障診斷 - Amazon Lightsail

本文為英文版的機器翻譯版本,如內容有任何歧義或不一致之處,概以英文版為準。

對 Lightsail Connect 錯誤進行故障診斷

本指南說明透過瀏覽器連線至Lightsail執行個體時可能看到的錯誤代碼,以及您可以如何再次連線。尋找您在下列清單中遇到的錯誤代碼,並執行其步驟。

512 (SERVER_ERROR)

意義:發生非預期的錯誤,無法完成連線。

可能原因:間歇性網路或網際網路問題,或連線重設。

處理方式:

  • 確保您的網際網路連線穩定。

  • 重新整理 Lightsail Connect 工作階段。

514 (UPSTREAM_TIMEOUT)

意義:等待回應時連線逾時。

可能原因:連線期間網路中斷。

處理方式:

  • 確保您的網際網路連線穩定。

  • 重新整理 Lightsail Connect 工作階段。

515 (UPSTREAM_ERROR)

意義:無法完成與執行個體的連線。

可能原因:您的執行個體資源不足,或仍在啟動且未準備好連線。當您執行個體的防火牆規則封鎖 SSH/RDP 時,也可能發生這種情況。如需防火牆規則的詳細資訊,請參閱 使用 中的防火牆控制執行個體流量 Lightsail。

處理方式:

516 (RESOURCE_NOT_FOUND)

意義:LightsailConnect 找不到您的執行個體。

可能原因:您的執行個體可能已刪除,或遇到暫時性問題。

處理方式:

  • 確認執行個體仍存在於 Lightsail主控台中。如果已刪除,請連線至不同的執行個體。

  • 請稍候,然後再次嘗試連線。

  • 在 Lightsail主控台中檢查執行個體的狀態。如果仍在啟動中,請等到執行中,然後再試一次。如果停止,請啟動它並等到它執行後再連線。 啟動、停止或重新啟動Lightsail執行個體

  • 重新啟動執行個體,然後重新連線。

519 (UPSTREAM_NOT_FOUND)

意義: Lightsail 無法連線到您的執行個體。

可能原因:無法連線執行個體,最常見的原因是執行個體仍在啟動或尚未回應。

處理方式:

  • 如果執行個體最近啟動或重新啟動,請等待幾分鐘讓它完成啟動,然後再次嘗試連線。

  • 確認執行個體正在Lightsail主控台中執行。

  • 重新啟動執行個體,然後再次嘗試連線。如需說明,請參閱啟動、停止或重新啟動Lightsail執行個體。

521 (SESSION_CONFLICT)

意義:您的工作階段已結束,因為另一個工作階段接管。一次只允許一個 RDP 工作階段。

根本原因:第二個 RDP 工作階段已開啟至相同的執行個體,例如在另一個瀏覽器索引標籤中,它從第一個接管。

處理方式:

  • 關閉您不想使用的工作階段,然後在您要保留的工作階段中重新連線。

  • 避免對相同的 Windows 執行個體開啟多個 RDP 工作階段。

523 (SESSION_CLOSED)

其意義:執行個體上的工作階段已結束,因此連線已關閉。

可能原因:通常執行個體已重新啟動或停止。它也可能由登出的工作階段造成。

處理方式:

524 (UPSTREAM_NLA_AUTHENTICATION_FAILURE)

意義:RDP 身分驗證失敗。您執行個體已拒絕所提供的密碼。您通常會看到「無效密碼」訊息。

可能原因:執行個體密碼已變更,且輸入的登入資料不再相符。

處理方式:

  • 重新輸入執行個體的正確目前密碼。

    • 如果您最近變更密碼,請使用新的密碼。

525 (CONNECTION_DEADLINE_EXCEEDED)

意義:您已達到 Lightsail Connect 允許單一工作階段的時間上限,因此 Lightsail Connect 會關閉與執行個體的連線。

根本原因:工作階段已達到 Lightsail Connect 設定的連線時間限制。

處理方式:

  • 重新連線以啟動新的工作階段。

767 (UPSTREAM_HOSTKEY_MISMATCH)

其意義:執行個體呈現的 SSH 主機金鑰不符合我們檔案上的主機金鑰。

可能原因:執行個體上的 SSH 主機金鑰已變更,例如當金鑰重新產生或手動變更時。

處理方式:

  • 如果您最近對執行個體進行了變更,並預期其主機金鑰會變更,則預期會發生這種情況。在對話方塊中,選擇重設記錄以更新已Lightsail存檔的主機金鑰;接著連線會自動恢復。

  • 如果對話方塊要求您稍後再試一次,請等待幾分鐘,然後重新連線。

768 (CLIENT_BAD_REQUEST)

意義:無法啟動連線,因為請求無效。

可能的原因:這通常是暫時性或瀏覽器端的問題,而不是執行個體的問題。

處理方式:

769 (CLIENT_UNAUTHORIZED)

意義:對執行個體的身分驗證失敗。您的執行個體已拒絕顯示的 SSH 金鑰。

可能原因:在建立執行個體之後不久,執行個體準備好接受 Lightsail Connect 工作階段之前,您可能會看到此情況。

處理方式:

  • 如果您最近建立或啟動執行個體,請等待幾分鐘,然後再次嘗試連線。

771 (CLIENT_FORBIDDEN)

意義:對連線的存取遭拒。

可能原因:通常是暫時性許可問題。

處理方式:

  • 請稍候並再次嘗試連線。

776 (CLIENT_TIMEOUT)

其意義:您的瀏覽器已停止回應 Lightsail Connect 伺服器,因此連線已關閉。

可能原因:瀏覽器調節或凍結背景標籤/視窗,這在標籤最小化或留在背景中時很常見。

處理方式:

  • 保持連線索引標籤處於作用中狀態,並在前景中。

  • 重新連線以繼續您的工作階段。

  • 避免讓瀏覽器在長時間工作階段期間暫停索引標籤。

797 (CLIENT_TOO_MANY)

意義:您已開啟太多並行工作階段。每個執行個體最多五個 SSH 工作階段和一個 RDP 工作階段。

根本原因:開啟超出允許限制的其他工作階段。

處理方式:

  1. 在開啟新的工作階段之前,請先關閉現有的工作階段。

  2. 確保每個執行個體保持在五個 SSH/一個 RDP 工作階段內。