Die vorliegende Übersetzung wurde maschinell erstellt. Im Falle eines Konflikts oder eines Widerspruchs zwischen dieser übersetzten Fassung und der englischen Fassung (einschließlich infolge von Verzögerungen bei der Übersetzung) ist die englische Fassung maßgeblich.
Behebung von Speicher- und Verschlüsselungsproblemen
In diesem Abschnitt werden mögliche Lösungen für Speicher- und Verschlüsselungsprobleme beschrieben.
Themen
Beheben Sie die Richtlinien für verschlüsselte Amazon S3-Buckets
Beschreibung
Sie haben einen verschlüsselten Amazon S3-Bucket, den Sie als Speicher für Ihren Transfer Family-Server verwenden. Wenn Sie versuchen, eine Datei auf den Server hochzuladen, erhalten Sie die FehlermeldungCouldn't close
file: Permission denied.
Und wenn Sie sich die Serverprotokolle ansehen, werden die folgenden Fehler angezeigt:
ERROR Message="Access denied" Operation=CLOSE Path=/bucket/user/test.txt BytesIn=13 ERROR Message="Access denied"
Ursache
Die Richtlinie für Ihren IAM-Benutzer ist nicht berechtigt, auf den verschlüsselten Bucket zuzugreifen.
Lösung
Sie müssen in Ihrer Richtlinie zusätzliche Berechtigungen angeben, um die erforderlichen AWS Key Management Service (AWS KMS) Berechtigungen zu gewähren. Details hierzu finden Sie unter Datenschutz und Verschlüsselung.
Fehler ResourceNotFound beheben
Beschreibung
Sie erhalten eine Fehlermeldung, bei der die Ressource nicht gefunden werden kann. Wenn Sie beispielsweise ausführenUpdateServer, wird möglicherweise die folgende Fehlermeldung angezeigt:
An error occurred (ResourceNotFoundException) when calling the UpdateServer operation: Unknown server
Ursache
Es gibt mehrere Gründe für den Empfang einer ResourceNotFoundException Nachricht. In den meisten Fällen ist die Ressource, die Sie in Ihrem API-Befehl angegeben haben, nicht vorhanden. Wenn Sie eine vorhandene Ressource angegeben haben, ist die wahrscheinlichste Ursache, dass sich Ihre Standardregion von der Region für Ihre Ressource unterscheidet. Wenn Ihre Standardregion beispielsweise us-east-1 ist und sich Ihr Transfer Family-Server in us-east-2 befindet, erhalten Sie eine Ausnahme für unbekannte Ressourcen.
Einzelheiten zum Festlegen einer Standardregion finden Sie unter Schnellkonfiguration mit. aws configure
Lösung
Fügen Sie Ihrem API-Befehl einen Regionsparameter hinzu, um explizit anzugeben, wo eine bestimmte Ressource zu finden ist.
aws transfer -describe-server --server-idserver-id--region us-east-2