Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.
Licuadora
Blender es un conjunto de herramientas de software gráfico 3D gratuito y de código abierto que se utiliza para crear películas animadas, efectos visuales, arte, modelos impresos en 3D, gráficos animados, aplicaciones 3D interactivas, realidad virtual y juegos de ordenador. Blender es compatible con AWS Deadline Cloud (Deadline Cloud) con una integración integral que incluye remitentes, paquetes conda y un adaptador para aumentar el rendimiento de renderizado. Esta guía proporciona instrucciones paso a paso para usar Deadline Cloud con Blender para renderizar tus proyectos más rápido distribuyendo las tareas de renderizado en varias máquinas.
Descripción general del soporte
Blender es compatible con los siguientes componentes:
-
Remitente: remitente integrado para el envío directo de trabajos desde Blender con detección automática de escenas y activos.
-
Paquetes Conda: Deadline Cloud para la instalación automática en flotas gestionadas por servicios.
-
Adaptador: un programa que se instala en los servidores de los trabajadores y que mantiene la aplicación cargada entre tareas para acelerar la renderización e informa sobre el progreso de la renderización.
-
Cross-platform compatibilidad: soporte para remitentes para Windows, macOS y Linux y soporte para Worker para Windows y Linux con asignación automática de rutas.
Compatibilidad entre versiones de Blender
La siguiente tabla muestra los niveles de soporte actuales para las versiones de Blender:
| Versión principal | Soporte para remitentes | Soporte de Conda | Motores de renderizado |
|---|---|---|---|
| 3.6 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 4.2 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 4.5 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 5.0 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 5.1 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
Canal Conda de Deadline Cloud
En la siguiente tabla se enumeran todos los paquetes de conda aplicables a Blender disponibles para las Service-managed flotas que se encuentran en el canal conda en la nube que tiene fecha límite:
| SO | Package | Versión | Notas |
|---|---|---|---|
| Linux | licuadora | 3.6 | Incluye todos los motores de renderizado integrados |
| Linux | licuadora | 4.2 | Incluye todos los motores de renderizado integrados |
| Linux | licuadora | 4.5 | Incluye todos los motores de renderizado integrados |
| Linux | licuadora | 5.0 | Incluye todos los motores de renderizado integrados |
| Linux | licuadora | 5.1 | Incluye todos los motores de renderizado integrados |
| Linux | blender-openjd | Incluye el adaptador Blender |
Introducción
Para usar Blender con Deadline Cloud:
-
Crea una flota gestionada por servicios y asóciala a una cola. Su cola debe configurarse con un entorno de colas que sea compatible con el canal conda en la nube con fecha límite. Para obtener más información, consulta Cómo crear un entorno de colas.
-
Instala el monitor Deadline Cloud y el remitente de Blender en tu estación de trabajo de artista utilizando los instaladores de monitor y remitente de Deadline Cloud. Para obtener más información, consulte Configure su estación de trabajo.
-
Envía tu trabajo directamente desde Blender a la lista de espera utilizando el sistema de envío integrado.
-
Supervisa el trabajo y descarga el resultado con el monitor Deadline Cloud.
Instalación
Para instalar el remitente de Deadline Cloud para Blender, necesita:
-
Una estación de trabajo Windows, macOS o Linux.
-
Blender 3.6 o posterior.
Hay tres maneras de instalar el remitente de Deadline Cloud para Blender:
-
Usar el instalador de Deadline Cloud Submitter (recomendado).
-
Instalar el remitente desde Blender.
Uso del instalador del remitente de Deadline Cloud
Puedes instalar el remitente de Deadline Cloud para Blender mediante el instalador del remitente de Deadline Cloud.
Para instalar el remitente
-
Descargue el instalador del remitente de Deadline Cloud.
-
Ejecute el instalador.
-
Cuando se te pida, selecciona cada versión de Blender con la que quieras usar el remitente.
-
-
Lanza Blender.
-
Comprueba la instalación consultando la opción Enviar a Deadline Cloud en el menú Render.
Si el complemento no está disponible en el menú Render, debe habilitarlo manualmente.
Para habilitar manualmente el complemento de remitente
-
En el menú Edición, seleccione Preferencias...
-
Selecciona Rutas de archivos en la barra lateral izquierda.
-
Busque la sección Directorios de scripts y elija +.
-
En Nombre, escriba
python. -
En Path, introduce la ruta al
pythondirectorio de tu instalación de Blender Submitter. -
Reinicia Blender para que los cambios surtan efecto.
Instalación del remitente desde Blender
nota
Esta función es experimental y está sujeta a cambios.
Puedes instalar y actualizar el remitente de Blender desde Blender usando la función de extensión de Blender.
Para instalar el remitente de Blender usando las extensiones de Blender, necesitas:
-
Blender 4.2 o posterior.
-
Una estación de trabajo con acceso constante a Internet.
Para agregar el remitente de Blender como una extensión
-
Abre Blender.
-
En el menú Edición, selecciona Preferencias...
-
Selecciona Obtener extensiones en la barra lateral izquierda.
-
Selecciona Repositorios, +, Agregar repositorio remoto.
-
En URL, escriba
https://github.com/aws-deadline/deadline-cloud-for-blender/releases/latest/download/index.json. -
Seleccione Buscar actualizaciones al iniciar el sistema y elija Crear.
-
En la entrada Disponible de Deadline Cloud, seleccione Instalar.
El complemento ya está instalado. Puedes usar la nueva opción Enviar a Deadline Cloud en el menú Render.
Cuando hay una actualización disponible, aparece un botón de actualización junto a la entrada de Deadline Cloud en la sección Obtener extensiones.
Uso del remitente de Blender
Para usar el remitente de Deadline Cloud para Blender, necesitas:
-
Un perfil con el que enviar a Deadline Cloud.
-
Una granja de Deadline Cloud y una cola a la que enviar.
Enviar un trabajo
Para enviar un trabajo desde Blender a Deadline Cloud
-
Guarda tu archivo de Blender.
-
En el menú Render, selecciona Enviar a Deadline Cloud.
-
Es posible que aparezca una ventana emergente para instalar las dependencias de la GUI. Selecciona Aceptar y espera a que desaparezca el cuadro de diálogo y, a continuación, vuelve a elegir Enviar a Deadline Cloud.
-
-
Usa las pestañas del cuadro de diálogo para personalizar tu trabajo.
-
(Opcional) Para exportar los archivos asociados a un trabajo a su directorio de historial de trabajos sin enviarlo, seleccione Exportar paquete.
-
Selecciona Enviar y sigue las instrucciones para enviar tu trabajo a Deadline Cloud.
Blender-specific ajustes
La pestaña Job-specific de configuración tiene opciones específicas para los trabajos creados en Blender.
-
Ruta del proyecto: la ubicación en la que se guarda el proyecto actual. Este valor no se puede cambiar.
-
Directorio de salida: la ubicación donde se guardan las salidas de los archivos del trabajo de renderizado.
-
Prefijo del archivo de salida: el patrón que se usa al nombrar las salidas de los archivos sigue la convención de Blender para los nombres de archivos. Los archivos de salida están formateados de la siguiente manera.
[LayerName]_[CameraName]_[OutputPrefix].[EXT] -
Escena: la escena del proyecto actual que se va a renderizar.
-
Motor de renderizado: el motor de renderizado (Cycles, EEVEE o Workbench) que se va a utilizar.
-
Ver capas: la capa que se va a renderizar o «Todas las capas renderizables» para renderizar cada capa aplicable de la escena por separado.
-
Cámaras: la cámara para renderizar, «Todas las cámaras renderizables» para renderizar cada cámara de la escena por separado o «Usar la cámara predeterminada» para usar la cámara predeterminada de la escena o las cámaras vinculadas a los marcadores de la línea de tiempo.
-
Ciclos de renderizado por GPU: si se debe habilitar el renderizado por GPU. Elige un tipo de dispositivo compatible con Blender o especifica el tuyo propio. Si este tipo de dispositivo no es compatible con tu máquina de renderizado, el adaptador intentará usar un tipo de dispositivo compatible antes de volver a renderizar con CPU.
-
Anular el rango de fotogramas: seleccione esta opción para renderizar un fotograma o un rango de fotogramas diferente al establecido en el archivo de escena. Los rangos de fotogramas siguen el patrón
Open Job Description.
Para obtener información sobre las demás pestañas de remitentes, consulte la guía de Deadline Cloud sobre el uso de un remitente.
Configuraciones avanzadas
Uso de versiones no compatibles
Deadline Cloud solo admite y prueba las versiones del software para estaciones de trabajo y trabajadores que figuran en la tabla anterior. Cuando utilice el remitente, el trabajador intentará instalar la misma versión que la utilizada en la estación de trabajo. Esta instalación falla si la versión de Blender para estaciones de trabajo no aparece en la tabla de versiones anterior.
Si necesitas una versión no compatible de Blender, tienes las siguientes opciones:
-
Al enviar el trabajo desde Blender, puedes anular el parámetro de CondaPackages cola para especificar una versión compatible para usarla en el programa de trabajo (por ejemplo,).
blender=4.5, blender-openjd=*Esta anulación puede funcionar o no, en función de las funciones que utilice tu escena y de cómo funcione Blender con las escenas de la versión de tu estación de trabajo. -
Puedes crear una receta y un canal de conda personalizados para que la versión que desees se instale en el programa de trabajo. Utilice la receta de conda para una versión compatible que se vincula a continuación como punto de partida y empaquete la versión que desee en un canal de conda personalizado. Para obtener más información sobre la creación de canales de conda personalizados, consulte Creación de canales de conda personalizados.
Complementos de Blender
Puedes hacer que los complementos de Blender estén disponibles para los trabajadores de flotas gestionadas por servicios creando un paquete de conda a partir de una receta de conda y agregándolo a un canal de conda personalizado. Cuando el entorno de conda se activa en un trabajador, el complemento se instala a través de la API de Blender; cuando se desactiva, el complemento se elimina. Para obtener más información sobre los canales de conda personalizados, consulta Cómo crear canales de conda personalizados.
Las siguientes recetas de conda están disponibles como puntos de partida:
-
El complemento Conda Recipe de FLIP Fluids incluye
la versión demo del complemento de simulación de líquidos de FLIP Fluids. -
El paquete de complementos de Blender conda recipe
empaqueta varios complementos de Blender en un solo archivo para que se instalen juntos cuando se active el entorno de conda.
Motores de render de Blender
Blender incluye varios motores de renderizado integrados compatibles:
| Motor de renderizado | Description (Descripción) | Soporte de GPU | Notas |
|---|---|---|---|
| Ciclos | Physically-based trazador de rutas | GPU/CPU híbrido | Renderización con calidad de producción con aceleración por GPU |
| Eevee | Real-time motor de renderizado | Optimizado para GPU | Ventana gráfica rápida y renderizado final |
| Banco de trabajo | Motor de sombreado sólido | Optimizado para GPU | Para modelar y esculpir flujos de trabajo |
Todos los motores de renderizado son detectados y configurados automáticamente por el remitente integrado de Blender. La aceleración por GPU está disponible cuando se utilizan flotas administradas por servicios con instancias. GPU-enabled
Recursos de código abierto
El remitente y el adaptador son de código abierto y están disponibles en: GitHub
-
Las recetas de conda de Blender
están disponibles en GitHub las versiones compatibles.