View a markdown version of this page

Solução de problemas - Amazon Elastic VMware Service

As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.

Solução de problemas

Este capítulo detalha alguns problemas comuns encontrados ao criar ou gerenciar ambientes do Amazon EVS.

Broadcom e AWS Orientação de suporte

AWS fornece suporte para o Amazon EVS e seus serviços de infraestrutura associados, incluindo o VMware Cloud Foundation (VCF). Para obter orientação de VCF-specific configuração ou problemas relacionados a outros produtos da VMware, como Aria Suite, HCX ou NSX, você também pode entrar em contato diretamente com a Broadcom usando seu direito de suporte da Broadcom. Para obter mais informações, consulte Portal de suporte da Broadcom.

Solucionar problemas nas verificações de status do ambiente que falharam

O Amazon EVS realiza verificações automatizadas em seu ambiente para identificar problemas. É possível visualizar o status do seu ambiente para identificar problemas específicos e detectáveis.

Revise as informações de verificação do status do ambiente

Para investigar ambientes comprometidos usando o console Amazon EVS

  1. Abra o console do Amazon EVS.

  2. No painel de navegação, escolha Ambientes e selecione seu ambiente.

  3. Selecione a guia Detalhes para ter uma visão geral do ambiente.

  4. Verifique o status do ambiente. Passe o mouse sobre esse campo para expandir um popover com resultados individuais para cada verificação de status do ambiente.

Falha na verificação de acessibilidade

A verificação de acessibilidade verifica se o Amazon EVS tem uma conexão persistente com o SDDC Manager. Se o Amazon EVS não conseguir acessar o ambiente, essa verificação falhará.

Se essa verificação falhar, o Amazon EVS não poderá mais acessar o SDDC Manager para validar o status do ambiente e não será mais possível adicionar hosts ao ambiente. A falha na acessibilidade também fará com que a reutilização da chave de licença e as verificações de cobertura da chave falhem e a verificação da contagem de hosts exiba a resposta Desconhecido.

Para garantir a acessibilidade, verifique o seguinte:

  • Verifique se seus certificados são válidos e não expiraram. É possível usar a interface de usuário do SDDC Manager ou o cliente do vSphere para gerenciar certificados em um ambiente do VCF. Após a implantação, é recomendável substituir todos os certificados do domínio de gerenciamento do VMware Cloud Foundation. Para obter mais informações, consulte Gerenciando certificados no VMware Cloud Foundation na documentação do VMware Cloud Foundation.

  • Certifique-se de que seus servidores DNS estejam acessíveis a partir da sub-rede de acesso ao serviço, que os registros DNS sejam válidos e que não haja nomes de host ou endereços IP duplicados.

  • Se você quiser criar suas próprias regras de firewall, siga estas diretrizes:

    • Permita o TCP/UDP acesso aos servidores DNS.

    • Permita o HTTPS/SSH acesso à sub-rede da VLAN de gerenciamento do host.

    • Permita o HTTPS/SSH acesso à sub-rede VLAN da VM de gerenciamento.

Se você ainda não conseguir resolver o problema depois de seguir essas orientações, recomendamos que entre em contato com o AWS Suporte para obter mais assistência.

Falha na verificação da contagem de hosts

Esta verificação confirma se o seu ambiente atende à contagem mínima de hosts exigida pela topologia de implantação do VCF.

Se essa verificação falhar, adicione hosts para que seu ambiente satisfaça o requisito mínimo. Para obter o número mínimo de hosts por versão do VCF e a topologia de implantação, consulte a documentação do VMware Cloud Foundation.

Falha na verificação de reutilização de chaves

Essa verificação verifica se a chave de licença do VCF não está sendo usada por outro ambiente do Amazon EVS. As licenças do VCF só podem ser usadas para um único ambiente do Amazon EVS. Essa verificação falhará se você fornecer chaves de licença VCF em uma solicitação de criação de ambiente que já esteja sendo usada por outro ambiente.

Se essa verificação falhar, você receberá uma resposta de erro informando que não foi possível criar o ambiente do Amazon EVS. Para resolver o problema, analise suas configurações de licença no SDDC Manager e substitua todas as licenças usadas anteriormente por licenças não utilizadas.

Importante

Use a interface de usuário do SDDC Manager para gerenciar a solução VCF e as chaves de licença do vSAN. O Amazon EVS exige que você mantenha a solução VCF válida e as chaves de licença do vSAN no SDDC Manager para que o serviço funcione corretamente. Embora as chaves devam ser atribuídas aos seus hosts e ao cluster vSAN usando o vSphere Client, você deve garantir que essas chaves também apareçam na tela de licenciamento da interface de usuário do SDDC Manager.

Falha na verificação da cobertura da chave

Essa verificação examina se sua chave de licença do VCF atribuída ao vCenter Server aloca núcleos de vCPU e capacidade de armazenamento (TiB) vSAN suficientes para todos os hosts implantados.

Se essa verificação falhar, você receberá uma resposta de erro informando que não foi possível criar o ambiente do Amazon EVS. A falha na cobertura da chave pode indicar um dos seguintes problemas:

  • As licenças do VCF não estão atribuídas corretamente ao vCenter Server. É necessário atribuir uma licença ao vCenter Server antes que o período de avaliação expire ou a licença atribuída no momento expire. Se esse for o problema, analise as atribuições de licença no SDDC Manager.

  • As licenças atuais do VCF não atendem às necessidades de capacidade de armazenamento do núcleo do vCPU e do vSAN. Os requisitos da chave da solução VCF (incluindo o número mínimo de núcleos) e da chave de licença do vSAN (incluindo a capacidade mínima do vSAN) variam de acordo com o tipo de instância. Para obter limites específicos para sua configuração, consulteAssinaturas VCF. Se esse for o problema, adicione licenças do vSAN no SDDC Manager até que suas necessidades de uso sejam atendidas.

Se as ações acima não resolverem o problema, entre em contato com o AWS Suporte para obter mais assistência.

Importante

Use a interface de usuário do SDDC Manager para gerenciar a solução VCF e as chaves de licença do vSAN. O Amazon EVS exige que você mantenha a solução VCF válida e as chaves de licença do vSAN no SDDC Manager para que o serviço funcione corretamente. Embora as chaves devam ser atribuídas aos seus hosts e ao cluster vSAN usando o vSphere Client, você deve garantir que essas chaves também apareçam na tela de licenciamento da interface de usuário do SDDC Manager.

O agente de HA do vSphere neste host não conseguiu acessar o endereço de isolamento

<IPv6 address>Na interface de usuário do vCenter, com o host ESX selecionado, você vê a mensagem “O agente do vSphere HA neste host não pôde alcançar o endereço de isolamento”.

Essa mensagem de erro indica que o agente vSphere HA em um host não consegue acessar o endereço de isolamento IPv6 padrão que o vSphere HA usa para verificações de pulsação. A mensagem de erro não é indicativa de um problema e ocorre apenas porque o Amazon EVS não oferece suporte a IPv6 no momento. A ausência de suporte IPV6 para o Amazon EVS não afeta a funcionalidade principal do vSphere HA.

As pré-verificações de upgrade do vSAN falham para o cluster de host ESX

Ao tentar atualizar o cluster de host ESX usando o SDDC Manager, as pré-verificações relacionadas ao disco do vSAN podem falhar. Isso ocorre porque o Amazon EVS usa o vSAN Express Storage Architecture (ESA) e as pré-verificações de upgrade não se aplicam ao vSAN ESA. Para obter mais informações, consulte o artigo da base de conhecimento da Broadcom sobre esse tópico.

Falha na adição do host devido à imagem de cluster incompatível

Problema

Quando você adiciona um host ao seu ambiente, o host tem a versão mais recente disponível do complemento de fornecedor personalizado EVS. Se seu ambiente usa hosts com uma versão de complemento mais antiga, a adição de novos hosts falhará com um erro de que o novo host não é compatível com sua imagem de cluster. Para corrigir esse problema, você deve usar o vSphere Lifecyle Manager para extrair a versão complementar mais recente disponível do host recém-adicionado.

Solução

Siga estas etapas.

  1. Acesse o inventário de hosts e clusters no VMware vCenter Server.

  2. Extraia o complemento do host recém-adicionado criando um cluster vazio temporário.

  3. Em Noções básicas, selecione Importar imagem de um host existente no vCenter Inventory e crie o cluster. Deixe todas as outras configurações como padrão.

  4. Depois que esse cluster temporário for criado com a imagem extraída, você poderá excluir o cluster temporário. O complemento agora estará disponível em seu depósito do vSphere Lifecycle Manager.

  5. Acesse seu cluster de ambiente e selecione a guia Atualizações.

  6. Edite a imagem do cluster e altere a versão do complemento para a versão recém-extraída.

  7. Escolha Salvar.

  8. No SDDC Manager, repita a tarefa de adição de host que falhou. Isso corrigirá seus hosts de cluster, atualizando todos os hosts para a versão complementar mais recente. A remediação da imagem do cluster exigirá reinicializações do host.

O SDDC Manager falha na validação do host VCF durante o comissionamento do host

Problema

Se você atualizou sua versão do ESX após a implantação do ambiente Amazon EVS, o SDDC Manager pode falhar durante a validação do host VCF na etapa de comissionamento de hosts. Para corrigir esse problema, você precisará usar o vSphere Lifecyle Manager para atualizar o ESX no host recém-adicionado.

Solução

Siga estas etapas.

Importante

Essas etapas exigem a adição temporária do host ao vCenter fora do SDDC Manager. Usar o vSphere Lifecyle Manager para qualquer operação que não seja a atualização do ESX pode tornar seu host inutilizável e exigir que você exclua e crie um novo host Amazon EVS.

  1. Acesse o inventário de hosts e clusters no VMware vCenter Server.

  2. Adicione o host temporariamente ao seu data center virtual, garantindo a seleção de gerenciar o host com uma imagem. O host será removido em uma etapa posterior após a conclusão do upgrade do ESX. Para obter mais informações, consulte Como adicionar um host ao seu data center ou pasta do vSphere na documentação do vSphere.

  3. Depois que o host for adicionado ao vSphere, atualize a versão ESX no host. Isso pode ser feito na guia Atualizações do seu host. Edite a imagem do host para corresponder à versão ESX do seu cluster.

  4. Depois que a atualização for concluída, remova o host do seu inventário do vCenter. Para obter mais informações, consulte Como remover um host ESX da sua instância do vCenter Server na documentação do vSphere.

  5. Comissione seu anfitrião no SDDC Manager. Para obter mais informações, consulte Commission Hosts na documentação do VMware Cloud Foundation.

  6. Depois que o host for comissionado, adicione-o ao seu cluster usando o SDDC Manager.

Solucionar problemas de direitos do Windows Server

Para obter ajuda na solução de problemas de direitos do Windows Server, consulte. Solução de problemas de direitos do Windows Server