View a markdown version of this page

带上你自己的 Windows 桌面许可证 WorkSpaces - 亚马逊 WorkSpaces

本文属于机器翻译版本。若本译文内容与英语原文存在差异,则一律以英文原文为准。

带上你自己的 Windows 桌面许可证 WorkSpaces

如果你与微软签订的许可协议允许,你可以在 Windows 10 或 11 桌面上安装和部署 WorkSpaces。为此,您必须启用自带许可 (BYOL) 并提供满足以下要求的 Windows 10 或 11 许可证。有关在上使用微软软件的更多信息 AWS,请参阅亚马逊网络服务和微软。

为了遵守微软的许可条款,请在 AWS 云端专为你准备的硬件 WorkSpaces上 AWS 运行你的 BYOL。通过提供您自己的许可证,您可以为用户提供一致的体验。有关更多信息,请参阅WorkSpaces 定价。

重要

已从 Windows 11 的一个版本升级到较新版本的 Windows 11(Windows 升 feature/version级)的 Windows 11 系统不支持创建映像。例如,升级到 24H2 的 Windows 11 23H2 系统不能用于创建映像。但是, WorkSpaces 映像创建过程支持 Windows 累积更新或安全更新。

如果你的账户已经启用了 BYOL,则无需预置新的专用基础架构来运行由 Windows 11 提供支持的 WorkSpaces 应用程序队列。支持现有 WorkSpaces 个人或泳池 BYOL 工作负载的专用硬件可用于 WorkSpaces 应用程序。只需将你的 Windows 11 BYOL 映像导入到 WorkSpaces 应用程序中,然后从中创建队列即可。要了解更多信息,请参阅自带 WorkSpaces 应用程序的 Windows 桌面许可证。

使用 “自带 Windows 桌面许可证” WorkSpaces

使用以下步骤在亚马逊中导入和使用您自己的 Windows 桌面许可证 WorkSpaces

在开始之前,请验证以下几点:

  • 您的 Microsoft 许可协议是否允许 Windows 在虚拟托管环境中运行。

  • 对于非GPU-enabled 捆绑商品, WorkSpaces 每个地区每月至少需要 50 个。此最低要求可确保工作负载在专用硬件上运行,符合 Microsoft 许可要求。

    • 最低 50 个实例可以由同一区域内的 WorkSpaces 应用程序唯一用户流式传输会话(AlwaysOn 或 On-Demand)和 WorkSpaces 个人实例的任意组合来满足。专用硬件由配置和管理 AWS ——您的 VPC 可以保持默认租期。

    • 如果您计划使用 GPU-enabled 捆绑包,请确认您每月在专用硬件上每个区域至少运行 4 AlwaysOn 或 20 个 AutoStop GPU-enabled WorkSpaces and/or WorkSpaces 应用程序。

    注意

    导入 BYOL 图像时请考虑以下几点:

    • GPU-enabled 套装不适用于非洲(开普敦)地区和以色列(特拉维夫)地区。

    • 作为映像导入过程的一部分, AWS 自动检索系统日志以解决图像导入错误,提供故障排除帮助,并向用户提供准确的错误消息。

    • GPU-enabled 捆绑包不适用于非洲(开普敦)地区和以色列(特拉维夫)地区。

    • 要 WorkSpaces 在非洲(开普敦)地区跑步,您需要在非洲(开普敦)地区跑步至少 400 WorkSpaces 次。

    • 超值套餐不适用于 Windows 11 和 WorkSpaces 矿池。有关迁移现有价值套餐的更多信息, WorkSpaces 请参阅WorkSpace 在 WorkSpaces 个人版中迁移。

    • 为了获得最佳视频会议体验,建议使用 Power(4 个 vCPU,16 GB 或更大内存)捆绑包。

  • WorkSpaces 可以使用 /16 IP 地址范围内的管理接口。管理接口连接到用于交互式流媒体的安全 WorkSpaces 管理网络。这样可以 WorkSpaces 管理您的 WorkSpaces. 有关更多信息,请参阅 网络接口。为此,您必须从以下 IP 地址范围中的至少一个预留 /16 网络掩码,并确保您选择的 IP 地址范围在您的网络中不发生冲突:

    • 10.0.0。0/8

    • 100.64.0。0/10

    • 172.16.0。0/12

    • 192.168.0。0/16

    • 198.18.0。0/15

    注意
    • 当您采用该 WorkSpaces 服务时,可用的管理接口 IP 地址范围经常发生变化。要确定当前有哪些范围可用,请运行 list-availle-manag AWS Command Line Interface ement-cidr-ranges () 命令。AWS CLI

    • 除了你选择的 /16 CIDR 区块外,还有 54.239.224。0/20 IP 地址范围用于所有 AWS 区域的管理接口流量。

S3 访问权限

如果您使用数据边界控制环境中 Amazon S3 的访问权限,则可能需要明确允许访问存储由 EC2 映像生成器管理的组件的 Amazon S3 存储桶。您可以使用存储桶 ARN 或存储桶 URL 将这些存储桶列入许可名单,具体取决于您如何控制对 Amazon S3 的访问权限。

Amazon EC2 映像生成器组件管理引导脚本所需的访问权限:

  • S3 存储桶 ARN:arn:<AWS partition>:s3:::ec2imagebuilder-managed-resources-<AWS Region>-prod

  • S3 存储桶 URL:https://ec2imagebuilder-managed-resources-<AWS Region>.s3.<AWS Region>.<AWS partition-specific domain name>

亚马逊 EC2 映像生成器托管组件所需的访问权限:

  • S3 存储桶 ARN:arn:<AWS partition>:s3:::ec2imagebuilder-toe-<AWS Region>-prod

  • S3 存储桶 URL:https://ec2imagebuilder-toe-<AWS Region>.s3.<AWS Region>.<AWS partition-specific domain name>

网络连接

如果您使用代理来筛选要导入 BYOL 映像的 AWS 账户中的出站通信(例如 AWS 网络防火墙),请确保可以访问以下 HTTPS 终端节点:

亚马逊 EC2 映像生成器组件所需的访问权限:

  • ssm.<region>.amazonaws.com

  • ssmmessages.<region>.amazonaws.com

  • ec2messages.<region>.amazonaws.com

  • imagebuilder.<region>.amazonaws.com

  • ec2.<region>.amazonaws.com

  • s3.<region>.amazonaws.com

  • s3.us-east-1.amazonaws.com

  • tools.amazonworkspaces.com

  • go.microsoft.com

  • definitionupdates.microsoft.com

  • time.windows.com

上面的列表并不详尽,建议使用具有公共互联网访问权限的 VPC。映像导入过程不支持使用 AWS 的 PrivateLink VPC。

支持 BYOL 的 Windows 版本

您的虚拟机必须使用 x64 架构运行以下 Windows 版本之一:

  • Windows 10 版本 22H2(2022 年 11 月更新)

  • Windows 10 Enterprise LTSC 2019(1809)

  • Windows 10 Enterprise LTSC 2021(21H2)

  • Windows 11 企业版 LTSC 2024 (24H2)

  • Windows 11 Enterprise 22H2(2022 年 10 月发布)

  • Windows 11 Enterprise 23H2(2023 年 10 月发布)

  • Windows 11 Enterprise 24H2(2024 年 10 月发布)

  • Windows 11 企业版 25H2(2025 年 9 月发布)

你需要使用支持的 Windows 操作系统版本的 Windows 虚拟机映像或 Windows ISO 映像文件:

  • 登录微软 365 管理中心下载企业版 ISO 镜像。在 Visual Studio 订阅门户上登录您的订阅以获取可用的下载。不要使用从不提供企业版 ISO 的 Windows 11 公共下载网站下载的 ISO 文件。

  • 要使用自定义的虚拟机映像,请在导入之前验证您的映像。

  • 导入过程不支持加密 AMI。配置最终 WorkSpaces 版本后,可以启用加密。

  • 不支持默认 EBS 加密。在导入映像之前,在 EC2 控制台中禁用默认加密。

    重要

    Software-level 导入之前, BitLocker 必须在源映像上禁用诸如 Microsoft 之类的磁盘加密。启用了 BitLocker或其他全盘加密软件的图像将导致导入过程失败。 BitLocker 在导出虚拟机进行导入之前,请确保已关闭且卷已完全解密。

  • 对于 Windows 11 映像, WorkSpaces 需要启用 UEFI 启动模式。有关 EC2 Image Builder 如何检测启动模式的更多信息,请参阅《虚拟机 Import/Export 用户指南》 Import/Export中的 VM 支持的卷类型和文件系统。

  • 所有支持的操作系统版本都支持您使用的 AWS 地区中所有可用的计算类型 WorkSpaces。微软不再支持的 Windows 版本不能保证正常运行,支持部门也不支持这些版本。 AWS

重要

如果您使用的是 Windows 10 或 Windows 11 LTSC(Long-Term 服务渠道)版本,请注意,亚马逊 EC2 映像生成器不支持为 LTSC 版本导入 ISO。您必须使用其他方法来创建基础映像,例如使用aws ec2 import-image AWS CLI 命令直接导入 VM 镜像。有关更多信息,请参阅《虚拟机 Import/Export 用户指南》中的 VM 导入支持的操作系统。

注意

目前,BYOL 不支持 Windows 10 N 和 Windows 11 N 版本。

注意

BYOL WorkSpaces 支持嵌套虚拟化。您可以使用、或 API 启用或禁用它 AWS 管理控制台 AWS CLI,就像在公共捆绑包上一样。有关更多信息,请参阅 WorkSpaces 个人嵌套虚拟化。

在确认满足使用 Windows BYOL 的先决条件后 WorkSpaces,需要允许您的帐户使用 BYOL 映像。

  1. 在 WorkSpaces 控制台中,导航到账户设置页面。

  2. 在“自带许可(BYOL)”部分,您会看到账户的 BYOL 启用状态。如果状态显示账户未启用,请选择开始使用 BYOL 按钮。

  3. 在 BYOL 页面上,选择“为账户启用 BYOL”。

    注意

    为账户启用 BYOL 仅适用于单个区域。请记下您当前所在的区域,如果您想使用其他区域,请在为账户启用 BYOL 前切换到相应区域。

  4. 将出现一个弹出模式,确认您了解使用 BY WorkSpaces OL 的最低要求。确认您已了解相关要求,然后选择“启用账户”。

    注意

    如果您计划在 BYOL 中 WorkSpaces 使用 Graphics,请创建 AWS 支持请求单。控制台尚不支持显卡 BYOL 启用。 WorkSpaces

  5. 在大多数情况下,账户会自动启用。但是,有些账户需要进一步审核。刷新后,您会在 BYOL 页面上看到启用状态。

  6. 为账户启用 BYOL 后,请继续执行下一步。

注意

此步骤仅适用于要导入的自定义虚拟机映像。如果您要导入的是 Windows ISO,则可跳过此步骤。

如果您要导入自定义虚拟机映像,我们建议您运行 I WorkSpaces mage Checker 工具,以确保您的 VM 与 WorkSpaces兼容。映像检查程序工具会运行一系列测试,并且可以帮助修复兼容性问题。

下载映像兼容性检查程序脚本

在下载并运行映像兼容性检查程序脚本之前,请验证虚拟机上是否安装了最新的 Windows 安全更新。此脚本在运行时会禁用 Windows 更新服务。

  1. 将图像兼容性检查器脚本.zip 文件从ImageCompatibilityChecker.zip您的Downloads文件夹中下载。

  2. 在 Downloads 文件夹中,创建一个 BYOL 文件夹。

  3. 从 ImageCompatibilityChecker.zip 中提取文件并将其复制到 Downloads\BYOL 文件夹。

  4. 删除 Downloads\ImageCompatibilityChecker.zip 文件夹,以便仅保留提取的文件。

检查是否未启用 Windows 虚拟机 BitLocker。有关此要求的更多信息,请参阅上面的在亚马逊上使用 Windows BYOL 的先决条件 WorkSpaces部分。

确保未启用 Windows VM BitLocker
  1. 以管理员身份打开 PowerShell。

  2. 运行以下命令:

    manage-bde -off DriveLetter:
  3. BitLocker 通过运行以下命令检查的状态:

    manage-bde -Status DriveLetter:
  4. 确保显示的值与以下值相匹配:

    • BitLocker 版本 — 无

    • 转换状态 – 已完全解密

    • 加密百分比 – 0.0%

    • 加密方法 - 无

    • 保护状态 - 保护已关闭

    • 锁定状态:已解锁

执行以下步骤以运行映像兼容性检查程序脚本。

运行映像兼容性检查程序脚本
  1. 以管理员身份打开 PowerShell。

    1. 选择 Windows 的“开始”按钮。

    2. Right-click Windows PowerShell。

    3. 选择以管理员身份运行。

    4. 如果出现用户账户控制提示,请选择是。

  2. 在 PowerShell 命令提示符处,切换到映像兼容性检查器脚本所在的目录。例如,如果脚本位于 Downloads\BYOL 目录中,请输入以下命令并按 Enter:

    cd C:\Users\username\Downloads\BYOL

  3. 输入以下命令更新计算机上的 PowerShell 执行策略。这样可以运行映像兼容性检查程序脚本:

    Set-ExecutionPolicy AllSigned

  4. 当系统提示确认是否更改 PowerShell 执行策略时,请输入A以指定 Yes to All。

  5. 输入以下命令以运行映像兼容性检查程序脚本:

    .\ImageCompatibilityChecker.exe

  6. 如果有安全通知出现,请按 R 键以运行一次。

  7. 在 “WorkSpaces 图像验证” 对话框中,选择 “运行测试” 。

  8. 每个测试完成后,您都可以查看测试的状态。对于状态为 FAILED (失败) 的任何测试,请选择 Info (信息) 以显示有关如何解决导致失败的问题的信息。如果任何测试显示了状态 WARNING (警告),请选择 Fix All Warnings (修复所有警告) 按钮。

  9. 适当时,请解决导致测试故障和警告的任何问题,然后重复 步骤 7 和 步骤 8,直到 VM 通过所有测试。您在导出 VM 之前必须解决所有故障和警告。

  10. BYOL 脚本检查程序将生成两个日志文件:WorkSpacesImageCompatabilityCheckLogYYYY-MM-DD_HHmmss.txt 和 ImageInfo.text。这两个文件位于映像兼容性检查程序脚本文件所在的目录中。

    提示

    请勿删除这些文件。出现问题时,它们可能有助于解决问题。

  11. 如果您的 VM 通过了所有测试,您将收到 Validation Successful (验证成功) 消息。

    您还将看到运行 Sysprep 的提示。关闭提示,暂时不要运行 Sysprep。

  12. 关闭虚拟机并将其导出。有关更多信息,请参阅《虚拟机 Import/Export 用户指南》中的 “将虚拟机从虚拟环境中导出”。

  13. (可选)启动虚拟机并再次运行映像兼容性检查程序脚本。应通过所有验证。屏幕将再次弹出,上面有一个用于运行 Sysprep 的按钮。选择运行 Sysprep。如果 Sysprep 成功,可将您在步骤 12 导出的虚拟机导入 Amazon Elastic Compute Cloud(Amazon EC2)中。

    如果 Sysprep 不成功,请查看 %WINDIR%\System32\Sysprep\Panther 路径中的 Sysprep 日志,从步骤 12 回滚到导出的虚拟机,解决报告的问题,然后通过导出固定虚拟机再次完成步骤 12。然后,重新运行映像兼容性检查程序脚本,以确保问题已得到解决。

    Sysprep 失败的最常见原因是未针对所有用户卸载现代 AppX 程序包。使用 Remove-AppxPackage PowerShell cmdlet 删除 AppX 软件包。

  14. 将您在步骤 12 中导出的虚拟机导入到 Amazon EC2。

执行以下步骤以导入您的映像并创建 WorkSpaces BYOL 映像:

  1. 转至导航窗格并选择映像,然后选择导入映像。

  2. 根据基础映像选项和要导入的映像类型,按照导入映像页面上的步骤进行操作:

    • 虚拟机导入:导入已经自定义的虚拟机映像。您可以导入 VHDX、VMDK 或 OVF 文件。

    • ISO 导入:导入从 Microsoft 下载的未自定义的 Windows ISO 映像。

    • AMI 导入 — 导入现有的 Amazon EC2 AMI 以用作您的 WorkSpaces BYOL 映像。

  3. 请执行以下操作之一:

    • 对于虚拟机导入选项,请将您的文件上传到 Amazon S3,然后指定文件要导入的位置。请注意,您使用的 S3 存储桶必须位于您打算部署 BYOL WorkSpaces 的同一区域。

    • 对于 ISO 导入:导入从 Microsoft 下载的未自定义的 Windows ISO 映像。请注意,您使用的 S3 存储桶必须位于您打算部署 BYOL WorkSpaces 的同一区域。

    • 对于AMI 导入,请指定 AMI ID。

  4. 转至基础设施配置。

    WorkSpaces 自动创建亚马逊 EC2 映像生成器管道来构建您的 BYOL 映像。基础设施配置定义如何配置 EC2 Image Builder 来构建映像。您可以使用以下设置对其进行自定义:

    • 服务默认值:创建并使用默认 IAM 角色和策略来构建映像。

    • 使用现有基础设施配置:提供一系列自定义基础设施配置选项,这些配置已在 Amazon EC2 Image Builder 中完成设置。有关更多信息,请参阅《EC2 Image Builder 用户指南》中的创建基础设施配置。

  5. 转至高级设置并选择是否要在映像遇到导入错误时终止 EC2 构建实例。

    • 如果您选择在出现故障时终止实例,则在映像导入工作流程中,您将无法访问实例来调试错误。

    • 如果您选择不终止实例,则实例可用于调试错误,但运行 EC2 实例可能会产生额外费用。

  6. 转至映像详情以指定映像的属性:包括映像名称。

    • 映像名称:映像的唯一标识符。

    • 计算类型 — 指定此图像应使用非graphics/base 硬件还是图形硬件

    • 操作系统版本:选择映像的 Windows 操作系统版本

    • 语义版本:为映像定义语义版本,该版本将存储在 EC2 Image Builder 中。有关更多信息,请参阅《EC2 Image Builder 用户指南》中的 Image Builder 中的语义版本控制。

注意

在 BYOL 导入过程中,将在您的 AWS 账户中创建 EC2 映像生成器资源。为了创建映像,系统会自动创建名为 AWSServiceRoleForImageBuilder 的服务相关角色(若该角色尚未存在)。此角色将包含 AWS 托管策略AWSServiceRoleForImageBuilder。您还必须具有 V Import/Export M 导入自定义 VM 映像所需的权限。

创建映像时,控制台映像页面上的状态将显示为待处理。BYOL 摄取过程至少需要 90 分钟。

导入映像时出现的错误将与建议解决方案一起显示在映像页面上。详细日志可在亚马逊导入图像时创建的映像生成器日志组 CloudWatch 下找到。可能的错误类型如下:

  • 映像错误:EC2 Image Builder 无法生成映像。修复虚拟化环境中的问题并导入新映像。

  • Image Builder 错误:尝试构建映像时出错。查看亚马逊中的映像生成器日志 CloudWatch ,了解更多详情

  • EC2 错误:映像存在无法自动修复的问题。要解决这些错误,您可以连接到 Amazon EC2 实例(如果该实例设置为在构建失败时不终止)并直接执行修复。然后,您可以从“映像”页面重试导入。

  • Auto-fixed 错误 -这些问题已由 WorkSpaces自动修复。无需进一步操作。

有关常见错误的详细信息,请参阅常见错误消息及其解决方案。

BYOL 在专用硬件上 WorkSpaces 运行,以符合微软的许可条款。为了支持这一点,创建了 BYOL 管理接口,以便在您 WorkSpaces 和 AWS 托管 WorkSpaces 管理网络之间建立安全连接。有关更多信息,请参阅网络接口。

如果您在同一地区有另一个启用了 BYOL 的 AWS 账户,则应跨账户使用相同的管理界面,以减少预留的 IP 地址。为此,请不要选择管理接口 IP 地址范围,可参阅下面的关联 BYOL 账户。

选择管理接口 IP 地址范围
  1. 返回账户设置中的 BYOL 页面。

  2. 在选择 IP 范围部分中,选择选择 IP 范围按钮。

  3. 通过提供网络上可用的 IP 地址范围来输入搜索范围。 WorkSpaces 返回与您的搜索相匹配的可用的 /16 网络掩码 IP 地址范围。

  4. 选择可用的 IP 地址范围(以 CIDR 数据块的形式显示)。

    注意

    为管理接口选择 IP 范围后,便无法更改。

如果您在同一地区有另一个启用了 BYOL 的 AWS 账户,该账户共享相同的付款人账户,则应在各个账户之间使用相同的管理界面,以减少预留的 IP 地址。关联账户还可以避免满足每个账户的最低 BYOL 要求,因为最低要求是在关联账户之间共享的。如果您在同一个付款人账户下没有启用了 BYOL 的另一账户,请跳过此步骤。

要关联到现有 BYOL 账户,请不要选择 IP 地址范围。

关联 BYOL 账户
  1. 登录已启用 BYOL WorkSpaces 的 AWS 帐户。

  2. 导航至账户设置中的 BYOL 页面。

  3. 在选择 IP 范围部分中,选择账户关联部分下的发送邀请按钮。

  4. 提供未启用 BYOL 且您希望关联的账户的账户 ID。 AWS

    注意

    这两个账户必须在同一区域使用 BYOL。

  5. 发送关联邀请后,返回到尚未启用 BYOL 的 AWS 账户。在账户设置页面中,您将看到一条横幅通知,显示您有待处理的 BYOL 账户关联邀请。在横幅中选择查看邀请。

  6. 确认账户关联邀请。

如果您希望对同一个付款人账户下的两个账户使用不同的管理界面,请联系 AWS 支持部门寻求帮助。

按照中的说明创建 BYOL 映像后,您可以使用该映像创建一个自定义捆绑包。有关信息,请参阅为 WorkSpaces 个人创建自定义 WorkSpaces 镜像和捆绑包。

要将 BYOL 映像用于 WorkSpaces,必须为此目的创建一个目录。

要为创建目录 WorkSpaces,请参阅为 WorkSpaces 个人创建目录。确保在创建目录 WorkSpaces 时选择 “启用专用”。

重要

如果您在注册目录时未看到 “启用专用 WorkSpaces ” 选项,请确保您已完成在您的账户和地区启用 BYOL 的步骤。

如果您已经注册了无法在专用硬件上运行的微软 AD AWS 托管目录或 AD 连接器目录,则可以为此目的设置新的微软 AD AWS 托管目录或 AD 连接器目录。 WorkSpaces 您也可以取消注册该目录,然后将其重新注册为专用 WorkSpaces目录。要了解有关注册和取消注册现有 AWS 目录服务目录的更多信息,请参阅向 WorkSpaces 个人注册现有 AWS 目录服务目录。

启动您的 BYOL WorkSpaces 个人版

要启动个人用户 WorkSpaces,请参阅 WorkSpace 在 WorkSpaces 个人中创建。

启动你的 BYOL 池 WorkSpaces

要启动一个 WorkSpaces 矿池,你必须启动一个人物 WorkSpace,为该个人创建一张图片 WorkSpace,然后使用该图像启动一个池。

为 BYOL 池 WorkSpaces 创建映像
  1. 使用您想在 WorkSpaces 泳池中使用的 BYOL 映像启动个人 WorkSpace 账户。有关如何启动 WorkSpaces 个人版的信息,请参阅 WorkSpace 在 WorkSpaces 个人中创建。

  2. 登录到个人账户 WorkSpace ,确保安装了所有的 Windows 更新。

  3. 更新您的 Amazon EC2 配置。要使用 Windows 10 更新您的 EC2 配置,请参阅安装最新版本的 EC2Config。要使用 Windows 11 更新您的 EC2 配置,请参阅安装最新版本的 EC2Launch。

  4. 添加 Windows Defender 排除列表。有关更多信息,请参阅 Add an exclusion to Windows Security。

    在 Windows Defender 中将以下文件夹添加到排除列表中:

    • C:\Program Files\Amazon\

    • C:\ProgramData\Amazon\*

    • C:\Program Files\NICE\

    • C:\ProgramData\NICE\

    • C:\Program Files (x86)\AWS Tools\*

    • C:\Program Files (x86)\AWS SDK for .NET\*

    • C:\AWSEUC\(这适用于会话脚本)

  5. 输入以下命令,在启动时禁用 Windows 更新。

  6. 以管理员身份打开 PowerShell。

    1. 选择 Windows 的“开始”按钮。

    2. Right-click Windows PowerShell。

    3. 选择以管理员身份运行。

    4. 如果出现用户账户控制提示,请选择是。

  7. 运行以下命令:

    New-Item -Path "HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" -Force
    New-Item -Path "HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU" -Force
    Set-ItemProperty -Path "HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU" -Name "NoAutoUpdate" -Value 1 -Force
  8. 重启 WorkSpace. 有关更多信息,请参阅 WorkSpace 在 WorkSpaces 个人版中重启。

    注意

    我们建议您在开始为 BYOL WorkSpaces 池创建映像之前执行以下操作。

    • 删除不必要的启动应用程序。

    • 删除或禁用不必要的计划任务。打开“开始”菜单,选择计划任务,选择要禁用的任务,然后选择禁用。

  9. 通过输入以下命令,在重新启动后运行映像检查程序。

    C:\Program Files\Amazon\ImageChecker.exe
  10. 解决映像检查程序发现的任何错误。有关更多信息,请参阅“解决映像检查程序检测到的问题的提示”。

  11. 在所有测试都通过图像检查器后,返回 WorkSpaces 控制台。

  12. 在导航窗格下方 WorkSpaces,选择个人。选择 BYOL 个人 WorkSpaces,然后选择操作、创建图像。

  13. 在导航窗格中,选择映像。在映像下,检查是否已创建映像。

现在,您可以使用您创建的映像启动 WorkSpaces 池。有关启动 WorkSpaces 池的更多信息,请参阅创建 WorkSpaces 池。