As traduções são geradas por tradução automática. Em caso de conflito entre o conteúdo da tradução e da versão original em inglês, a versão em inglês prevalecerá.
Liquidificador
O Blender é um conjunto de ferramentas de software de computação gráfica 3D gratuito e de código aberto usado para criar filmes animados, efeitos visuais, arte, modelos impressos em 3D, gráficos em movimento, aplicativos 3D interativos, realidade virtual e jogos de computador. O Blender é suportado pelo AWS Deadline Cloud (Deadline Cloud) com integração abrangente, incluindo remetentes, pacotes conda e um adaptador para aumentar o desempenho de renderização. Este guia fornece instruções passo a passo para usar o Deadline Cloud com o Blender para renderizar seus projetos mais rapidamente distribuindo as tarefas de renderização em várias máquinas.
Visão geral do suporte
O Blender é suportado pelos seguintes componentes:
-
Remetente: remetente integrado para envio direto de trabalhos do Blender com detecção automática de cenas e ativos.
-
Pacotes Conda: Deadline Cloud para instalação automática em frotas gerenciadas por serviços.
-
Adaptador: um programa em hosts de trabalho que mantém o aplicativo carregado entre as tarefas para acelerar a renderização e os relatórios do progresso da renderização.
-
Cross-platform compatibilidade: suporte do remetente para Windows, macOS e Linux com suporte de trabalho para Windows e Linux com mapeamento automático de caminhos.
Compatibilidade com a versão do Blender
A tabela a seguir mostra os níveis atuais de suporte para as versões do Blender:
| Versão principal | Suporte ao remetente | Suporte Conda | Mecanismos de render |
|---|---|---|---|
| 3.6 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 4.2 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 4.5 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 5,0 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
| 5.1 | Windows, macOS, Linux | Linux | Cycles, Eevee, Workbench |
Canal Deadline Cloud Conda
A tabela a seguir lista todos os pacotes conda aplicáveis ao Blender disponíveis para Service-managed frotas no canal conda deadline-cloud:
| SO | Pacote | Versão | Observações |
|---|---|---|---|
| Linux | liquidificador | 3.6 | Inclui todos os mecanismos de renderização integrados |
| Linux | liquidificador | 4.2 | Inclui todos os mecanismos de renderização integrados |
| Linux | liquidificador | 4.5 | Inclui todos os mecanismos de renderização integrados |
| Linux | liquidificador | 5,0 | Inclui todos os mecanismos de renderização integrados |
| Linux | liquidificador | 5.1 | Inclui todos os mecanismos de renderização integrados |
| Linux | blender-openjd | Inclui o adaptador Blender |
Introdução
Para usar o Blender com o Deadline Cloud:
-
Crie uma frota gerenciada por serviços e associe-a a uma fila. Sua fila deve ser configurada com um ambiente de fila que ofereça suporte ao canal conda deadline-cloud. Para obter mais informações, consulte Criação de um ambiente de fila.
-
Instale o monitor Deadline Cloud e o remetente do Blender na estação de trabalho do artista usando o monitor Deadline Cloud e os instaladores do remetente. Para obter mais informações, consulte Configure sua estação de trabalho.
-
Envie seu trabalho diretamente do Blender usando o remetente integrado à fila.
-
Monitore o trabalho e baixe a saída usando o monitor Deadline Cloud.
Instalação
Para instalar o remetente do Deadline Cloud for Blender, você precisa:
-
Uma estação de trabalho Windows, macOS ou Linux.
-
Blender 3.6 ou posterior.
Há três maneiras de instalar o Deadline Cloud para remetente do Blender:
-
Usando o instalador do Deadline Cloud Submitter (recomendado).
-
Instalando o remetente a partir do Blender.
Usando o instalador do Deadline Cloud Submitter
Você pode instalar o Deadline Cloud para remetente do Blender usando o instalador do remetente do Deadline Cloud.
Para instalar o remetente
-
Baixe o instalador do Deadline Cloud Submitter.
-
Execute o instalador.
-
Quando solicitado, selecione cada versão do Blender com a qual você deseja usar o remetente.
-
-
Inicie o Blender.
-
Verifique a instalação verificando no menu Render a opção Enviar para o Deadline Cloud.
Se o complemento não estiver disponível no menu Render, você precisará habilitá-lo manualmente.
Para ativar manualmente o complemento do remetente
-
No menu Editar, escolha Preferências...
-
Escolha Caminhos de arquivo na barra lateral esquerda.
-
Encontre a seção Diretórios de scripts e escolha +.
-
Em Nome, digite
python. -
Em Path, insira o caminho para o
pythondiretório na instalação do transmissor do Blender. -
Reinicie o Blender para que as alterações entrem em vigor.
Instalando o remetente a partir do Blender
nota
Esse recurso é experimental e está sujeito a alterações.
Você pode instalar e atualizar o remetente do Blender de dentro do Blender usando o recurso de extensão do Blender.
Para instalar o transmissor do Blender usando as extensões do Blender, você precisa:
-
Blender 4.2 ou posterior.
-
Uma estação de trabalho com acesso consistente à Internet.
Para adicionar o remetente do Blender como uma extensão
-
Abra o Blender.
-
No menu Editar, escolha Preferências...
-
Escolha Obter extensões na barra lateral esquerda.
-
Escolha Repositórios, +, Adicionar repositório remoto.
-
Para URL, insira
https://github.com/aws-deadline/deadline-cloud-for-blender/releases/latest/download/index.json. -
Selecione Verificar atualizações na inicialização e escolha Criar.
-
Na entrada Deadline Cloud, em Disponível, escolha Instalar.
O complemento agora está instalado. Você pode usar a nova opção Enviar para Deadline Cloud no menu Render.
Quando uma atualização está disponível, um botão Atualizar aparece ao lado da entrada Deadline Cloud na seção Obter extensões.
Usando o remetente do Blender
Para usar o Deadline Cloud para remetente do Blender, você precisa:
-
Um perfil para enviar ao Deadline Cloud com.
-
Uma fazenda e uma fila do Deadline Cloud para enviar.
Enviar uma tarefa
Para enviar um trabalho do Blender para o Deadline Cloud
-
Salve seu arquivo do Blender.
-
No menu Render, escolha Enviar para Deadline Cloud.
-
Você pode ver um pop-up para instalar as dependências da GUI. Escolha OK e aguarde até que a caixa de diálogo desapareça, depois escolha Enviar para o Deadline Cloud novamente.
-
-
Use as guias na caixa de diálogo para personalizar seu trabalho.
-
(Opcional) Para exportar os arquivos associados a um trabalho para seu diretório de histórico de trabalhos sem enviá-lo, escolha Exportar pacote.
-
Escolha Enviar e siga as instruções para enviar seu trabalho para o Deadline Cloud.
Blender-specific configurações
A guia de Job-specific configurações tem opções específicas para trabalhos criados no Blender.
-
Caminho do projeto - O local em que o projeto atual é salvo. Esse valor não pode ser alterado.
-
Diretório de saída - O local para salvar as saídas do arquivo do trabalho de renderização.
-
Prefixo do arquivo de saída - O padrão a ser usado ao nomear as saídas do arquivo segue a convenção do Blender para nomes de arquivos. Os arquivos de saída são formatados como
[LayerName]_[CameraName]_[OutputPrefix].[EXT]. -
Cena - A cena do projeto atual a ser renderizada.
-
Mecanismo de renderização - O mecanismo de renderização (Cycles, EEVEE ou Workbench) a ser usado.
-
Exibir camadas - A camada a ser renderizada ou “Todas as camadas renderizáveis” para renderizar cada camada aplicável na cena separadamente.
-
Câmeras - A câmera a ser renderizada, “Todas as câmeras renderizáveis” para renderizar cada câmera na cena separadamente ou “Usar câmera padrão” para usar a câmera padrão da cena ou câmeras vinculadas aos marcadores da linha do tempo.
-
Cicla a renderização da GPU - Se a renderização da GPU deve ser ativada. Escolha um tipo de dispositivo compatível com o Blender ou especifique o seu próprio. Se esse tipo de dispositivo não for suportado em sua máquina de renderização, o adaptador tentará usar um tipo de dispositivo compatível antes de voltar à renderização pela CPU.
-
Substituir intervalo de quadros - Selecione essa opção para renderizar um quadro ou intervalo de quadros diferente do definido no arquivo de cena. Os intervalos de quadros seguem o padrão
Open Job Description.
Para obter informações sobre as outras guias do remetente, consulte o guia do Deadline Cloud para usar um remetente.
Configurações avançadas
Usando versões não suportadas
O Deadline Cloud só suporta e testa as versões de software de estação de trabalho e de trabalho na tabela acima. Ao usar o remetente, o trabalhador tentará instalar a mesma versão usada na estação de trabalho. Essa instalação falhará se a versão da estação de trabalho do Blender não aparecer na tabela de versões acima.
Se você precisar de uma versão não suportada do Blender, você tem as seguintes opções:
-
Ao enviar o trabalho do Blender, você pode substituir o parâmetro CondaPackages queue para especificar uma versão compatível para usar no trabalhador (por exemplo,).
blender=4.5, blender-openjd=*Essa substituição pode ou não funcionar, dependendo dos recursos usados pela sua cena e de como o Blender funciona com cenas da sua versão da estação de trabalho. -
Você pode criar uma receita e um canal de conda personalizados para que a versão desejada seja instalada no trabalhador. Use a receita conda para uma versão compatível no link abaixo como ponto de partida e empacote a versão desejada em um canal conda personalizado. Para obter mais informações sobre como criar canais conda personalizados, consulte Criação de canais conda personalizados.
Complementos do Blender
Você pode disponibilizar complementos do Blender para trabalhadores de frotas gerenciados por serviços criando um pacote conda a partir de uma receita de conda e adicionando-o a um canal conda personalizado. Quando o ambiente conda é ativado em um trabalhador, o complemento é instalado por meio da API do Blender; quando ele é desativado, o complemento é removido. Para obter mais informações sobre canais conda personalizados, consulte Criação de canais conda personalizados.
As seguintes receitas de conda estão disponíveis como pontos de partida:
-
A receita adicional de conda FLIP Fluids inclui a versão demo do
complemento de simulação de líquidos FLIP Fluids. -
Pacote de complementos do Blender conda recipe
empacota vários complementos do Blender de um único arquivo para que eles sejam instalados juntos quando o ambiente conda for ativado.
Mecanismos de renderização
O Blender inclui vários mecanismos de renderização integrados que são suportados:
| mecanismo de renderização | Description | Suporte de GPU | Observações |
|---|---|---|---|
| Ciclos | Physically-based rastreador de caminho | GPU/CPU híbrido | Renderização de qualidade de produção com aceleração de GPU |
| Eevee | Real-time mecanismo de renderização | Otimizado para GPU | Janela de visualização rápida e renderização final |
| Workbench | Motor de sombreamento sólido | Otimizado para GPU | Para modelar e esculpir fluxos de trabalho |
Todos os mecanismos de renderização são detectados e configurados automaticamente pelo remetente integrado do Blender. A aceleração de GPU está disponível ao usar frotas gerenciadas por serviços com instâncias. GPU-enabled
Recursos de código aberto
O remetente e o adaptador são de código aberto e estão disponíveis em: GitHub
-
As receitas do Blender conda
estão disponíveis nas GitHub versões suportadas.